Question PC ne démarre pas à partir du CD-ROM


J'essaie d'installer Linux à partir d'un CD live (Elementary OS)

J'ai défini mon ordre de priorité de démarrage pour que CDROM soit le premier dans le BIOS.

Cependant, mon PC choisit toujours de charger mon disque SSD à la place.

Pour vérifier que le live CD fonctionne correctement, débranchez tous mes disques, SAUF mon lecteur de CD-ROM.

Avec cette configuration, le CD-ROM démarre et je suis capable de tester le système d’exploitation élémentaire.

Lors du branchement du SSD, le SSD est toujours chargé en premier.

J'ai vérifié mon BIOS au moins 3 fois et je m'assure que le CDROM est le premier à démarrer. J'ai également essayé de charger le CDROM via le sélecteur de démarrage après la publication (via f12). Pourtant, il charge le SSD à la place. Donc, je sais que mon CD live est bootable et fonctionne correctement.

C'est bizarre! Je sais que le live CD fonctionne et j'ai vérifié trois fois l’ordre de démarrage, mais il ne se chargera tout simplement pas si mon SSD est branché.

Informations supplémentaires pouvant aider

Sur le SSD, j'ai déjà une configuration dual boot avec Ubuntu et Windows 7. Je me demande si cela pourrait affecter l’ordre de démarrage. Je ne sais pas vraiment comment ....

Y a-t-il autre chose qui me manque? MBR peut-il en quelque sorte remplacer l'ordre de démarrage du BIOS?

Ma carte mère est un Gigabyte GA-970A-UD3

Mises à jour

  1. J'ai vérifié mon lecteur de CD-ROM pour un cavalier maître-esclave sur le dos. Il n'y a pas de cavaliers. Ceci est un disque SATA
  2. J'ai échangé les connecteurs SATA sur la carte mère pour que le CD-ROM soit branché sur le premier port SATA, toujours le disque dur au lieu du CD-ROM
  3. La version du BIOS est AMD ACHI version 3.07

2
2017-12-10 12:58


origine


Existe-t-il des paramètres de cavalier dans votre CD-ROM, tels que maître / esclave?. Si oui, essayez de modifier ce paramètre. - vembutech
Pas de cavalier, voir les mises à jour en question. - Lucas Scholten
Essayez de changer physiquement les câbles (cd et SSD) sur la carte mère (je veux dire débranchez le câble de cd et branchez-le sur SSD et vice versa) ... BTW quelle version de BIOS? - Hastur
@Hastur s'il vous plaît voir le message original. J'ai déjà essayé de permuter physiquement les câbles sur la carte mère afin que le CD-ROM soit maintenant branché là où le SSD était branché (port SATA 0) - Lucas Scholten
@Hastur La version du BIOS est AMD ACHI 3.07 - Lucas Scholten


Réponses:


Il semble que sur cette carte mère, il soit possible d’avoir les 4 premiers ports en mode AHCI et les 2 derniers en mode IDE.

J'avais tout exécuté sur AHCI à cause du SSD. Le lecteur de CD-ROM était également branché sur un port compatible ACHI, qui semblait fonctionner correctement pour tout, sauf dans le cas où il refusait de démarrer.

SOLUTION : Branchez le câble SATA CDROM dans un port SATA compatible IDE et voilà, il démarre maintenant comme il est censé le faire.


2
2017-12-10 16:45