Question Monter le disque dur externe avec les autorisations r / w pour minidlna


J'essaye de monter mon disque dur externe (NTFS) sur mon raspberry pi dans / home / pi / dd

Mais je voudrais avoir un accès r / w à tous les fichiers sur ce disque dur parce que je veux utiliser un de ses sous-dossiers avec minidlna: exemple sur /etc/minidlna.conf:

media_dir= /home/pi/dd/a_folder

En fait chown et chmod ne fonctionne pas après le montage ...

Exemple de ce que j'ai fait:

pi@raspberrypi - ~ sudo cat /etc/passwd
pi:x:1000:1000:,,,:/home/pi:/bin/bash
minidlna:x:107:110:MiniDLNA server,,,:/var/lib/minidlna:/usr/sbin/nologin

pi@raspberrypi - ~ sudo cat /etc/fstab
proc                    /proc           proc    defaults                                0       0
/dev/mmcblk0p5          /boot           vfat    defaults                                0       2
/dev/mmcblk0p6          /               ext4    defaults,noatime                        0       1
UUID=0A1C40D81C40C105   /home/pi/dd     ntfs-3g uid=1000,gid=1000                       0       2

pi@raspberrypi - ~ ll
total 12K
drwxr-xr-x 2 pi pi 4,0K janv. 30 10:18 backup_files
drwxr-xr-x 2 pi pi 4,0K janv. 30 10:17 dd
drwxr-xr-x 2 pi pi 4,0K déc.  24 12:34 Desktop

pi@raspberrypi - ~ sudo mount /dev/sda1

pi@raspberrypi - ~ ll
total 24K
drwxr-xr-x 2 pi   pi   4,0K janv. 30 10:18 backup_files
drwxrwx--- 1 root 1004  16K janv. 30 07:43 dd
drwxr-xr-x 2 pi   pi   4,0K déc.  24 12:34 Desktop

Nous pouvons voir la ligne:

drwxrwx--- 1 root 1004  16K janv. 30 07:43 dd

Cela (je pense) provoque l'échec du démarrage de minidlna:

pi@raspberrypi - ~ sudo service minidlna force-reload
[....] Restarting DLNA/UPnP-AV media server: minidlna[2015/01/30 10:57:31] minidlna.c:474: error: Media directory "/home/pi/dd/Downloads/Music" not accessible! [Permission denied]
[2015/01/30 10:57:31] minidlna.c:474: error: Media directory "/home/pi/dd/Downloads/Films" not accessible! [Permission denied]
. ok

Et quand je chmod ou chown dd folder, rien ne change le dossier propriétaire / droits ne changent pas ...

Je pense que je ne comprends pas très bien les options de montage ...

Merci de votre aide

EDIT: Voici le résultat de "sudo cat / proc / mounts"

pi@raspberrypi - ~ sudo cat /proc/mounts
rootfs / rootfs rw 0 0
/dev/root / ext4 rw,noatime,data=ordered 0 0
devtmpfs /dev devtmpfs rw,relatime,size=219744k,nr_inodes=54936,mode=755 0 0
tmpfs /run tmpfs rw,nosuid,noexec,relatime,size=44784k,mode=755 0 0
tmpfs /run/lock tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
tmpfs /run/shm tmpfs rw,nosuid,nodev,noexec,relatime,size=89560k 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
/dev/mmcblk0p5 /boot vfat rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro 0 0
/dev/sda1 /home/pi/dd fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096 0 0

EDIT 2: J'ai oublié de dire que je partage ce dossier / home / pi / dd avec samba, voici le fichier de configuration:

[global]
   workgroup = WORKGROUP
   server string = %h server
   netbios name = Naspi
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   security = user
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
   usershare allow guests = yes

[Nas]
   path =/home/pi/dd
   read only = no
   locking = no
   guest ok = yes
   force user = pi

2
2018-01-30 11:04


origine


Pouvez-vous poster la sortie de sudo cat /proc/mounts pendant que la partition est montée? - chaos
Oui, je viens de l'ajouter à mon message;) - Hilo


Réponses:


Le problème est que votre partition est montée via fusible. Ce n'est pas la même chose que de monter un système de fichiers natif.

Utilisez cette commande:

sudo mount -t ntfs-3g /dev/sda1 /home/pi/dd -o uid=1000,gid=1000

Cela devrait définir l'utilisateur et le groupe de la partition à pi.


2
2018-01-30 11:38



Cela fonctionne parfaitement :) (Si je remplace sda5 par sda1: p) Mais comment puis-je faire avec le fichier fstab? - Hilo