Question Comment empêcher Windows 10 de redémarrer l'ordinateur après l'installation des mises à jour


Cette question a déjà reçu une réponse, par ex. ici, mais toutes les réponses que j'ai vues nécessitent une liste déroulante dans Paramètres> Mise à jour et sécurité> Options avancées.

Sur ma version de Windows 10 Pro, il n'y a pas de liste déroulante:

Windows update advanced options

Comment puis-je empêcher les redémarrages automatiques?


78
2017-08-05 15:46


origine


Windows 10 version 1607 (version du système d'exploitation 14393.10) - Laurent
Oui, mais le problème avec la définition des heures "actives" est que si j'oublie de fermer Excel et de le laisser ouvert la nuit, Windows peut redémarrer pendant la nuit, ce qui me fait perdre des données non enregistrées. En outre, la durée maximale active est de 12 heures, ce qui suppose que tout le monde dort au moins 12 heures par jour ... - Laurent
@Laurent, lorsque la mise à jour des créateurs sera publiée le mois prochain, l'un des changements va augmenter le maximum Active Hours réglage que vous pouvez configurer à 18 heures. J'espère que vous en arrivez généralement à moins six heures de sommeil! - Run5k
C'est l'une des nombreuses tâches de Windows qui nous ralentit et entrave notre travail. Bien que nous utilisions encore un peu Windows dans nos activités (principalement dans WINE ou VirtualBox), nous sommes passés à Linux (RHEL, LM MATE 18.1 et Xubuntu 16.04). Les mises à jour Linux ne nous ralentissent pas et il est rarement nécessaire de redémarrer. - Mike Waters
Duplicata possible de Comment arrêter Windows 10 des redémarrages automatiques - Tomas


Réponses:


Définition du "Pas de redémarrage automatique avec les utilisateurs connectés pour les installations de mises à jour automatiques planifiées" Le GPO ne fonctionnait pas pour moi. Je me suis réveillé ce matin et ma machine a été redémarrée. (J'utilisais l'ordinateur la nuit dernière et je n'ai même pas reçu d'avertissement.)

Cette suggestion de techjourney.net semble plus prometteur.

  • Ouvrir Planificateur de tâches et naviguez jusqu'à Bibliothèque du Planificateur de tâches> Microsoft> Windows> UpdateOrchestrator
  • Clic droit sur le Redémarrer tâche et Désactiver il.

Windows tentera de réactiver la tâche automatiquement, vous devrez donc également modifier les autorisations du fichier de tâches.

  • Aller à C: \ Windows \ System32 \ Tâches \ Microsoft \ Windows \ UpdateOrchestrator
  • Ouvrez les propriétés du Redémarrer fichier, ouvrez l'onglet Sécurité et ouvrez les autorisations avancées.
  • Prenez possession du fichier en cliquant sur le lien "Modifier" à côté du propriétaire et en tapant votre nom. Désactivez l'héritage via le bouton en bas.

  • Modifiez toutes les autorisations pour lire ou lire et exécuter uniquement.


89
2017-09-16 12:57



Vous devez également définir la stratégie de groupe "Activer Windows UPM pour activer automatiquement le système pour installer les mises à jour planifiées" sur DISABLED. Si vous ne le faites pas, Windows démarrera parfois votre ordinateur lorsqu'il sera éteint (hibernation), installera des mises à jour et s'éteindra à nouveau, vous faisant ainsi perdre votre état de veille prolongée. Cela vous fait perdre toutes vos fenêtres ouvertes, ce qui est très pénible. - Steve
On dirait que les paramètres de sécurité avancés ont été désactivés dans la dernière version de Win 10 Pro 64 bits - veryRandomMe
Attention, la tâche doit être désactivée en premier, puis les autorisations de fichier doivent être définies. Si vous effectuez d'abord les autorisations de fichier, la tâche peut générer une erreur lors de la tentative de définition de l'état sur désactivé. - Mike Simpson
Autant que je sache, cela ne fonctionne plus. Windows ignore désormais les autorisations sur le fichier et retourne le "redémarrage" sur activé. Je ne pense pas qu’il existe actuellement un moyen d’empêcher Windows de redémarrer, ce qui est absolument ridicule. - dallin
@dallin Je suis étonné que vous ayez pu exprimer librement votre opinion sur Internet à propos de la gêne liée au redémarrage automatique sans que votre opinion ne soit dénaturée. Chanceux? - Mugen


Modifier:

Microsoft va publier un moyen de répéter les mises à jour. The Verge - Microsoft facilite l’arrêt de Windows 10 du redémarrage de votre PC pour des mises à jour

Je ne suis pas sûr si l'application de paramètres vous permet de le faire plus. J'ai regardé mais je ne trouve rien. Cette solution ci-dessous fonctionnera, peu importe si vous avez Windows 10 Pro.

Dans la boîte de dialogue d'exécution (winkey + R), tapez "gpedit.msc" (sans les guillemets), appuyez sur Entrée   Naviguez vers Configuration ordinateur / Modèles d'administration / Composants Windows / Windows Update   Double-cliquez sur "Pas de redémarrage automatique avec les utilisateurs connectés pour les installations de mises à jour automatiques planifiées"   Activez-le et cliquez sur Appliquer

Ref: Windows 10: désactiver le redémarrage automatique pour les mises à jour

Gpedit


9
2017-08-05 15:52



gpedit est uniquement pour les versions Pro et supérieures, Home ou inférieur ne possède pas gpedit - Moab
J'ai Pro alors j'ai pu le faire. Mais il était déjà activé (je l'ai activé il y a longtemps quand j'étais encore sous Windows 8). La nuit dernière, il a redémarré même si ce paramètre était activé. - Laurent
Cela ne fonctionne pas. Je l'ai activé, mais il redémarre toujours. La chose la plus ennuyeuse est qu’elle redémarre au cours de la semaine, pendant les heures de bureau, alors que de nombreuses applications sont ouvertes, les ferme avec force et je perds mon travail. A chaque fois. J'utilise Windows depuis la version 3.1 et je ne me préoccupais pas de leurs décisions douteuses concernant l'interface utilisateur, y compris la 8 Modern UI. Mais laissez-moi faire mon boulot sans interruption. Ironiquement, ils l'appellent Windows 10 "Pro". - Groo
Ne marche pas. (Windows 10 Version 1607 Build 14393.187) - user643011
Quelqu'un at-il lu le dernier paragraphe de cette option "cela ne fonctionne pas si la politique Configure Automatic Updates n'est pas actif "? Je suppose (mais je n'ai pas encore pu vérifier) ​​que cela ne fonctionne que si l'on active également cette politique. - Tobias Kienzler


Toutes les solutions de contournement proposées ne semblent pas fonctionner avec la mise à jour de l'anniversaire. Mais il y a toujours une option: Vous pouvez périodiquement mettre à jour les "heures actives" dans les paramètres. Cependant, ce n'est pas amusant à faire manuellement, mais il existe un petit service Windows qui peut le faire pour vous: https://www.udse.de/fr/windows-10-reboot-blocker


8
2017-11-05 14:12



La réponse acceptée semble toujours fonctionner pour moi ... Comme les mises à jour ne s’installent pas automatiquement, elles ne redémarrent pas. Toutefois, si je clique pour installer les mises à jour, il redémarrera plus tard sans demander, alors je m'assure de redémarrer correctement après avoir installé manuellement les mises à jour. - Laurent
C'est ridicule! Je ne peux pas croire que nous devons installer cela pour "réparer" quelque chose qui n'aurait pas dû être "cassé" en premier lieu! Tant pis pour être une version "pro" .... - tftd


Les deux autres solutions ne semblent pas fonctionner pour moi, car ces paramètres de registre étaient déjà définis sur mon ordinateur.

Voici une solution indirecte, qui consiste à demander à Windows Update de ne pas installer les mises à jour automatiquement, de les télécharger, puis de demander l’installation. L'utilisateur peut alors choisir quand les installer et redémarrer ensuite.

Accédez à la clé de registre suivante:    HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Mise à jour Windows \ Mise à jour automatique
  Met le AUOptions valeur à l'une des valeurs suivantes:

  1 = Ne jamais vérifier les mises à jour
  2 = Vérifiez les mises à jour mais laissez-moi choisir de les télécharger et de les installer
  3 = Télécharger les mises à jour mais laissez-moi choisir si vous souhaitez les installer
  4 = Installer les mises à jour automatiquement

Je le mets à 3.

La source: Forums Microsoft Technet: comment empêcher Windows 10 de redémarrer automatiquement, répondez par MaxBak83


4
2017-08-08 14:15



Oui, j'utilise cet outil pour rechercher manuellement des mises à jour: superuser.com/a/948069/174557 - magicandre1981
Non, cela ne fonctionne pas non plus. My Windows 10 Pro (avec ce paramètre défini sur 2, (après avoir supprimé le Windows/SoftwareDistribution dossier, réellement téléchargé les mises à jour, les a installées, puis redémarré, au milieu de mes heures de bureau, mercredi à 13h, avec plusieurs applications ouvertes, y compris un document Word non enregistré. Ensuite, il a procédé à l’installation de «l’édition Aniversary» pour les 30 minutes suivantes, a échoué, puis a automatiquement restauré ma version précédente. Cool, maintenant je peux attendre la prochaine tentative. Ne pas oublier de sauver chaque fois que je vais chercher une tasse de café. - Groo
Cela a fonctionné pour moi; maintenant je reçois un message disant Redémarrage requis et puis un plus inquiétant Nous allons redémarrer votre appareil en dehors des heures de bureau. Mais cela ne redémarre pas tout seul. Il y a un bouton pour Redémarrer maintenant. - jmgonet
Ne marche pas. (Windows 10 Version 1607 Build 14393.187) - user643011
n'est-ce pas HKLM \ SOFTWARE \ Les politiques \ Microsoft \ ...? En outre, cela semble confirmer mon commentaire que vous devez activer tous les deux politiques "Configurer les mises à jour automatiques" et "Pas de redémarrage automatique avec les utilisateurs connectés pour les installations de mises à jour automatiques planifiées" - Tobias Kienzler


Winaero.com a fourni un moyen pour le faire:

  • Ouvrez l'éditeur de registre.
  • Accédez à la clé de registre suivante: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU
  • Créez une nouvelle valeur DWORD nommée ici NoAutoRebootWithLoggedOnUsers et le mettre à 1 et redémarrez le périphérique.

enter image description here


2
2017-08-06 06:43



Je suis juste allé là-bas dans regedit et sur mon PC cette clé était déjà définie à 1. - Laurent
Mon ordinateur n'a pas WindowsUpdate - Richard
@Richard crée une clé avec ce nom si vous ne le trouvez pas - magicandre1981
Ne marche pas. (Windows 10 Version 1607 Build 14393.187) - user643011
Poursuivant la tendance des blogs technologiques à ne pas effectuer de recherches adéquates et à ne pas recouper suffisamment leurs réponses, le guide ne répertorie pas correctement les informations de bitness. La clé que vous avez publiée ne s'applique qu'aux machines 32 bits. J'ai également ajouté les informations pour les machines 64 bits. - seagull


Pour les ordinateurs dotés d'une stratégie de groupe, l'application de la stratégie Configuration utilisateur \ Modèles d'administration \ Composants Windows \ Windows Update \ Supprimer l'accès pour utiliser toutes les fonctionnalités Windows Update avec l'option Ne pas afficher les notifications empêchera complètement les redémarrages forcés. Windows Update sur Windows 10 restera toujours fonctionnel.

Les entrées de registre pour cette stratégie sont HKCU \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Policies \ WindowsUpdate Créez les clés: DisableWindowsUpdateAccess avec la valeur 1 DisableWindowsUpdateAccessMode avec la valeur 0

Cela empêchera la tâche du planificateur de tâches dans la réponse de JaredE de forcer également un redémarrage. Même l'exécution manuelle de cette tâche ne provoquera pas de redémarrage.


0
2018-01-16 20:11





Voici un fichier .zip contenant un fichier .reg qui DEVRAIT fonctionner même sous Windows 10 (même si je ne saurai pas avec certitude jusqu'à la prochaine fois que M $ pousse une mise à jour Win10 nécessitant un redémarrage):

http://www.geeksalive.com/NoAutoReboot_Win10.zip

Voici le contenu du fichier NoAutoReboot.reg, mais veillez à lire également le fichier 00ReadMe.txt.

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]
"NoAutoRebootWithLoggedOnUsers"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"NoAutoRebootWithLoggedOnUsers"=dword:00000001
"NoAutoUpdate"=dword:00000000
"AUOptions"=dword:00000004
"AutomaticMaintenanceEnabled"=dword:00000001
"ScheduledInstallDay"=dword:00000000
"ScheduledInstallTime"=dword:00000003
"AllowMUUpdateService"=dword:00000001

Notez que pour que cela soit efficace, vous devez soit redémarrer le service Windows Update, soit redémarrer l'ordinateur après avoir installé la mise à jour du registre.


0
2018-04-14 11:48





Réponse possible, toujours en phase de test mais semble fonctionner jusqu'à ce que MS modifie ces paramètres dans le Planificateur de tâches.

Sur un autre post, "Comment désactiver redémarrage automatique dans Windows 10? ", références jakethedog utilisant le Planificateur de tâches. J'ai développé les paramètres par éléments dans UpdateOchestrator.

Allez à Démarrer et entrez Planificateur de tâches. Aller à la bibliothèque du planificateur de tâches >> Microsoft >> Windows >> UpdateOrchestrator.

Vous trouverez ici des éléments qui peuvent être ajustés pour que les mises à jour se comportent différemment. Vous pouvez modifier différentes propriétés dans chaque élément en cliquant avec le bouton droit de la souris et en sélectionnant Propriétés.

Vous devriez voir six onglets. La plupart ont des paramètres qui peuvent être définis, désactivés ou supprimés. Utilisez l'onglet Historique sur chaque élément pour voir quand et ce qu'ils traitent. Ensuite, par onglet, effectuez les modifications souhaitées.

Jusqu'à présent, je n'ai désactivé et désactivé aucun paramètre. MS peut rajouter un paramètre supprimé lors de l'exécution des analyses de mise à jour, que ce soit manuellement ou automatiquement et remplacer les éléments manquants.

Sur chaque article que j'ai ajusté, j'ai changé les onglets suivants.

Onglet Général >> Options de sécurité. Modification du compte d'utilisateur contrôlant l'élément de System sur mon compte. Cela devrait aider le compte système à arrêter de modifier les modifications.

Déclencheurs >> Modifier >> Paramètres avancés. Commencez la tâche: sur un calendrier. Définissez la tâche de délai jusqu'à (délai aléatoire): jusqu'à 1 jour. Définissez la tâche d'arrêt si elle est supérieure à: 30 minutes. Définir expiration: le jour où vous apportez une modification à l'élément, 15 minutes plus tard que lorsque le changement est effectué et à synchroniser entre les fuseaux horaires. Désactivé Activer.

Actions >> Modifier. Renommez l'entrée Programme / script. Ici, j'ai juste changé MusNotification.exe à MNcation.exe et supprimé l'option Ajouter des arguments de Reboot. Cela peut s'ajouter à l'observateur d'événements, je n'ai pas vérifié pour voir.

Conditions >> Puissance. Décochez les deux entrées.

Paramètres. Définissez les paramètres suivants.

enter image description here

Sélectionnez ensuite OK pour fermer la fenêtre Propriétés, puis cliquez avec le bouton droit de la souris et désactivez l'élément par élément que vous ajustez. Puis redémarrez.


-1
2017-12-15 17:57



Vous devez éditer cette réponse après avoir vérifié qu'il s'agit d'une réponse réelle. La revue. Pourquoi soumettez-vous des réponses identiques à des questions au lieu de signaler l'une des questions en double? - Ramhound