Question autorisation de lecture et d'écriture pour la partition FAT32 dans Ubuntu


C'est un problème étrange. J'ai la table de partition suivante

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13        5737    45978624    7  HPFS/NTFS
/dev/sda3            5738       10600    39062047+  83  Linux
/dev/sda4           10601       19457    71143852+   5  Extended
/dev/sda5           10601       11208     4883728+  82  Linux swap / Solaris
/dev/sda6           11209       15033    30720000    b  W95 FAT32
/dev/sda7           15033       19457    35537920    7  HPFS/NTFS

Je double boot Win7 (sda2) et Ubuntu (sda3) et je voulais utiliser la partition FAT23 pour partager des fichiers entre deux systèmes d'exploitation.

J'ai suivi un didacticiel en ligne et j'ai fait ceci:

sudo mkdir /media/FAT32
sudo chmod 777 /media/FAT32
sudo mount /dev/sda6/ /media/FAT32

Après avoir monté le fichier, je ne peux que lire mais je ne peux pas y écrire.

J'ai vérifié l'autorisation de fichier, il devient:

drwxr-xr-x

mais après je l'ai démonté, il devient alors

drwxrwxrwx

et je peux lire et écrire.

très étrange.

Je ne sais pas où je me suis trompé.

À votre santé.


15
2017-12-05 15:36


origine




Réponses:


Essayez de monter avec rw et spécifiez le type:

mount -t vfat /dev/sda6 /media/FAT32 -o rw,uid=xxx,gid=xxx

où uid et gid sont ceux de votre compte utilisateur.


16
2017-12-07 15:32



L'umask a un effet lors de la création de nouveaux fichiers. - geek
user et auto sont des options pour le fstab entrée; ils ne sont pas très utiles sur la ligne de commande. - quack quixote
ouais je viens de traduire une de mes entrées fstab en ligne de commande. Resté dans quelques bits qui ne sont pas utiles, mais ils ne sont pas exactement nuisibles non plus. - John T
sudo mount -t vfat /dev/sda6 /media/FAT32 -o rw,uid=$(id -u),gid=$(id -g) - chefarov


Pour les systèmes de fichiers FAT, la disponibilité en lecture / écriture est régie par les options de montage.

Consultez la page de manuel pour monter et lire sur uid et gid options de montage pour FAT.


1
2017-12-07 14:48





Avez-vous essayé d'écrire dans les fichiers avec un sudo commander? Cette devrait travailler avec votre configuration actuelle.

Pour obtenir des écritures de fichiers pour votre utilisateur normal, vous devez utiliser le uid et gid options à mount, pour définir le propriétaire des fichiers de la partition sur votre identifiant utilisateur actuel. Vous voulez probablement aussi umask ou dmask et fmask options

Votre mount commande ressemblerait à ceci:

sudo mount -t vfat /dev/sda6 /media/FAT32 -o uid=1000,gid=1000,umask=022
# assuming your user's UID is 1000, GID is 1000
# umask=022 sets permission mode 755 for all files on the partition

1
2017-12-07 19:00





Vous avez le mauvais ordre sur les commandes que vous voulez:

sudo mkdir /media/FAT32
sudo mount /dev/sda6 /media/FAT32
sudo chmod 777 /media/FAT32

Ce qui se passe est que / media / FAT32 représente différents répertoires avant et après le montage. Avant c'est le répertoire que vous avez fait, et que vous avez chmodé 777. Après, c'est le répertoire racine du système de fichiers dans / dev / sda6.


1
2018-05-15 20:51





Si vous oubliez simplement la ligne de commande et montez avec Nautilus, il devrait le définir comme vous le souhaitez.

À partir du terminal, les autorisations du dossier avant le montage sont sans importance. Ce sont les options de montage qui comptent. Essayer:

mount -t vfat /dev/sda6 /media/FAT32 -o rw,uid=xxx,gid=xxx,umask=133,dmask=022

Cela va définir les fichiers à rw-r--r-- et des dossiers à rwxr-xr-x.

Si vous voulez d’autres utilisateurs / groupes et autorisations, par exemple pour copier des fichiers de fat32 vers la partition ext4 avec les attributs désirés, mieux consulter le mount page de manuel. En gros, vous mettez umask le contraire de ce que vous mettriez chmod.


1
2017-08-18 12:44





Parfois, j'ai perdu le disque Windows de Linux et j'ai résolu en utilisant mount avec "-o force", comme dans cet exemple:

sudo mount -t ntfs-3g /dev/sda1 /media/win -o force

Dans votre cas, être FAT32, vous devriez lire, mais mon aide sera utile. Quoi qu’il en soit, essayez à vos risques et périls!


0
2017-12-05 15:47





J'ai eu exactement le même problème et la seule chose qui a fonctionné est:

sudo mount -t vfat  /dev/sda6 /media/FAT32 -o rw,umask=0000

Voir également cette réponse


0
2017-12-17 08:19



Je l'ai fait, la clé USB est toujours protégée en écriture - Eildosa
As-tu essayé chmod 777 /media/FAT32 ? - lauhub
pour une raison quelconque, supprimer ", umask = 0000" a fonctionné - Eildosa


Sans montage manuel, une ligne fstab fait l'affaire,

UUID = 1DD9-0D44 / media / exthd / TERABYTE_G vfat rw, noatime, uid = 1000, gid = 1000, utilisateur 0 0

(uid, gid sont de votre utilisateur, / media / exthd / TERABYTE_G doit être pré-créé)

mais notez que mount -a ne semble pas appliquer correctement pour tester la nouvelle ligne fstab, donc un redémarrage complet aide.


0
2018-02-11 13:03





Réparation / vérification très importante du disque sous Windows avant de l'utiliser sur Linux, par défaut les pilotes fat / ntfs désactivent l'écriture s'ils trouvent des erreurs sur le disque

chkdsk d: /f 

alors

sudo mount -t vfat /dev/sdc1 /media/FAT32 -o rw,uid=$(id -u),gid=$(id -g)

comme indiqué avant


0
2017-07-16 02:17