Question Pourquoi Virtual Box ne me donnera pas la possibilité de créer des invités 64 bits?


Mon hôte est Windows 8.1 64 bits.

J'ai téléchargé la dernière Virtual Box (4.3) et j'essaie de créer une VM avec un système d'exploitation Ubuntu 64 bits (Ubuntu-12.04.3-desktop-amd64).

Quand je vais à l'assistant New VM, cela ne me donne pas la possibilité de sélectionner "Ubuntu (x64)" comme je l'ai vu dans les captures d'écran d'autres personnes, seulement juste "Ubuntu". En conséquence, l'ISO ne peut pas démarrer. J'ai essayé sur un autre PC et Virtual Box donne les variantes x64 à la plupart des systèmes d'exploitation listés ...

Le panneau de configuration affiche le système d'exploitation x64, processeur x64. Mon ordinateur portable hôte est un processeur Sony Vaio VPCZ22UGX / N, Intel Core i7-2640M. CPUz montre que Vx-t est disponible sur mon processeur, bien sûr.

Voici ce que j'ai essayé jusqu'ici:

  • J'ai activé IO APIC comme requis dans les documents.

  • J'ai la virtualisation activée dans le BIOS. Cela fonctionne bien dans VMware.

  • Vérifiez que Hyper-V n'est pas en cours d'exécution ou même installé sur Windows. Idem pour VMware.

  • J'ai aussi essayé d'exécuter la commande:

    VBoxManage modifyvm [vmname] --longmode on

pour cette VM, mais pas de changement .. Je pense que le problème est vraiment que je ne peux pas sélectionner la variante x64 du système d'exploitation Ubuntu pour cette VM. D'autres personnes semblent indiquer que c'est une exigence, mais je n'obtiens pas cette option pour une raison quelconque.

J'ai passé beaucoup de temps et je ne trouve pas ce qui ne va pas ... Quelqu'un sait-il ce qui pourrait manquer ici?

Merci beaucoup!!

Eduardo


82
2017-10-31 18:57


origine


Que se passe-t-il si vous créez une machine Ubuntu (x84), puis accédez à ses paramètres, sa page de base et examinez les options? - JohnLBevan
D'après ce que vous avez tenté jusqu'à présent, je soupçonne que vous avez vu cela, mais au cas où: forums.virtualbox.org/viewtopic.php?f=6&t=57926 - JohnLBevan
@JohnLBevan Je ne reçois que les options x86 .. ne peut pas le changer en x64. Je pense que vous avez raison, je frappe ce problème .. sauf que le gars a résolu le problème en désactivant hyper-v et je ne l'ai pas désinstallé. - Edy Bourne
Regardez ce post: superuser.com/questions/367290/ - ordinateur différent, mais éventuellement solution similaire? - JohnLBevan
Bonjour @JohnLBevan, merci pour votre réponse! Malheureusement, j'ai déjà activé VT-x dans le BIOS, sans changement. Je pense revenir à VMware et réessayer avec une nouvelle version de VirtualBox dans le futur. - Edy Bourne


Réponses:


J'ai rencontré le même problème.

Désactiver Hyper-v a temporairement résolu mon problème et toutes les options 64 bits étaient disponibles:

J'utilise hyper-v sur mon ordinateur portable. Quand je sais que je n'ai pas besoin de VM pour la journée,   Je peux tirer un peu plus de performance de la machine en tournant   hyper-v off avec:

bcdedit / set off hypervisorlaunchtype

et un redémarrage. Pour le réactiver:

bcdedit / set hypervisorlaunchtype on (ou démarrage automatique)

et redémarrer.

La source


45
2018-05-10 17:05



Cela m'a aidé aussi. Citation: "J'utilise hyper-v sur mon ordinateur portable. Quand je sais que je n'ai pas besoin de machines virtuelles pour la journée, je peux améliorer un peu la performance en désactivant hyper-v avec: bcdedit / set hypervisorlaunchtype off et un redémarrage. Pour le réactiver: bcdedit / set hypervisorlaunchtype on (ou auto start) et redémarrer. " - derFunk
Y a-t-il une solution sans redémarrage? - AlikElzin-kilaka
Bizarre, Hyper-V est désactivé dans le BIOS. Mais de toute façon cette option a fonctionné pour moi sur Windows 8.1 - spankmaster79
n'a pas fonctionné pour moi. exécutant Windows 8.1 Quoi de plus je ne peux pas le mettre en marche après je l'ai éteint. J'obtiens "Les données entières ne sont pas valides comme spécifié. Exécutez" bcdedit /? "Pour une assistance en ligne de commande. Le paramètre est incorrect." - Xitcod13
Cela signifie que nous ne pouvons pas utiliser Windows Phone Emulator à vie! :( utiliser OS invité virtuel de 64 bits? - Milson


J'ai eu le même problème (matériel compatible, options activées - aucun moyen de créer une machine virtuelle 64 bits), et j'ai abandonné VirtualBox et j'ai essayé VMware Workstation. Heureusement, j'ai eu une erreur similaire mais explicite me demandant de désinstaller Hyper-V. Désactiver ce n'est pas suffisant, vous devez supprimer le composant de votre système. Cet article m'a été utile: Désinstallation de HyperV à partir de Windows 8

Pour supprimer le composant, lancez simplement cette commande depuis et admin cmd (crédits sur @ levi-botelho):

Dism /online /disable-feature /featurename:Microsoft-Hyper-V

16
2018-06-26 18:46



Je ne suis pas sûr de savoir ce qu’Hyper-V a à faire avec elle, ni pourquoi il a été activé, mais le désactiver a été corrigé pour moi. Il existe maintenant des options 64 bits pour les systèmes d'exploitation invités. - ub3rst4r
excellent! enfin trouvé la solution. Je ne me souvenais pas d'avoir activé Hyper-V et je ne sais absolument pas que cela aurait masqué les options 64 bits sur virtualbox. - George
Supprimer HyperV vient de résoudre ce problème, bien que je l'a retiré du panneau de contrôle. Je ne l'ai pas activé, je suppose que certains outils, pilotes ou mises à jour Windows ont fait. J'ai déjà fait 64x machines, elles ne fonctionneraient pas tant que je ne me serais pas débarrassé d'HyperV. - Theraot
Cette solution a fonctionné pour moi après 3 jours de frustration. Merci beaucoup. - Jdbaba


VT-x / AMD-v les processeurs sont la voie à suivre.

Voir ce post pour plus de détails.

J'ai réussi activé cette capacité dans mon Thinkpad T420.


14
2017-11-29 08:09



Merci pour votre réponse. J'ai un processeur Intel® Core i7-2640M. CPUz montre que Vx-t est disponible sur mon processeur ... le mystère continue ... hé hé, je suis de retour avec VMware, mais je vais passer à Virtual box si une solution est trouvée. - Edy Bourne
@EduardoBorn Vous pourriez avoir besoin de vérifier les options dans le BIOS. J'ai activé cette fonctionnalité matérielle via le BIOS. - Kane
Pour moi, la clé pour faire apparaître ces options 64 bits et fonctionner était d'activer Config -> CPU -> "Intel (R) Virtualization Technology" et "Intel (R) Vt-d Feature" du BIOS. Après que les options sont apparues, pas besoin de réinstaller VirtualBox. - eis
Ce qui VT-x/AMD-v cpus? Où puis-je le trouver? - AlikElzin-kilaka
Si cette réponse disait de permettre la visualisation dans le bios, cela a fonctionné pour moi. L'option bios était VTx. - AlikElzin-kilaka


Le paramètre VT-x étant généralement verrouillé à la mise sous tension, il est nécessaire de mettre le système complètement hors tension après avoir modifié les options VT-x du micrologiciel (BIOS / EFI). Un simple redémarrage n'est pas suffisant!

Il peut être lié uniquement aux processeurs Intel


4
2017-10-03 10:54





J'ai eu un problème similaire. Publiez VT-x dans votre BIOS et redémarrez, pouvez-vous essayer de réinstaller VirtualBox? Pour une raison quelconque, l'option 64 bits ne s'affiche pas, sauf si vous réinstallez VirtualBox. Je l'ai fait et cela a résolu le problème pour moi.


3
2018-02-25 05:57



aucun résultat avec la réinstallation après la désactivation de Hyper-V - Xitcod13


J'ai eu exactement le même problème; Hyper-V désinstallé, la virtualisation BIOS / UEFI activée, a tenté de forcer l'activation de la machine virtuelle.

Au final, la solution était assez simple:

Lorsque vous installez VirtualBox avec tous les paramètres corrects, cela indique que seuls les invités 32 bits sont disponibles comme auparavant. Cependant, si vous redémarrez votre ordinateur et essayez de charger à nouveau VirtualBox (pour moi, il a planté deux fois avant de charger correctement), les options 64 bits apparaissent de nulle part.


1
2017-07-25 18:14





La solution pour moi était de mettre à jour mon bios. Même si mon bios 2012 avait l'option de virtualisation Intel, cela n'a pas fonctionné pour moi. Je suppose que c'était un décalage entre mes bios et mes drivers Windows. Clignotant au bios 2014 a résolu le problème pour moi. Maintenant, j'ai des options x64 dans mon boîtier virtuel.


0
2017-09-14 20:31



Ce n'est vraiment pas une réponse à la question de l'auteur - Ramhound
C'est une solution potentielle pour toute personne rencontrant le problème de vt-x ne fonctionnant pas et ne disposant pas des options x64. Donc, merci pour la haine @ramhound. - Rafe
Ce n'est pas personnel. Votre question était dans la revue en raison de la faible qualité. - Ramhound


Je n'avais pas réalisé que les étapes pour accéder au BIOS avaient changé dans Windows 8.1, mais c'est le lien le plus utile pour ce problème!: http://www.makeuseof.com/tag/how-to-access-the-bios-on-a-windows-8-computer/

Une fois que vous entrez dans le BIOS en suivant les étapes du lien ci-dessus, activez "SVM" et vous devriez être prêt!


0
2017-10-02 21:56



Comment cette réponse s'applique-t-elle à la question? - Wes Sayeed


Après avoir suivi les étapes recommandées par la plupart des autres, je ne pouvais toujours pas avancer. ce qui l'a fait pour moi était de désactiver l'antivirus (dans mon cas Avast). Redémarrage de Virtualbox et le tour est joué!


0
2017-08-15 16:29