Question Comment puis-je obtenir le support Java sur Google Chrome sous Linux?


Existe-t-il un moyen d’exécuter Linux Google Chrome avec le support Java?


85


origine


Note du Modérateur: J'ai supprimé les réponses qui sont maintenant obsolètes, depuis Chrome 35 a abandonné le support NPAPI et les méthodes affichées ici tout ne va pas marcher. En règle générale, nous ne supprimons pas les anciennes réponses au cas où les utilisateurs voudraient toujours utiliser d’anciennes versions stables du logiciel, mais avec Chrome, ce n’est pas vraiment faisable ni pratique. Dans l'attente de réponses qui tiennent compte de la dernière version, ce qui rend ce wiki de communauté pour encourager les efforts conjoints. - slhck
Question connexe sur Ask Ubuntu: askubuntu.com/questions/470594/ - slhck
Afaik et aussi selon productforums.google.com/forum/#!topic/chrome/qPiZkcLwFFk Il n'y a aucun moyen de supporter Java sur les récentes versions de Google Chrome pour Linux. Alors, passez à Firefox ou utilisez - avec soin - une version plus ancienne de Chrome. - lmedinas
Les informations sur java.com/en/download/faq/chrome.xml est un peu déroutant, mais il semble suggérer que vous avez besoin de Chrome 64 bits et de Java 7 bits pour exécuter Java sous Linux. (Il prétend que Chrome n’a pas de version Linux 64 bits, mais c'est faux). - trlkly
Une autre chose que je n'ai pas testée, donc je ne vais pas l'utiliser comme réponse: que se passe-t-il si vous lancez Chrome dans Wine? Le plug-in Windows Java 7 fonctionne-t-il là? Si tel est le cas, il existe des projets pour obtenir des plug-ins qui fonctionnent dans Windows pour fonctionner dans les navigateurs Linux. L'un est utilisé pour faire fonctionner Netflix, par exemple. (Ceci est principalement une suggestion pour aider les gens à trouver une réponse.) - trlkly


Réponses:


Il y a un gars (Michael Müller) qui a écrit des correctifs pour réactiver le support de NPAPI (donc icedtea fonctionnera).

C'est un peu une solution de contournement. mais devrait travailler. (En fait je n'ai pas testé)

Actuellement, la version de compilation est 36.

Si vous utilisez ArchLinux, vous pouvez le construire et l'installer depuis AUR. chrome-npapi

Sinon, vous pouvez voir dans PKGBUILD le processus de construction.


1





essayez d'installer icedtea sous linux. il fonctionne comme un charme.

pour Ubuntu

apt-get install icedtea


-3



Est-ce que cela fonctionne sur Chrome 35 ou plus récent? - Journeyman Geek♦
cela ne fonctionne pas. ref: superuser.com/questions/44827/ - Sathya♦