Question Comment empêcher Windows 10 de se réveiller en voyage en sac?


Je ne suis pas en train d'éteindre mon ordinateur portable, mais plutôt de le mettre en veille prolongée car il démarre beaucoup plus rapidement et je peux continuer à travailler sans redémarrer toutes les applications.

Il fonctionnait longtemps de Windows XP à Windows 8.1.

Cependant, maintenant (après la mise à niveau vers Windows 10), quand je sors mon portable du sac après un voyage, il fait très chaud. J'ai réalisé qu'il est allumé.

Dans le journal des événements, j'ai constaté qu'il installait des mises à jour et avant cela, il y avait le journal suivant:

Le système est revenu d'un état de faible consommation.

Heure du sommeil: 2015 - 08 - 16T12: 55: 18.180075900Z Heure de réveil:   2015 - 08 - 16T12: 55: 17.852758500Z

Wake Source: Inconnu, mais peut-être à cause du minuteur - Windows   exécuter 'NT TASK \ Microsoft \ Windows \ UpdateOrchestrator \ Reboot'   tâche planifiée qui a demandé de réveiller l'ordinateur.

Lorsque j'ai localisé la tâche ci-dessus dans le planificateur de tâches, elle se déclenche à ce moment-là, mais la "dernière exécution" a eu lieu la veille. Donc, je ne sais pas quoi croire "dernière exécution" ou la source de l'épreuve ci-dessus?

Comment savoir ce qui réveille l'ordinateur de l'hibernation (c'est possible?) Et comment le prévenir?


85
2017-08-16 16:19


origine


J'ai trouvé une page qui oblige Windows à ne pas changer le redémarrage superuser.com/questions/973009/...


Réponses:


Cela a fonctionné pour moi jusqu'à présent. Aller à:

Panneau de configuration \ Matériel et audio \ Options d'alimentation \ Modifier les paramètres du plan

Cliquez sur "Modifier les paramètres d'alimentation avancés"

Allez dans "Veille-> Autoriser les minuteries" et modifiez le paramètre sur Désactiver.

power options screenshot 1

METTRE À JOUR: Comme Erik l'a souligné, il peut y avoir deux options:

power options screenshot 2 with 2 options

Désactivez les deux.


66
2017-08-22 08:42



Ne fonctionnait pas pour moi, c'était déjà désactivé, et la mise à jour de Windows a de toute façon réveillé mon PC - Erik
Utilisez "powercfg -waketimers" pour vérifier la présence d'autres horloges de réveil. Certaines versions de Spotify et TeamViewer sont également censées créer des minuteries. Cependant, j’ai aussi des problèmes avec Windows 10 en ignorant les minuteurs de réveil désactivés. - voldemarz
Pour ceux qui lisent ceci, Spotify a corrigé le bogue qui l'a fait créer des réveils il y a quelques semaines. - Godsmith
@Dan: Merci, mais je préfère ne pas réorganiser ma vie en fonction de l'incompétence de MS. ; -) - Nick Westgate
@Dan: Je m'éloigne de mon ordinateur pendant quelques jours et j'ai parfois besoin d'accéder à mon ordinateur à distance. S'il est en état de veille, je peux envoyer un paquet WOL, le réveiller et le mettre en veille une fois terminé. Cependant, je ne veux pas qu’il soit réveillé par Windows Update et gaspille de l’énergie pendant des jours. - user33339


Sur WIN 10, il existe une option dans l'éditeur de stratégie de groupe local pour le configurer facilement:

  1. Chercher:  Local Group Policy Editor (vous pouvez lancer gpedit.msc)
  2. Aller vers:  Computer Configuration / Administrative Templates / Windows Components / Windows Update
  3. Double-cliquez sur:  Enabling Windows Update Power Management to automatically wake up the system to install scheduled updates et réglez-le sur "Disabled".

Figure pour le paramètre Éditeur de stratégie de groupe local:

enter image description here


56
2017-12-17 06:27



IMO c'est la bonne solution. Désactiver complètement les minuteries n'est pas toujours souhaité. - JeffRSon
+1, mais je ne veux pas qu'il se réveille (la nuit) pour une raison quelconque! Il existe un nouveau paramètre pour Autoriser les minuteurs de réveil: Minuteries de réveil importantes uniquement. Aucune idée de ce que ça fait. Espérons que MS se réveillera et nous permettra de spécifier la plage horaire pendant laquelle les réveils sont autorisés. Oh, et Windows 10 Home utilisateurs n'ont pas gpedit mais apparemment peut utiliser un hack de registre. - Nick Westgate
J'ai désactivé la politique, mais la tâche Windows était toujours enregistrée (cochée avec "powercfg -waketimers"). Doit aller et désactiver manuellement la tâche Windows comme indiqué dans superuser.com/a/958264/267379 pour le faire fonctionner. Espérons que la combinaison des deux fonctionnera: D - Sean Feldman
Je ne peux pas confirmer que cette politique fonctionne. J'avais déjà désactivé cette stratégie depuis des semaines, et hier soir, la tâche "UpdateOrchestrator \ Reboot" réveillait l'ordinateur. - Thorsten Albrecht
@ThorstenAlbrecht Même ici. J'utilise Windows 10 Pro v1703 64 bits (version 15063.540) et le UpdateOrchestrator\Reboot  tâche planifiée a repris de l'hibernation ce matin même si j'ai cette stratégie définie sur Disabled. En fait, je suis surpris que les paramètres de la stratégie de groupe locale n'aient pas été ébranlés par la mise à jour du créateur, comme la plupart des choses. Au minimum, je vais essayer de désactiver et de réinitialiser cette politique et voir si cela a un effet. - BACON


Après la mise à niveau vers Windows 10, l’ordinateur de ma chambre me réveille à 3 heures du matin. Désactivation Wake the computer sur le Microsoft\Windows\UpdateOrchestrator\Reboot tâche planifiée n'a pas aidé. Windows rétablit périodiquement l'indicateur. Même la désactivation de «Désactiver les minuteries» dans Options d'alimentation n'a pas aidé. UpdateOrchestrator continuait d'orchestrer les alarmes de minuit.

En tant que solution, j'ai ajouté un script powershell qui supprime les paramètres de réveil toutes les heures.

  1. Pour autoriser l'exécution de scripts Powershell: exécutez Powershell en tant qu'administrateur et exécutez:

    Set-ExecutionPolicy RemoteSigned

  2. Créez un fichier appelé "disable_wakejobs.ps1" qui contient une ligne de code:

    Get-ScheduledTask | ? {$_.Settings.WakeToRun -eq $true -and $_.State -ne "Disabled"} | % {$_.Settings.WakeToRun = $false; Set-ScheduledTask $_}

  3. Ouvrez le Planificateur de tâches et créez une tâche planifiée.

  4. Dans l'onglet "Général", définissez le compte d'utilisateur sur "SYSTÈME" (ou vous devrez mettre à jour un mot de passe enregistré chaque fois que vous modifiez votre propre mot de passe).
  5. Dans l'onglet "Déclencheurs", créez un déclencheur qui exécute le travail quotidiennement et répète toutes les heures.
  6. Dans l'onglet "Actions", créez une action pour "Démarrer un programme", avec "Programme / script" défini sur "PowerShell.exe" et les arguments -Command "c:\tools\disable_wakejobs.ps1" (changer le chemin d'accès à l'endroit où vous avez stocké disable_wakejobs.ps1 à l'étape 2.)

Les commandes PowerShell proviennent de cet article par Reidar Johansen.


30
2017-08-20 05:20



J'ai une erreur en cours d'exécution: Set-ScheduledTask: le paramètre est incorrect. At C: \ Users \ Filip \ scripts \ désactiver_wakejobs.ps1: 1 caractère: 123 + ... Désactivé "} |% {$ _. Settings.WakeToRun = $ false; Set-ScheduledTask $ _} + ~~~~~ ~~~~~~~~~~~~~~~ + CategoryInfo: InvalidArgument: (PS_ScheduledTask: Root / Microsoft / ... S_ScheduledTask) [Set-ScheduledTask], CimException + FullyQualifiedErrorId: HRESULT 0x80070057, Set-ScheduledTask - Godsmith
Aucune des autres solutions n'a fonctionné pour moi, alors j'espère que cela fera l'affaire! Hacky, mais quoi que je puisse faire pour que mon PC ne s'allume pas au milieu de la nuit, je le ferai. - GotDibbs
Comment est-ce fou? Vous ne pouvez même plus compter sur les paramètres et ils ont été réinstallés. Microsoft est-il hors de leur esprit? C'est totalement non fiable. - t3chb0t
Je ne vois aucun moyen de définir le compte d'utilisateur à l'utilisateur "SYSTEM" à l'étape 4. - Castaa
@ Castaa- bit plus tard, mais vous le modifiez en sélectionnant Changer d'utilisateur ou de groupe, puis en tapant System puis appuyez sur check name. Le résultat final devrait ressembler à ceci: puu.sh/mOIX4/58082e816e.png - Paul


Cela devrait résoudre votre problème:

  1. Chercher Task Scheduler
  2. Aller vers Task Scheduler Library\Microsoft\Windows\UpdateOrchestrator\Reboot
    Remarque:  Reboot est juste un fichier, mais vous devez aller dans tous ces dossiers
  3. Clic-droit Propriétés puis clique Conditions
  4. Décocher Wake the computer to run this task

6
2017-08-16 23:41



J'ai changé cela, espérons que cela ne fonctionnera plus. - TN.
Ce n'est pas la solution. Windows réactivera la case à nouveau la prochaine fois :-( - kipusoep
Je l'ai fait, mais Windows a réactivé le drapeau. Windows ignore même le paramètre "Désactiver les minuteries". Voici un article de blog qui montre comment décocher le "réveiller l'ordinateur" d'une tâche planifiée. - Andomar
Oui, la case à cocher est activée à nouveau ... - TN.
Non seulement WIndows réinitialise cette option, mais il ne parvient même pas à la saisir pour que l’utilisateur sache pourquoi l’ordinateur a redémarré: lorsque je demande la raison à powercfg, il est dit «inconnu»: devrait corriger cela dès que possible, il m'a fallu des heures pour découvrir ce qui continuait à réveiller mon système. En outre, le redémarrage était totalement inutile, parce que je l'ai déjà fait juste après la mise à jour, mais Microsoft a quand même décidé de redémarrer :( - Erik


J'utilise la fonction Wake On LAN (WOL) sur mon ordinateur pour que je puisse réveiller mon ordinateur à distance si je dois y accéder pendant mon absence. Pour que WOL fonctionne, je dois autoriser ma carte réseau à réveiller l'ordinateur lorsque j'envoie le paquet magique WOL.

Cela provoque en quelque sorte mon ordinateur à se réveiller au hasard sans raison apparente. Pour savoir si cela provoque un réveil aléatoire de votre ordinateur, tapez cette commande dans l'invite de commande:

powercfg -lastwake

enter image description here

Si vous voyez quelque chose à propos de votre carte réseau (à partir de mon Realtek PCIe) .. alors vous devez aller dans les paramètres de votre carte réseau et assurez-vous que le Only allow a magic packet to wake the computer la case à cocher est cochée (la mienne ne l'était pas):

enter image description here

Alors prie ton Dieu ...


4
2018-01-16 05:57



C'est le seul qui a fonctionné pour moi: D - Jamie Hutber
C'est une bonne solution à une autre question. La question identifie "TASK \ Microsoft \ Windows \ UpdateOrchestrator \ Reboot" dans Windows 10 comme étant la cause. WOL est difficile à configurer correctement, alors j'espère que cela aidera les autres aussi. - user33339


Cela semble être la tâche de maintenance du système en cours d'exécution. Si c'est le cas, vous pouvez essayer de désactiver la maintenance du système.

Contrôle WIN + R rechercher "maintenance" dans la zone de recherche, sélectionnez "Modifier les paramètres de maintenance automatique".

Désactivez l'option "Autoriser la maintenance programmée pour réactiver mon ordinateur à l'heure prévue".

Voir si cela aide à éliminer le problème. Il sera beaucoup plus fiable que certains des autres mécanismes proposés.


1
2017-08-24 01:46



J'ai cette case non cochée. (Donc ça ne va pas aider dans mon cas.) - TN.


En appliquant la solution d'Andomar, j'ai aussi eu l'erreur:

  • Set-ScheduledTask: le paramètre est incorrect. Sur C: \ Users \ Filip \ scripts \ disable_wakejobs.ps1: 1 caractère: 123 + ... Désactivé "} |% {$.Settings.WakeToRun = $ false; Set-ScheduledTask $} + ~~~~~~~~~~~~~~~~~~~~ + CategoryInfo: InvalidArgument: (PS_ScheduledTask: Root / Microsoft / ... S_ScheduledTask) [Set-ScheduledTask], CimException + FullyQualifiedErrorId: HRESULT 0x80070057, Set-ScheduledTask

Dans mon cas, cela était dû à une tâche qui ne peut pas être modifiée (AUSessionConnect dans WindowsUpdate pour être précis). Donc, je modifie directement la tâche responsable (Redémarrer dans UpdateOrchestrator). Le fichier disable_wakejobs.ps1 correspondant ressemble à ceci (pour savoir comment utiliser ce fichier, consultez la réponse d'Andomar):

Get-ScheduledTask -TaskName "Reboot" | % {$_.Settings.WakeToRun = $false; Set-ScheduledTask $_}

Pour tester le script manuellement, assurez-vous de l'exécuter à partir d'une instance PowerShell surélevée (Exécuter en tant qu'administrateur).


1
2018-01-07 15:07





J'ai rencontré un problème lorsque UpdateOrchestrator s'est réactivé. Bien entendu, mon ordinateur a dû sortir du mode veille (gravement, il a déclenché Microsoft pour me réveiller au milieu de la nuit). J'ai trouvé des informations sur reddit qui semblent le résoudre.

Open PowerShell:

  • exécuter: Get-ScheduledTask | où {$ _. settings.waketorun}

Ouvrir cmd:

  • Exécuter SCHTASKS / Change / TN "Microsoft \ Windows \ UpdateOrchestrator \ Reboot" / DISABLE
  • Exécutez icacls "% WINDIR% \ System32 \ Tâches \ Microsoft \ Windows \ UpdateOrchestrator \ Reboot" / héritage: r / deny "Everyone: F" / deny "SYSTEM: F" / deny "Service local: F" / deny "Administrateurs: F".

Cela empêchera la tâche d'être réactivée. Cela suppose que vous exécutiez une version anglaise de Windows - traduisez les noms d'utilisateur si nécessaire ou recherchez les SID, si nécessaire.

Message original sur reddit. https://www.reddit.com/r/Windows10/comments/48rg7x/is_there_any_way_to_stop_updateorchestrator_for/


1
2018-03-18 08:55





Windows 10 a deux choses que vous pouvez diable pour les minuteurs de sillage

Lorsque vous entrez dans le réglage de puissance avancé, vous verrez désactiver les minuteries de réveil sous les minuteries de réveil, puis sous ce dernier vous verrez un minuteur de réveil important, désactivez-le également.


0
2017-09-10 23:07



Il me semble que cela dépend si le PC peut avoir une batterie ou non. J'ai mis à jour la réponse à Nick. - TN.