Question Win8.1 se fige au démarrage avec hypervisorlaunchtype = Off sauf si je déconnecte brièvement le SSD


J'ai un Lenovo ThinkPad X1 (modèle 12943QG) à partir de 2012, sous Windows 8.1 x64. J'ai mis à niveau l'ordinateur portable avec un SSD Samsung 840 PRO de 512 Go à utiliser comme lecteur système au lieu du petit SSD Intel de 128 Go. Le SSD de Samsung possède une version de micrologiciel à jour, l'installation de Windows est entièrement corrigée et j'exécute les versions récentes des pilotes dans la mesure où je les trouve pour cette machine relativement ancienne.

J'ai la machine configurée pour avoir 2 chargeurs de démarrage pour Windows 8.1, l'un avec Hyper-V activé et l'autre avec Hyper-V désactivé. J'utilise ce dernier lorsque j'ai besoin d'utiliser VirtualBox, qui nécessite Hyper-V désactivé pour exécuter son propre hyperviseur. J'ai initialement créé le chargeur de démarrage Hyper-V-disabled en utilisant bcdedit \copy ..., comme expliqué ici. Mais j'ai toujours du mal à le démarrer. Il a tendance à fonctionner une fois après la création du chargeur de démarrage, mais après le redémarrage de la machine, il se bloque au logo bleu de Windows, ce qui ne me laisse que le chargeur de démarrage compatible Hyper-V. J'ai essayé de recréer le (s) chargeur (s) de démarrage plusieurs fois bcdedit /create au lieu de /copy) et finalement j'ai même reconstruit le magasin de bcd entier à partir de zéro. Tout cela en vain: le chargeur de démarrage Hyper-V-disable se bloque à chaque deuxième tentative de démarrage.

Cependant, après beaucoup d'essais et d'erreurs, j'ai trouvé une méthode simple, mais complètement déconcertante, pour démarrer en mode Hyper-V-disable à chaque fois. Croyez-le ou non mais le tour est:

  • éteindre complètement l'ordinateur portable;
  • sortez le SSD et faites-le glisser tout de suite;
  • pouvoir sur l'ordinateur portable.

Ensuite, Windows 8.1 démarre en mode Hyper-V-disabled sans problème. Mais, malheureusement, je dois le faire chaque fois que je veux entrer dans ce mode après un redémarrage (même sans avoir utilisé le mode compatible Hyper-V entre-temps). Clairement, c'est une perte de temps et parce que je travaille souvent en déplacement, cela signifie aussi que je dois porter un tournevis pour pouvoir ouvrir la trappe de disque chaque fois que je veux redémarrer.

J'ai environ 2 questions:

  • Qu'est-ce qui pourrait causer cette situation étrange?
  • Pourrait-il y avoir un autre moyen d'obtenir le même résultat sans avoir à déconnecter physiquement le SSD?

Au cas où cela est important, voici ma configuration actuelle de bcd:

Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume1
description             Windows Boot Manager
locale                  en-UK
inherit                 {globalsettings}
integrityservices       Enable
default                 {default}
resumeobject            {cecf0999-8220-11e5-82e0-806e6f6e6963}
displayorder            {default}
                        {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
-------------------
identifier              {default}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 8.1 (Hyper-V enabled)
locale                  en-UK
inherit                 {bootloadersettings}
integrityservices       Enable
recoveryenabled         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {1c96e7d5-8220-11e5-82dd-806e6f6e6963}
nx                      OptIn
bootmenupolicy          Standard
hypervisorlaunchtype    Auto

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 8.1 (Hyper-V disabled)
locale                  en-UK
inherit                 {bootloadersettings}
integrityservices       Enable
recoveryenabled         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \Windows
resumeobject            {cecf0999-8220-11e5-82e0-806e6f6e6963}
nx                      OptIn
bootmenupolicy          Standard
hypervisorlaunchtype    Off

Merci d'avance!


3
2017-11-03 12:33


origine




Réponses:


J'ai rencontré un problème similaire avec Lenovo ThinkPad T420 Windows 8.1 Pro 64 bits. J'ai besoin de Virtual Box avec Laravel Homestead, mais la VM ne fonctionnerait pas et le message d'erreur est que le VT-x / AMD-V n'est pas activé. Après une recherche rapide, il est apparu que Hyper-V devait être supprimé ou désactivé. J'ai d'abord essayé de le supprimer en désélectionnant l'intégralité du groupe Hyper-V dans la page "Activer ou désactiver des fonctionnalités Windows". Après le redémarrage, le système a démarré normalement jusqu'à ce que le logo Windows bleu disparaisse, à cet état, il a gelé. Essayé plusieurs fois, a enlevé la batterie et le cordon d'alimentation, cela n'a pas aidé. Doit effectuer la récupération du système en utilisant un point de restauration qui a fonctionné avec succès. Ensuite, sur le système récupéré avec Hyper-V actif, j'ai essayé la deuxième approche avec une copie de l'entrée du chargeur de démarrage (copie de bcdedit et hypervisorlaunchtype désactivée). Le résultat est le même maintenant, le système démarre jusqu'à ce que le logo bleu disparaisse puis se fige. Heureusement, cette fois, je suis capable de démarrer normalement grâce au choix par défaut laissé dans le chargeur de démarrage. Note: Je n'ai pas essayé le truc en déconnectant le disque dur.

P.S. C'était un commentaire, mais je n'ai pas pu l'ajouter en raison de restrictions. :(

Edit: a été capable de démarrer avec Hyper-V désactivé et d'utiliser VirtualBox après avoir modifié les paramètres de virtualisation du BIOS pour les éléments suivants:

  • Technologie de virtualisation Intel (R): activée
  • Fonctionnalité Intel (R) VT-d: désactivé

Il s'avère que la fonctionnalité VT-d provoque le problème de suspension pendant le démarrage. Peut-être que cela aide aussi dans votre cas.


0
2017-12-04 04:58



Vous racontez une expérience «moi aussi», mais on ne sait pas comment quelqu'un utiliserait cette information pour résoudre son problème. Si vous croyez qu'il y a des informations utiles ici, pouvez-vous modifier votre réponse pour mieux la cibler et l'expliquer; le transformer en quelque chose actionnable? - fixer1234
Merci beaucoup Mr.Key! Il semble que la désactivation de VT-d ait également résolu le problème pour moi. J'ai pu démarrer avec Hyper-V désactivé sans avoir à déconnecter d'abord mon disque dur. Hourra! - Matthias
Cela n'explique pas vraiment ce que vous avez fait pour résoudre le problème, je suppose que vous vouliez hypervisorlaunchtype être mis à auto au lieu de off mais ce n'est pas clair ce que vous avez fait à moins que vous disiez désactiver VT-d réparé pour vous. Ce commentaire stimule le fait, je suis allé à la recherche hypervisorlaunchtype et est tombé sur cette réponse incomplète. - Ramhound