Question Comment arrêter Mac pour convertir un double tiret en emdash?


Je pense que c'est un truc de Mountain Lion, quand vous tapez - (tiret) deux fois, ça devient - (emdash). Lorsque vous tapez tm, cela devient (symbole de marque). Ou quand vous tapez trois. (point), ça devient ... (elipsis). Certains sont utiles, d'autres très ennuyeux. Dans l'ensemble, je veux arrêter ça. Comment puis-je atteindre cet objectif?


89
2018-02-22 06:46


origine


Juste une note pour les autres personnes qui lisent, que si ce n'est pas une chose OSX pour vous, alors ce peut être votre éditeur de texte. J'ai dû modifier TextEdit avec Préférences> tirets intelligents. - levininja
Je me demande quelle est la solution de macOS Sierra. - Charlie Parker
Il semble que certaines applications doivent être fermées et ouvertes pour que tout fonctionne. J'utilisais l'application Notes et il semble que cela n'a pas fonctionné jusqu'à ce que je ferme une application (le quitte complètement). Ca aurait pu être moi defaults write 'Apple Global Domain' NSAutomaticDashSubstitutionEnabled 0, mais qui sait. - Charlie Parker


Réponses:


(sur Sierra 10.12, ceci est maintenant dans le panneau de configuration du clavier)

Accédez aux préférences système et choisissez "Langue et texte"

enter image description here

Dans l'onglet "Texte", vous trouverez la liste des substitutions.

enter image description here

Si tu veux arrêter -- d'être transformé en  (emdash) vous devez utiliser le + bouton et ajouter une nouvelle règle pour remplacer -- avec -- (remplacer par lui-même)

Ou, faites un clic droit dans un champ de texte et allez dans "Substitutions" et désactivez "Smart Dashes"

Stupid Dashes


92
2018-02-22 07:06



ah ok, donc si je fais une autre règle comme "-" à "-" alors cela sauve mes doubles tirets. Merci! - beatak
Ajouter - pour être remplacé par lui-même ne semble pas fonctionner dans Yosemite (et Keynote) :( - Balint Erdi
@BalintErdi Je viens de trouver cette question encore par googler pour le problème, trouvé la réponse, pensé Hmmm, ça ne marche pas, quel idiot a posté ce truc et a ensuite vu qu'il était propre damner modifier. LOL. Je viens de mettre à jour la réponse, j'espère que cela fonctionne mieux maintenant! - Josh
El Capitan 11.11 Ceci est maintenant sur le panneau de contrôle du clavier. - vy32
J'ai dû fermer et rouvrir TextEdit pour qu'il fonctionne sur Yosemite. Aucun redémarrage requis. - Kris


J'ai rencontré ce même problème sur Mavericks (10.9), où le correctif a légèrement changé. Allez dans Préférences Système, puis "Langue et région", puis cliquez sur le bouton "Préférences du clavier ..." et accédez à l'onglet "Texte". Ce n'est plus une substitution, cependant, mais à la droite de la fenêtre se trouve une case à cocher "Utiliser des guillemets et des tirets". Si vous décochez ce bouton, cela ne change rien à deux tirets en un tableau de bord.

Un petit truc: sur 10.9.5 avec TextEdit (et probablement d'autres), vous devez quitter puis redémarrer votre éditeur pour que cette modification prenne effet.


48
2017-09-21 08:05



Et désactive également les devis intelligents. Je n'ai aucune idée de la raison pour laquelle Apple a décidé de regrouper ces deux éléments dans le même seau dans les préférences. Heureusement, vous pouvez les désactiver individuellement sous Modifier> Substitutions, bien que ce comportement soit par application. - dgatwood
Au moins 10.11 El Capitan, il est possible de désactiver uniquement les tirets intelligents (tout en gardant les devis intelligents) en exécutant defaults write 'Apple Global Domain' NSAutomaticDashSubstitutionEnabled 0 du terminal. Il y a deux réglages distincts sous le capot, NSAutomaticDashSubstitutionEnabled et NSAutomaticQuoteSubstitutionEnabledLa case à cocher "Utiliser des guillemets et des tirets intelligents" permet de basculer les deux. Mais Apple ne garantit pas que cela ne changera pas dans les futures versions d’OS X. - Adam Rosenfield
merci beaucoup @AdamRosenfield, votre solution est de loin la meilleure répertoriée ici. - zanona
@AdamRosenfield, vous devriez élever ce commentaire à une réponse afin que nous puissions voter pour elle. :-) - Nick K9
tu es sur que ça marche? Dois-je redémarrer mon Mac ou redémarrer mes applications? - Charlie Parker


En 11.11 c'est sous System Preferences > Keyboard. Il y a une case à cocher pour Use smart quotes and dashes.

Pré de clavier dans 11.11


24
2018-01-18 18:54



Sauf que cela désactive également les devis intelligents, que vous avez probablement ne pas vouloir faire. Désactiver les tirets intelligents sous Modifier> Substitutions corrige le problème plus proprement (en désactivant uniquement les tirets), en soulignant que le comportement est par application. (Pourquoi!?!) - dgatwood
Pourquoi voudriez-vous des devis intelligents? J'ai toujours considéré cela comme une solution à un problème qui n'existait jamais. Ils sont aussi particulièrement horribles pour les programmeurs. - CoreDumpError
tu es sur que ça marche? Dois-je redémarrer mon Mac ou redémarrer mes applications? - Charlie Parker
@dgatwood Donc, toutes les applications ne supportent pas Edit> Substitions. Dans Slack, par exemple, je ne vois aucune autre solution que de désactiver les deux comme le suggère cette réponse. +1 pour cette réponse (bien que cela ne me dérange pas les guillemets si vous les tapez) - Mark Edington


Dans les versions antérieures de Mac OS X, il y avait deux options distinctes pour les devis intelligents et les tirets intelligents dans les Préférences Système du clavier; Toutefois, dans au moins les versions 10.9 à 10.11, cette option a été remplacée par une seule préférence "Utiliser les guillemets et les tirets".

Heureusement, il y a encore deux préférences distinctes sous le capot, et la case à cocher de l'interface utilisateur bascule les deux simultanément. Vous pouvez activer ou désactiver un seul des devis intelligents ou des tirets intelligents à partir du terminal:

# Disable just smart dashes
defaults write -g NSAutomaticDashSubstitutionEnabled 0

# Disable just smart quotes
defaults write -g NSAutomaticQuoteSubstitutionEnabled 0

# To re-enable, set either back to 1.

Ceci est actuellement vrai à partir de OS X 10.11; cela peut changer dans les futures versions d'OS X (ou macOS, comme on l'appellera maintenant).


15
2017-07-19 18:26



Fonctionne toujours à partir du 10.12.6 - merci! - Glenn
Fonctionne toujours sur 10.13 également. - ShiDoiSi


Je ne suis pas sûr que vous ayez toujours ce problème, mais je viens juste de découvrir à quel point cela peut être frustrant. J'écrivais un script Unix pour Apple Remote Desktop qui nécessite un --get flag et il continuait à être converti en un tableau de bord, ruinant la commande.

Je ne pouvais pas trouver un moyen de désactiver la conversion de tableau de bord, mais tout espoir n'est pas perdu. Dans le menu Langue et texte (onglet Texte), j'ai créé une entrée qui remplace -- avec -- (c'est-à-dire qu'il remplace deux tirets par lui-même). Cela remplace la conversion du système -- à un em dash.


4
2017-12-05 20:34





Il convient de mentionner que même si l'option "Utiliser les guillemets et les tirets" est activée, vous pouvez toujours "annuler" la conversion automatique de - en - (emdash) en appuyant sur CMD + Z. Si transformer les tirets intelligents semble trop extrême, c'est une façon de ramener le - (double tiret).

En outre, voici mon histoire d'horreur à propos des "guillemets": j'avais utilisé Github pendant des années et me suis demandé pourquoi mes "contributions" ne figuraient jamais correctement sur mon profil. J'ai finalement découvert que j'avais configuré mon nom d'utilisateur git dans un terminal avec des guillemets au lieu de marques droites:

git config --global user.name “Steve”       //instead of...
git config --global user.name "Steve"

Même si je copiais / collais la commande directement à partir de Instructions de GitHub, TextEdit "corrigeait" mes devis avant de les mettre dans Terminal. Incroyable! Cela m'a rendu fou, mais je récupère ...


2
2018-02-04 21:40





En utilisant les outils "Office" d'Apple: Page, Number, etc., les paramètres des Préférences Système ou la commande par défaut de la ligne de commande, comme mentionné dans les réponses précédentes, n'affecteront pas les substitutions intelligentes. Au lieu de cela, vous devrez accéder au menu Edition> Substitutions de la barre d'outils du haut pour cocher ou décocher les "Citations intelligentes", "Smart Dashes", etc.

Si vous utilisez TextEdit, alors la réponse de 7stud est la solution, qui est incluse ici pour être complet: TextEdit> Préférences et cochez / décochez les paramètres dans les sections inférieures.


1
2018-05-18 15:56





Ce comportement est contrôlé par un système par défaut. Pour le désactiver, tapez sur le terminal:

    les valeurs par défaut écrivent -app 'Keynote' TSWPAutomaticDashSubstitution 0

ou

    les valeurs par défaut écrivent 'Apple Global Domain' TSWPAutomaticDashSubstitution 0

Le premier désactive la substitution de tirets pour une application particulière (ici, Keynote); la seconde pour toutes les applications qui ne possèdent pas leur propre paramètre par défaut défini explicitement. Remplacer 0 par 1 pour réactiver la substitution de tiret.

Comme d’autres réponses l’ont indiqué, la valeur par défaut globale peut également être modifiée en utilisant Préférences de système (Clavier> Texte> Case à cocher "Utiliser des guillemets et des tirets"), mais ceci est activé ou désactivé citation substitution aussi bien que substitution de tiret. De plus, certaines applications, mais pas toutes, vous permettent de modifier leurs valeurs par défaut en cliquant sur un champ de texte tout en sélectionnant Substitutions ou Afficher les substitutions. Par exemple, Courrier vous permet de faire cela, mais Keynote ne fait pas.

Si vous souhaitez activer la substitution de devis, par exemple, pour Keynote utilisation

écriture par défaut -app 'Keynote' NSAutomaticQuoteSubstitutionEnabled 1

ou, pour l’activer pour tout ce qui n’a pas de valeur par défaut, utilisez

les valeurs par défaut écrivent «domaine global Apple» NSAutomaticQuoteSubstitutionEnabled 1

Pour l'éteindre, utilisez 0 au lieu de 1.


1
2018-01-26 22:12



Pour Slack, où cela me rendait fou, je pense que la clé de réglage est WebAutomaticDashSubstitutionEnabled. - Michael


Si vous souhaitez simplement éviter que cela se produise à l'occasion, ou par une instance spécifique, vous pouvez simplement attendre que Mac effectue les modifications indésirables, puis appuyez sur CMD+z défaire.


1
2017-10-09 17:29



Avez-vous testé cela avec le "-" et "-" pour confirmer que cela fonctionne comme prévu, comme décrit par l'OP? - Pimp Juice IT


Yosemite 10.2 and TextEdit:

  1. Lancez TextEdit.

  2. TextEdit> Préférences

  3. En bas à droite, décocher Smart dashes .

  4. Si votre fichier TextEdit est ouvert, fermez-le et rouvrez-le.


0
2018-05-25 19:39