Question Comment puis-je faire ctrl + touches gauche / droite pour déplacer par mot entier dans tmux?


A la fois zsh et bash, ctrl + flèches me permet de déplacer la position que je tape par mot entier, mais cela ne fonctionne pas avec tmux, ce qui est un problème car je le lance automatiquement chaque fois que j'ouvre un shell .

Comment puis-je réparer cela?


91
2017-11-23 19:43


origine




Réponses:


  1. Modifier votre ~/.tmux.conf et ajouter des lignes:

    set-window-option -g xterm-keys on
    
  2. Si vous ne voulez pas le rendre permanent, faites:

    C-b :set-window-option xterm-keys on
    
  3. Rechargez votre configuration dans tmux en faisant:

    C-b :source-file ~/.tmux.conf
    

Plus d'information ici:


117
2018-02-29 11:04



Strange: Cela ne fonctionne pour moi que si je recharge le fichier ~ / .tmux.conf à partir de tmux ou si je mets l’action dans le répertoire: -prompt de tmux, pas au début lorsque j'ouvre tmux. Des idées quel pourrait être le problème là-bas? - AME
@AME ferme toutes les sessions tmux puis réessaye. - Nathan
Si reload config ne résout pas le problème (c'est le cas pour moi), essayez une nouvelle session. Peut-être devez-vous tuer la session en cours et en créer une nouvelle. C-b: respawn-pane -k est une autre option pour le rendre effectif dans un volet (pas une session) - fstang
Cela a fonctionné pour moi, principalement. Je me demande pourquoi ce n'est pas par défaut? - inetknght
Tuer la session, ou peu importe set-window-option -g xterm-keys on ne fait toujours rien dans mon cas. - noraj


set-window-option -g xterm-keys on

M'a donné un peu de chemin là-bas et m'a donné Ctrl-Gauche droite sur la console, mais il réagissait toujours différemment dans vim.

Le relâchement des touches ne semblait pas aider.

Il s'est avéré qu'à un moment donné, j'avais défini mon terminal par défaut sur écran (set-option -g default-terminal "screen" dans .tmux.conf)

En changeant ceci à ce qui suit, on m'a donné Ctrl-Gauche droite dans tout le reste:

set-option -g default-terminal "xterm-256color"

J'espère que ça aide quelqu'un.


8
2018-06-11 10:38



Sauf que cela brise les couleurs en vim, tig, et probablement beaucoup d'autres choses ... - koniiiik
voir également unix.stackexchange.com/a/1098/250 pour un conseil contre la mise en place de TERM comme ça dans tmux - phunehehe


Je ne suis pas sûr, mais cela pourrait être parce que tmux par défaut lie C-<up/down/left/right> pour déplacer la mise au point sur le volet au-dessus / au-dessous / à gauche / à droite du panneau actuellement focalisé. Si vous n'utilisez pas souvent les volets, vous n'avez peut-être pas remarqué cette fonctionnalité. Si tel est le problème, vous pouvez supprimer ces clés en disant:

unbind C-Left
unbind C-Right

Cela pourrait suffire à elle-même, ou vous devrez peut-être les relier manuellement à ce que vous souhaitez qu'ils fassent, via:

bind -n C-Left <the action you want>
bind -n C-Right <other action you want>

1
2017-12-08 10:49



Il devrait être suffisant sur lui-même, s'il n'est pas saisi par tmux, il devrait passer sur le shell. - Rob


Pour msys2 / Cygwin / mintty:

Ajouter ci-dessous à ~/.inputrc.

"\e[1;5C": forward-word   # ctrl + right
"\e[1;5D": backward-word  # ctrl + left 

Reload ferait fonctionner correctement tmux.


1
2017-10-19 02:05





Pour moi, les clés n'étaient pas liées correctement, car les préférences du système dans High Sierra étaient définies comme étant utilisées par le contrôle de mission. Si vous décochez ces cases, les bonnes liaisons fonctionnent dans iTerm2 et Tmux.

Préférences de système

En décochant tous les éléments faisant référence à la clé de contrôle, les liaisons fonctionnaient correctement


0
2018-01-24 08:44