Question Hyper-V VM ne démarrera pas à partir de Cd, erreur: "le hachage de l'image non signée n'est pas autorisé"


Je suis allé installer une instance Debian sur le client Windows Hyper-V dans Windows 10. Cependant, lorsque j'ai tenté de démarrer la VM, elle ne démarrait pas à partir du CD. Éventuellement, le BIOS Hyper-V ne m'a pas permis de démarrer l'écran répertoriant les périphériques de démarrage et leur état. L'état du périphérique SCSI-DVD était le suivant: "Le hachage de l'image non signée n'est pas autorisé (DB)".

La recherche d'informations sur cette erreur sur Internet s'avère difficile.


91
2018-01-14 08:19


origine




Réponses:


Cette erreur est la conséquence de l'activation du démarrage sécurisé sur la machine virtuelle. Secure Boot empêche le système d’être piraté au démarrage en autorisant uniquement le chargement d’images de démarrage spécifiquement autorisées. Dans le client Hyper-V, la liste est plutôt courte.

Pour désactiver le démarrage sécurisé, mettez la machine virtuelle hors tension, puis ouvrez les paramètres de la machine virtuelle. Sous Secure Boot, décochez la case "Activer le démarrage sécurisé", puis cliquez sur "OK". Cela permettra à la VM de démarrer l'image de CD "non autorisée".


141
2018-01-14 08:19



Merci, vraiment étrange que cela a échoué avec les images ISO directement à partir de MSDN. Mais c'est M $ pour toi. - Rob
Réponse parfaite merci, je me demandais ce que c'était. Peut-on le réactiver après l'installation? - Raphael Teubner
Le démarrage sécurisé est activé ou désactivé pour chaque machine virtuelle. Tant que le système d'exploitation installé possède une image de démarrage reconnue, vous pouvez réactiver le démarrage sécurisé après l'installation. - Thomas
J'ai choisi un autre modèle: "Microsoft UEFI Certificate Authority". A travaillé comme du charme. - Itai Bar-Haim


Désactivez l'option de démarrage sécurisé dans les paramètres de la machine virtuelle:

enter image description here

Cette fonctionnalité est activée par défaut sur les machines virtuelles Gen2 et nécessite que votre chargeur de démarrage d'image ISO soit signé par un certificat Microsoft Authenticode. Toutes les images personnalisées avec le chargeur de démarrage modifié ne pourront pas démarrer. Il existe également un modèle "Microsoft UEFI Certificate Authority" pour les images Linux.


53
2017-10-01 11:52





Je regardais ce problème et suis tombé sur ce fil. J'ai trouvé que la modification de l'option pour utiliser "Microsoft UEFI Certificate Authority" a résolu mon problème en utilisant Ubuntu Server 17.x.

Set-VMFirmware -VM $VM -FirstBootDevice $(Get-VMDvdDrive -VM $VM) -EnableSecureBoot On -SecureBootTemplate MicrosoftUEFICertificateAuthority

2
2017-10-28 18:05



Comment définissez-vous la valeur de $ VM? - code_monk
Vous pouvez également définir cela dans l'interface utilisateur (voir la réponse de Makhail) en sélectionnant "Autorité de certification Microsoft UEFI" dans la liste déroulante Modèle de l'écran Paramètres de sécurité. - devrelm


Cela m'est arrivé aussi en essayant d'installer Windows Server 2008 R2 sur Windows 10 Hyper-v. Il a également déclaré que DHCP a échoué et qu'aucun système d'exploitation n'a été trouvé. Décocher l'option de démarrage sécurisé n'a pas résolu le problème. Cependant, la création d'une nouvelle machine virtuelle Gen 1 a eu lieu.


1
2018-06-12 09:22