Question Cygwin X sur DPI élevé


Sur mon Windows 10 Surface Pro (résolution 2736x1824), chaque fois que je me connecte via PuTTY à un serveur Ubuntu 14.04 et que je lance Eclipse ou gVim sur Cygwin X, le texte et les fenêtres sont extrêmement petits.

Je peux faire glisser les fenêtres sur mon écran de bureau (1920x1080), mais cela prend juste la taille de l'image sur l'écran 2736x1824 et la redimensionne pour obtenir la même taille approximative (plus floue, en raison de la résolution inférieure) .

Existe-t-il un moyen de faire en sorte que les programmes Cygwin ou Unix X s'exécutent pour reconnaître le DPI, ou redimensionner automatiquement les images, ou similaires?

J'ai vu que le X de Cygwin a un Option DPI, mais je ne peux pas dire que cela ait un effet sur gVim ou Eclipse.


3
2018-04-14 21:40


origine




Réponses:


Exécutez ces commandes dans le serveur bash session avant l'exécution des applications:

export GDK_SCALE=2
export QT_SCALE_FACTOR=2
export ELM_SCALE=2 

Vous pouvez ajouter ces lignes à ~/.bash_profile pour rendre cela automatique sur les futures connexions.

La source: HiDPI - ArchWiki


2
2017-07-06 01:48



Il semble que cela n’aide pas gVim, mais cela aide Eclipse (tant qu’Eclipse utilise son support par défaut de GTK3). Merci pour les conseils et le lien. - Josh Kelley
Avez-vous essayé la version GTK3 de gVim? packages.debian.org/sid/vim-gtk3 - Sean W.


Installez MATE et le mode bureau et cela devrait fonctionner.

Pour le mode multi-fenêtre, exécutez le terminal mate-terminal ou le terminal mintty à partir du menu xwin-xdg (icône du bac vert) et tapez:

/usr/libexec/mate-settings-daemon.exe &

faire en sorte que tous les processus gtk respectent la mise à l'échelle


0
2018-05-26 20:42