Question ShellExecute a échoué (2) erreur pour Notepad ++ sur Windows 7 64 bits


Windows 7 Error: Is this command correct?

ShellExecute failed (2): Is this command correct? "C:\Program Files (x86)\Notepad++\notepad++.exe [location of file to edit]

Je semble avoir un problème avec RIGHT CLICK > Edit with Notepad ++. Ceci est sur une nouvelle installation de Microsoft Windows 7 Professional 64 bits.

Je ne peux pas sembler trouver aucun avis de cette erreur? Ou est-ce juste un problème de configuration de Windows 7?


96
2017-11-19 21:30


origine


Notepad ++ fonctionne bien sur mon Win 7 x64. Essayez de réinstaller - Sathya♦
J'ai tenté d'installer sur Program Files au lieu du répertoire de fichiers du programme x86, cela n'a pas résolu le problème. Je pense que le problème est que l'extension de shell s'exécute à partir d'une DLL qui n'a pas d'accès administrateur. Je crois que ce soit NppShell_04.dll donc si nous trouvons comment dire à Windows 7 de donner cet accès administratif à l'exécution, alors nous sommes en or. - Steve
-1 vous devriez inclure un mot-clé de l'erreur dans le titre, alors les gens sauront avant même d'avoir cliqué - barlop


Réponses:


J'ai Windows 7 64 Bit et je travaille avec Notepad ++ depuis plus d'un an sur différentes installations de Windows 7 64 Bit et je n'ai jamais vu une telle erreur. Avez-vous essayé de désinstaller complètement, exécutez CCleaner et installez Notepad ++ à nouveau?


3
2017-11-19 23:24



CCleaner ne va pas faire de différence ici. La réinstallation devrait cependant résoudre le problème. - Billy ONeal
J'ai essayé une ré-installation, c'est la chose amusante. Je ne sais pas quel est le problème, je vais essayer une désinstallation, vérifier les entrées de registre et faire une installation complète à nouveau. - Jakub
J'ai essayé la méthode de désinstallation et nettoyé complètement le registre de tous Notepad++ les références. Une nouvelle réinstallation a fonctionné. Étrange... - Jakub
C'est une très mauvaise réponse. Ce devrait être un commentaire, au mieux. - Brian Webster


Cela est dû lorsque vous définissez Notepad ++ pour qu'il s'exécute en tant qu'administrateur sous Windows 7.

Allez dans votre base de registre en tant qu'administrateur et recherchez notepad ++. Exe. Trouvez la clé sous HKEY_CLASSES_ROOT qui a une entrée avec le Edit with Notepad++ (ou peut-être Edit with &Notepad++) et supprimez la clé entière. Faites un clic droit et vous devriez voir que vous n'avez plus cette option.

Maintenant, nous le recréons:

  1. Aller à:

    HKEY_CLASSES_ROOT\*\shell
    
  2. Créer une nouvelle clé sous shell appelée OpenWithNotepad et créer une sous-clé sous celle appelée command.

  3. dans le OpenWithNotepad key La chaîne par défaut est ce que vous voulez que l'élément de menu contextuel soit appelé. Je l'ai mis à Open with Notepad++.

  4. Toujours dans le OpenWithNotepad clé, créer une nouvelle valeur de chaîne appelée icon et définir la valeur à path-to-notepad++.exe où chemin vers le bloc-notes ++. exe devrait être le chemin complet, par ex. C:\Program Files\Notepad++\notepad++.exe.

  5. Sous le command modifier la valeur de la chaîne par défaut et la changer pour "path-to-notepad++.exe" "%1" où chemin vers le bloc-notes ++. exe devrait être le chemin complet, par ex. C:\Program Files\Notepad++\notepad++.exe.

Lorsque vous cliquez avec le bouton droit de la souris sur cette option, vous devez maintenant demander à Notepad ++ admin d’accéder à un fichier.

Vous devez toujours accéder aux propriétés de notepad ++. Exe et le configurer pour qu'il fonctionne en tant qu'administrateur.


175
2017-12-24 20:15



C'est la seule réponse qui me permet d'utiliser encore "Open as administrator" avec Notepad ++. - Allbite
Travaillé parfaitement pour moi sur Windows 8 aussi. Merci. - LDJ
Mon entrée de registre était "Edit with & Notepad ++" - Greg Woods
En outre, comment pourrions-nous combiner cela avec une méthode pour arrêter les avertissements UAC? Tout ce que je peux trouver utilise des raccourcis; Cependant, ce correctif de registre pointe directement sur l'exécutable. Parce que soyons francs, il est presque pire de cliquer avec le bouton droit de la souris sur "Modifier avec Notepad ++" dans 10 fichiers et de traiter 10 invites UAC plutôt que de les enregistrer dans un dossier temporaire. administrateur. - Ariane
La réponse de @John Swaringen est plus facile que ces opérations manuelles et a fonctionné pour moi. - Beytan Kurt


Ceci est un fichier de registre qui pourrait aider tout le monde:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\OpenWithNotepad]
@="Edit with &Notepad++"
"icon"="C:\\Program Files (x86)\\Notepad++\\Notepad++.exe"

[HKEY_CLASSES_ROOT\*\shell\OpenWithNotepad\Command]
@="\"C:\\Program Files (x86)\\Notepad++\\Notepad++.exe\" \"%1\""

Copiez-le dans le Bloc-notes et enregistrez-le avec une extension .reg. Fermez le Bloc-notes et double-cliquez sur le fichier.


53
2018-02-15 06:55



Assurez-vous de copier également la première ligne. - CrnaStena
Cela a fonctionné pour moi dans Win8 x64. Cela m'a donné un doublon, donc je devais d'abord réinstaller Notepad ++, puis désactiver l'option Menu contextuel dans le programme d'installation. Merci. - Aske B.
Merci travail pour moi! Je pense qu'un fichier "NppShell_06.dll" est un bogue pour les versions de Windows ou un autre système d'exploitation. - KingRider
Fonctionne sur Win10 x64 - Harlandraka
La ligne 3 devrait être @ = "Edit with & Notepad ++ (en tant qu'admin)"? - PotatoFarmer


Sur mon ordinateur Windows 7 (32 bits), j'ai défini notepad ++ comme administrateur, ce qui a provoqué l'arrêt de l'extension du shell de l'explorateur avec l'erreur "Shell Execute failed". La désactivation de ce paramètre (clic droit, propriétés, compatibilité ...) a résolu le problème. Peut-être que c'est ce qui cause vos problèmes? (Maintenant, tout ce dont j'ai besoin est une extension "Modifier dans Notepad ++ en tant qu'administrateur".)


27
2017-12-01 08:27



Cela a résolu le problème pour moi. - AaronLS
Cela a fonctionné pour moi aussi. J'utilisais Windows 7 Ultimate 64bit. - TryHarder
La même chose m'est arrivée lorsque j'ai épinglé Notepad ++ sur la barre des tâches et coché Shift + clic droit -> Propriétés -> Compatibilité -> Exécuter ce programme en tant qu'administrateur. Décochez et sélectionnez Raccourci -> Avancé -> Exécuter en tant qu'administrateur aidé. - too


J'ai récemment mis à jour Notepad ++ et j'ai commencé à obtenir cette erreur "ShellExecute failed" lorsque j'essayais d'utiliser la fonctionnalité de menu contextuel "Modifier dans Notepad ++".

Alors que j'ai trouvé de nombreux rapports en ligne sur cette erreur, aucune des solutions que j'ai vues n'a fonctionné sur ma machine.

Voici les étapes que j'ai utilisées pour résoudre le problème:

  1. Faites un clic droit sur notepad ++. Exe dans le dossier du programme Notepad ++.
  2. Sélectionnez l'élément de menu Propriétés.
  3. Sélectionnez l'onglet Compatibilité.
  4. Lorsque "Exécuter ce programme en tant qu'administrateur" est activé uniquement pour l'utilisateur actuel, vous pouvez le désactiver en cliquant sur la case à cocher.
  5. Sinon, "Exécuter ce programme en tant qu'administrateur" est activé pour tous les utilisateurs et vous devez d'abord cliquer sur "Modifier les paramètres pour tous les utilisateurs", puis vous pouvez désactiver l'option.

J'ai créé une image pour chacun de ces scénarios et les ai joints ci-dessous.

J'ai mis en évidence "Exécuter ce programme en tant qu'administrateur" dans les deux images et mis en évidence le bouton "Modifier les paramètres pour tous les utilisateurs" en vert pour le scénario dans lequel l'option était activée pour tous les utilisateurs.

RunAsAdmin CurrentUser Scenario RunAsAdmin AllUsers Scenario


13
2017-10-21 13:17



Merci beaucoup Jeff. Cela a corrigé Donnez-lui un coup avant de jouer avec Registry. Si cela ne fonctionne pas, passez directement au Registre. - RuntimeException
Cela a fonctionné pour moi. Merci ! - knowledge_seeker


Désinstaller, nettoyer le registre et réinstaller ne fonctionnait pas pour moi. Je ne travaillais pas non plus dans un mode de compatibilité, ce qui ne pouvait être mon problème.

Le problème pour moi est que j'ai coché l'option "Exécuter ce programme en tant qu'administrateur" dans l'onglet Compatibilité. J'avais activé cette option pour pouvoir enregistrer, par ex. le fichier hosts. Après avoir décoché cette option, j'ai finalement pu cliquer à droite et éditer les fichiers en utilisant NotePad ++ à nouveau.


4
2017-12-09 00:55



C'était une solution facile. Commencé sur le chemin du regedit et est allé beurk. J'ai essayé, totalement travaillé. - jcollum


au cas où vous ne l'auriez pas encore réparé, j'ai eu le même problème et j'ai essayé tout ce qui précède. J'avais dit à Notepad ++ de démarrer en mode compatibilité et d'avoir cette erreur. Après l'avoir éteint, tout est revenu à la normale.


1
2017-12-08 17:14





Dans mon cas, il fallait installer Notepad ++ dans le répertoire "Program Files", et non dans "Program Files (x86)". Le chemin est foutu :)

J'espère que cela aide!


1
2017-12-16 00:13





J'ai eu des problèmes persistants avec Notepad ++ (sur 5.9) en ce qui concerne l'ouverture / édition de fichiers via l'interface de l'explorateur (à la fois un clic direct pour ouvrir et un clic droit pour modifier..etc). La solution pour moi a été d'installer Notepad ++ dans C: \ Program Tools \ Notepad ++ \ - si j'essaie l'un des emplacements d'installation "officiels", Notepad ++ ouvre uniquement les choses correctement en mode admin (ce qui est tu me pardonneras mon français)


1
2018-05-12 14:55