Question Tous les navigateurs ne voient pas Java JRE sous Windows 8.1


Je ne parviens pas à exécuter d'applet Java dans tous les navigateurs. Les pages Internet contenant des applets (ou similaires) disent comme "JRE n'est pas installé sur votre machine. Installez JRE et réessayez" ou elles ne montrent rien.

Voici un nouveau Windows 8.1 x64 pour une seule langue. Il n'y a pas de politique administrative, je crois parce que je l'ai installé personnellement. J'ai désactivé le pare-feu Windows et la protection en temps réel de Defener. Ensuite installé jre-8u77-windows-x64.exe:

C:\Program Files\Java\jre1.8.0_77\bin>java.exe -version
java version "1.8.0_77"
Java(TM) SE Runtime Environment (build 1.8.0_77-b03)
Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode)

Java est activé dans les navigateurs:

enter image description here

Maintenant, je vérifie si Java installé avec https://www.java.com/fr/download/installed.jsp ...

Firefox 45.0.2

- Pas de Java présenté à la page Plugins about:addons. Sur Java.com, j'appuie sur "Accepter et continuer". Ensuite, on me dit "Java est désactivé ou non installé".

Chrome 49.0.2623.112 m

- Il n'y a pas de Java listé à chrome://plugins/. Java.com déclare: "Le navigateur Chrome ne prend pas en charge les plug-ins NPAPI et n'exécutera donc pas tous les contenus Java. Basculez vers un autre navigateur (Firefox, Internet Explorer ou Safari sur Mac) pour exécuter le plug-in Java."

IE 11 (mise à jour automatiquement)

- Sur Java.com, j'appuie sur "Accepter et continuer". L'applet n'apparaît pas.

P.S. J'ai essayé d'installer JRE 7 aussi


3
2018-04-13 10:52


origine


Utilisez-vous la version 64 bits de Firefox? - DavidPostill♦
Je ne sais pas. Il n'y a pas un tel choix, et aucun de ces détails dans "à propos de". - Pavel Vlasov
Où voir quelle version de Firefox est en cours d'exécution? (64 bits ou 32 bits) - DavidPostill♦
@DavidPostill, merci beaucoup! Après votre point, j'ai installé JRE 32 bits et ça marche maintenant. Si vous ajoutez une réponse, je la marquerai comme solution. - Pavel Vlasov
Réponse ajoutée;) - DavidPostill♦


Réponses:


Je ne parviens pas à exécuter d'applet Java dans tous les navigateurs.

Firefox:

Firefox 64 bit ne prend pas en charge le JRE.

Firefox 32 supporte toujours le JRE (mais le support sera retiré en 2016). Vous devez installer le JRE 32 bits pour que cela fonctionne.

Mozilla a l'intention de supprimer la prise en charge de la plupart des plug-ins NPAPI dans Firefox d'ici la fin de 2016. Firefox a lancé ce processus il y a plusieurs années avec l'activation manuelle des plug-ins, permettant aux utilisateurs d'activer les plug-ins. Cette décision reflète les actions d'autres navigateurs modernes, tels que Google Chrome et Microsoft Edge, qui ont déjà supprimé la prise en charge des plug-ins hérités.

De plus, étant donné que les nouvelles plates-formes Firefox ne doivent pas prendre en charge un écosystème d'utilisateurs et de plug-ins existants, de nouvelles plates-formes, telles que Firefox 64 bits pour Windows, seront lancées sans support de plug-in.

La source Plugins NPAPI dans Firefox

Chrome

Chrome ne prend plus en charge le JRE.

Java est un plugin NPAPI.

Les plug-ins NPAPI sont éliminés de Chrome 42. Veuillez noter que Chrome ne supportera pas les plug-ins NPAPI après avril 2015; par conséquent, tous les sites Web utilisant ces plug-ins cesseront de fonctionner:

La source Les plugins Java disparaissent après la nouvelle mise à jour de Chrome vers la version 42.0.2311.90 m 


3
2018-04-13 12:18