Question Les apostrophes et les guillemets ne s'affichent pas avant que je tape la lettre suivante


dans Windows XP, lorsque je tape une apostrophe ', ou citation muette / machine à écrire  ", aucun caractère n'est affiché. Si je tape un autre caractère, l'apostrophe ou la citation muette et le caractère suivant apparaissent en même temps. Cela se produit avec des guillemets doubles ", apostrophes ' et tilde ~ personnages.

Qu'est-ce qui pourrait causer cela?

Cela se produit dans toutes les applications que j'ai testées - wordpad, firefox, ms word, etc.


101
2018-03-22 06:45


origine


cela s'applique également aux marques ~. - fastmultiplication
Duplicata de cette question. - JdeBP
États-Unis-International clavier était le problème pour moi. Doit le supprimer du Panneau de configuration \ Horloge, langue et région \ Langue -> options et garder US dans la méthode de saisie .. Cela résout ce problème dans Windows 10 ainsi .. source de ojnetworks.com.au/2012/04/ - Aravinda
Utilisateurs Windows 10: Voir le commentaire de l'antreality sur La réponse de Gabriel ci-dessous pour un correctif pour ce système d'exploitation - MickyD
J'ai un problème étrange où PowerPoint 2013 dans Windows traite parfois ma clé d'apostrophe (guillemet simple) comme une virgule et encore plus souvent comme un guillemet simple ouvert (au lieu d'une apostrophe). Ça me rend fou. J'ai vérifié mes paramètres de clavier Windows et ne vois rien d'anormal. - Ryan


Réponses:


C'est parce que vous avez un clavier où '  ~  " sont réglés sur le paramètre de touche morte.

Le comportement d'une clé morte est ... eh bien ... d'être mort! Donc, pas de réaction lorsque vous appuyez dessus. Vous pouvez ensuite attribuer un comportement différent lors de la frappe suivante, par exemple l’accentuation ou l’affichage de tout type de caractère pour lequel vous l’avez programmé. Et généralement, quand une frappe n'a pas de sens après une clé morte, vous avez un comportement standard qui consiste à afficher le caractère de la clé morte. Et bien sûr, le caractère suivant apparaît également car il se trouve dans le tampon.

Ainsi, vous pouvez suivre les conseils d'une autre affiche sur la manière de changer votre clavier (regardez quel KB vous avez configuré). Vous pouvez également obtenir le Microsoft Keyboard Layout Creator pour mapper un nouveau clavier et voir comment programmer des touches mortes.


43
2018-04-05 08:20



La réponse de Gabriel est meilleure. - ron
OP a demandé ce qui peut donner ce genre de comportement. Pas comment le changer. Donc, cette réponse explique pourquoi cela se produit, alors que la réponse de @gabriel le traite d'un point de vue local. En passant, j'ai fait référence à d'autres réponses concernant la manière pratique de changer de carte de clavier, car elles permettent de résoudre ce problème clairement. - M'vy
c'est encore mieux ... - user1916182
@ user1916182 lol! - Crimbo
Link est mort btw .. :( - Julian Declercq


La raison est que vous utilisez US-international clavier.

Voici comment changer cela:

  1. Dans la zone d'exécution Windows (les fenêtres+R) type control intl.cpl ou control international.
  2. Cliquez sur l'onglet "Claviers et langues"
  3. Cliquez sur "Modifier les claviers ..."
  4. À ce point, assurez-vous que vous utilisez «English (United Kingdom) - US» comme langue d’entrée par défaut, ce qui signifie que vous définissez le clavier sur US-international

171
2017-10-06 03:30



être conscient cependant de la différences des claviers anglais, américains et britanniques. - n611x007
cela ne marche pas sur la victoire 8. - numan
Merci! Sous Windows 8.1, j'ai dû appuyer sur Démarrer, puis rechercher "Modifier les options de langue et de clavier". Les mots sont un peu différents de Win7 / XP mais c'est la même approche - will-hart
C'est la bonne réponse. "Anglais (Royaume-Uni)" comme langue et "US" comme clavier. Fonctionne avec Logitech TK820 - Derek
Pour Windows 10, le correctif du panneau de commande ne fonctionnait pas. Je dois utiliser "Paramètres" -> "Région et langue". Ensuite, en sélectionnant la langue - dans mon cas, EN (UK) - m'a donné le bouton d'options pour aller à "Options de langue" où les claviers peuvent être modifiés; dans mon cas, ajoutez "US-Qwerty" et supprimez "US-Intl". - antreality


J'ai vérifié mes paramètres et ils sont définis sur anglais / américain mais le problème persiste. Puis, après la fermeture du dialogue, une icône est apparue sur la barre des tâches, me permettant de passer du clavier EN / International au clavier EN / US - Problème résolu!


12
2018-04-10 21:34





Vérifiez vos paramètres de clavier dans la région / langue. S'il est défini sur non-anglais / américain, il peut s'agir de caractères accentués, formés en appuyant sur l'accent (', ", ^, etc.) puis sur un caractère.


8
2018-03-22 07:24





Les problèmes résident dans la langue d'entrée. Pour changer entre les langues d'entrée, appuyez sur Alt gauche+Décalage. Cela devrait résoudre votre problème. Si cela ne fonctionne pas, faites-le de cette façon:

  1. Rechercher Language dans le menu Démarrer
  2. Cliquez sur Change keyboards or other input methods
  3. Clique le Keyboards and Languages languette
  4. Cliquez sur Change Keyboards...
  5. Clique le Advanced Key Settings languette
  6. Cliquez sur Change Key Sequence
  7. Attribuer un raccourci à Switch Input Language

7
2018-01-21 19:33



Je dois appuyer sur WIN + SPACE pour changer de langue - thumbmunkeys


J'ai connu le même problème désagréable depuis la nouvelle et propre installation de Windows 7 il y a quelques mois. Il s’est avéré que lors de l’installation de la langue de saisie supplémentaire, Windows a ajouté Correction d'encre. Ceci est un service de clavier pour la saisie "facile" de caractères accentués.

La solution est de supprimer cette Correction d'encre:

Text Services and Input Languages

Et n'oubliez pas de redémarrer Windows après avoir supprimé la correction d'encre.

MODIFIER:

Enlever le Correction d'encre résolu le problème que partiellement. (Les clés mortes avaient disparu dans le chat Skype, mais étaient toujours mortes dans Word 2010.)

Solution finale: Changer la langue de saisie États-Unis-International à NOUS.


6
2018-05-29 15:19





J'ai eu le même problème aussi. Mes "touches ne fonctionnaient pas au premier coup. J'ai changé la langue de saisie en anglais (Royaume-uni) États-Unis international en anglais (Royaume-uni) US. Mon clavier fonctionne maintenant parfaitement.


5
2018-03-07 12:05





Sur Windows 10, la solution la plus simple et la plus efficace que j'ai trouvée consistait à supprimer le raccourci clavier à l'origine du Control panel \ Clock, language and country / region \ Language \ Advanced Settings

Les paramètres de visibilité du pack de langue d'entrée anglais (US) 28 Mo et de la barre de langue n'étaient pas nécessaires.


0
2017-12-20 15:35