Question Faites en sorte que Windows 7 ignore le WiFi lorsque Ethernet est disponible


Lorsque je connecte mon ordinateur portable Windows 7, je souhaite qu’il préfère la connexion Ethernet câblée sur WiFi.

C'est une chose assez simple à faire sur mon Mac: je ne fais que réorganiser mes préférences réseau et cela "fait le bon choix". Je n'arrive pas à comprendre comment réaliser la même chose sur mon ordinateur portable Win7.

Ainsi, lorsque je suis connecté, il se connecte au WiFi, puis ne parvient pas à se connecter aux serveurs du réseau filaire local. Comment puis-je réparer ça?


110
2018-02-18 19:42


origine


Avec Windows, j'ai toujours utilisé les connexions IBM Access, qui s'appelleraient désormais Lenovo Access Connections. Mais cela ne pouvait être installé que sur le matériel Lenovo. Essayez donc la réponse à cette question: superuser.com/questions/214427/... Vous pourriez peut-être même utiliser le logiciel Access Connections? www-01.ibm.com/common/ssi/cgi-bin/ - Darokthar
Ceci est répondu ici: [entrez la description du lien ici] [1] [1]: superuser.com/questions/237892/... - CodeMonkey
Tu pourrais essayer ce, Je l'utilise sur mes ordinateurs. Désactive les adaptateurs Wi-Fi lorsque n'importe quel nic Ethernet est connecté et les réactive lorsque le réseau devient indisponible, fonctionne lorsque plusieurs nics câblés et sans fil sont présents. Bonne chance. - sean_m


Réponses:


C'est sur Windows 7, mais c'est assez bien caché.

Allez dans Panneau de configuration -> Centre Réseau et partage -> Modifier les paramètres de l'adaptateur -> Appuyez sur Alt pour obtenir le menu et choisissez Avancé -> Paramètres avancés.

Ensuite, vous pouvez réorganiser vos connexions dans cette liste.

Bien que Windows devrait déjà préférer automatiquement votre connexion filaire sur votre connexion sans fil. Il choisit l'adaptateur à utiliser en fonction de la métrique d'interface la plus basse et une connexion sans fil doit avoir une métrique supérieure à celle de votre connexion filaire. Courir route print depuis l'invite de commande pour voir cela.


110
2018-02-18 19:49



Cette solution n'a pas fonctionné pour moi. J'ai commandé mes connexions: (1) Connexion au réseau local, (2) Connexion au réseau sans fil. Lorsque je me connecte au réseau WiFi public, je ne peux pas accéder aux sites internes. Quand je me déconnecte, je peux. Il semble toujours préférer le WiFi. - jkooker
Est-ce que vos connexions câblées et sans fil ont toutes deux un ensemble de passerelles par défaut (vérifiez via ipconfig)? Plusieurs passerelles par défaut différentes entraîneront des problèmes de routage. Si tel est le cas, vous pouvez probablement résoudre votre problème en ajoutant un routeur statique via la commande route. Nous devrons connaître la configuration de votre adresse IP et les adresses des serveurs auxquels vous essayez de vous connecter pour vous aider. - shf301
il est parfaitement légal d'avoir plusieurs passerelles par défaut; c'est la norme. un seul sera utilisé, mais les autres sont toujours là au cas où l'une des interfaces disparaîtrait (câble débranché, sans fil éteint) - Michael Lowman
Certes, le problème vient du fait que les différentes passerelles par défaut n’ont pas accès aux mêmes réseaux, ce qui est le cas de jkooker. Voir son commentaire à votre réponse. Dans son cas, la modification des passerelles par défaut modifie le réseau accessible. C'était le contexte dans lequel je pensais. - shf301
Utilisez les instructions à la fin de cet article de la base de connaissances: support.microsoft.com/kb/299540/en-us - shf301


  1. Cliquez sur Début et, dans le champ de recherche, tapez Afficher les connexions réseau.
  2. appuie sur le ALT clé, cliquez sur Options avancées puis cliquez sur Réglages avancés.
  3. Sélectionnez la connexion sans fil et avancez pour une priorité absolue.

28
2018-02-11 08:39



L'onglet "Adaptateurs et liaisons" n'apparaît pas pour moi, uniquement "Ordre fournisseur" - Attila Szeremi
@AttilaSzeremi Je ne sais pas pourquoi. Mais êtes-vous un administrateur local sur la machine ou un membre du groupe d'opérateurs de configuration réseau? - pulsarjune
oui, c'est mon propre PC à la maison - Attila Szeremi


Allez dans le Panneau de configuration -> Centre Réseau et partage -> Modifier les paramètres de la carte -> Puis cliquez avec le bouton droit de la souris sur le réseau sans fil et sélectionnez Statut Puis clique Propriétés sans fil et assurez-vous que si vous l'avez configuré pour se connecter à portée, il est également configuré pour se connecter à Connectez-vous à un réseau préféré si disponible.


15
2017-07-30 09:53



non disponible sur Windows 8 - beluchin
Enfin, dans tous les articles que j'ai lus sur ce problème (en cours depuis des années!), C'est la première fois que je rencontre cette solution - et ça marche !!! - wotney
Le réseau local était déjà placé en haut de la liste de connexions et comportait la métrique la plus basse, mais n’était toujours pas utilisé lorsque le wifi était disponible. Changer ce paramètre a finalement corrigé les choses pour moi sur Windows 7. - Rintze Zelle
En fait, j'ai résolu le problème en sélectionnant simplement une adresse IP statique mais en ne spécifiant pas la passerelle par défaut sur l'interface pour laquelle je ne souhaite pas utiliser le trafic Internet. - David Okwii


Deux choses: d'abord, vous pouvez ajouter une métrique à chaque interface pour spécifier que l'une est meilleure qu'une autre. À l’aide de l’interface graphique, accédez aux propriétés de votre connexion réseau, TCP / IP, Avancé, décochez la mesure Automatique et entrez le nombre approprié. Comme la métrique représente un coût, Windows utilisera automatiquement l'interface avec une métrique inférieure si elle ne peut pas décider. Ce Article de la base de connaissances décrit la fonctionnalité que vous désactivez.

Deuxièmement, vous ne devriez jamais avoir un problème nécessitant l’utilisation d’une interface sur une autre. Si les deux interfaces sont le même réseau, alors vous voudrez toujours le rapide. S'ils sont différents réseaux, les tables de routage enverront automatiquement les paquets à l'interface appropriée pour atteindre le réseau auquel ils appartiennent.

Vous avez peut-être deux réseaux séparés physiquement avec le même bloc IP? Ceci est une mauvaise configuration, et vous devriez la réparer.


13
2018-02-18 19:50



Ceci est à l'œuvre, de sorte que le réseau câblé a accès aux sites internes, contrairement au réseau sans fil. - jkooker
ok, je soutiens toujours que c'est un problème de configuration, mais pas un problème que vous pouvez résoudre à la source. Il vous suffit donc de donner à votre interface sans fil une métrique plus élevée, et la passerelle par défaut du réseau câblé sera utilisée. encore, route print aide J'ai deux interfaces, une avec une métrique de 20, l'autre 10. La passerelle par défaut (dest 0.0.0.0, masque 0.0.0.0) utilisé sera celui avec la métrique la plus basse. - Michael Lowman
Cette solution a fonctionné pour moi, semble-t-il. - Peter Jaric
Cela a fonctionné pour moi, mais j'ai dû bricoler un peu. J'ai changé ma métrique de connexion filaire à 10 et la métrique de connexion sans fil à 20. Lorsque j'ai utilisé route print, il a montré le filaire comme 250-300 et le sans fil à 20-30 à chaque fois. Pour contourner ce problème, je me suis mis à l'extrême. Wired = 1, Wireless = 999. Je reçois maintenant la commande appropriée. Merci! - Lyrical
Le problème avec les métriques que j'avais, était lié à la création d'un commutateur virtuel Hyper-V connecté à une carte réseau sans fil. Dans ce cas, les métriques sont incorrectement faibles pour le «commutateur virtuel sans fil» qui a toujours été choisi par Windows au lieu du «commutateur virtuel Ethernet». - Pablo Montilla


Si vous avez un commutateur sans fil sur votre ordinateur portable, vous pouvez le désactiver. Vous pouvez également vérifier si votre port Ethernet est opérationnel dans le gestionnaire de périphériques. Vous pouvez également configurer cela via vos options Internet.


1
2018-02-18 19:49



désactiver le wifi fonctionne, mais est une solution de piratage. - jkooker


  1. Allez à Panneau de configuration> Réseau et Internet> Connexions réseau
  2. Faites un clic droit sur votre adaptateur réseau Wifi, généralement intitulé "Connexion réseau sans fil"
  3. Sélectionnez Propriétés
  4. Cliquez sur le bouton "Configurer"
  5. Sélectionnez l'onglet Avancé
  6. Sous "Property", faites défiler jusqu'à "Disable Upon Wired Connect" et mettez-le en surbrillance
  7. Sur le côté droit sous "Valeur", sélectionnez "Activé" dans le menu déroulant.
  8. Hit OK
  9. Désactiver puis Activer la connexion réseau sans fil.

1
2017-12-11 22:22



Ce n'est pas disponible pour tous les adaptateurs. - Logos


Un moyen simple de désactiver le sans fil est le bouton Windows + X, désactivez le sans fil. Répétez le processus pour le réactiver.


1
2018-04-17 19:32





Je l'ai fait en réglant le metric mise à 10 pour le fil et 1000 pour le wifi, toutes les autres suggestions que j'ai trouvées ne fonctionnaient pas.


0
2017-09-02 04:53





Mon problème était que le DHCP n'était pas activé pour ma connexion LAN - a exécuté l'utilitaire de dépannage, il l'a activé et tout va bien maintenant.


0
2017-10-17 02:54