Question Comment empêcher VLC de redimensionner automatiquement sa fenêtre en fonction de la résolution du contenu affiché?


Dans le cas de moi, une trame graphique de résolution très élevée (comparée au flux vidéo) (en disant "accès refusé" (lorsque mon IP change)) peut apparaître au lieu d’un flux vidéo, ce qui fait redimensionner la fenêtre VLC. l'écran est. Cela m'agace. Puis-je configurer VLC pour ne jamais redimensionner sa fenêtre lorsque je ne le fais pas moi-même et ne redimensionne pas le contenu à la place?


110
2017-12-16 18:30


origine




Réponses:


Il est vraiment difficile de trouver la case à cocher qui doit être non vérifié, vous pouvez donc modifier le fichier rc (mais n'utilisez pas notepad.exe pour le faire, car le fichier ne sera pas formaté).

C:\Users\%USERNAME%\AppData\Roaming\VLC

--- vlcrc.default       2011-12-16 11:46:51.000000000 -0800
+++ vlcrc.noresize      2010-12-05 20:00:26.000000000 -0800
@@ -1088,7 +1088,7 @@
 #qt-maximized=101

 # Resize interface to the native video size (boolean)
-#qt-video-autoresize=1
+qt-video-autoresize=0

Voici où se trouve l'option dans l'interface.

VLC disable resize


136
2017-12-16 19:52



PS, c'était un PITA extrême de constater que la première fois que je le cherchais. En fait, j'ai fouillé dans la source vlc avant de savoir où ils cachaient cette case stupide. - Zoredache
Vous devez également définir VLC pour UTILISER l'interface QT. - Mindwin
+1. Je suis allé à l'énorme problème de se connecter sur le site pour voter. C'est énorme pour moi, frère. lol merci pour la bonne réponse.
Notez que cela peut également être réalisé temporairement avec l'indicateur de ligne de commande --no-qt-video-autoresize - WirthLuce
nécessite la fermeture et l'ouverture avant que le nouveau comportement prenne effet. - Trevor Boyd Smith


Sélectionner Outils ⇨ Préférences ⇨ Interface puis décochez la case Redimensionner l'interface à la taille de la vidéo.
Enfin, redémarrez VLC.

enter image description here


91
2018-04-14 02:57



Cette réponse est plus à jour. L'autre réponse (acceptée) semble s'appliquer aux anciennes versions de VLC antérieures à 2.xx. - nixda
assurez-vous de redémarrer VLC (comme indiqué ci-dessus). c'est vraiment nécessaire! - Simon
L'ancienne réponse fonctionne si vous avez le "Show All" ou tout ce qui est appelé "activé", mais c'est certainement le moyen le plus rapide de trouver la solution, de nos jours. - kayleeFrye_onDeck
Cette réponse met en évidence la case à modifier. - Jake Berger
Lorsque j'ai commencé une vidéo, VLC était toujours maximisée. La case a été cochée par défaut. Donc j'ai fait: décochez la case> redémarrer VLC> cocher à nouveau> redémarrer VLC. Maintenant, chaque fois que je démarre une vidéo, la fenêtre redimensionne à la taille d'origine de la vidéo, ce que je voulais. C'est dans Ubuntu, pour une raison quelconque, le comportement correct n'était pas appliqué même si la boîte était sélectionnée par défaut lors de l'installation de VLC. - Daniel


Choisissez d'abord la taille de la fenêtre que vous souhaitez que la fenêtre VLC soit.

Ensuite, maintenez la Ctrl et fermez la fenêtre avec l'icône X.

Lorsque vous rouvrez VLC, il doit ouvrir la fenêtre dans la même taille que vous l'avez fermée.


13
2017-12-15 23:19



Merci, cela a fonctionné pour moi et c'est exactement ce dont j'avais besoin. - KoKo
+1 Cette case à cocher dans les paramètres ne fait pas sens, mais cette méthode a fait le tour. Merci! - zur4ik


Du Documentation VLC, J'ai trouvé:

--sout-transcode-maxwidth=<integer>
  Maximum output video width.

--sout-transcode-maxheight=<integer>
  Maximum output video height.

Cependant, l’exécution de VLC à partir de la ligne de commande nécessite beaucoup d’installation (y compris les paramètres du module standard et du module de transcodage). Exemples.

Je vais installer VLC sur cet ordinateur et examiner la possibilité de définir des tailles maximales via l'interface graphique. Je vais rendre compte si je trouve quelque chose.


2
2017-12-16 19:52



Je suis presque certain qu'il ne veut rien transcoder, il veut juste que l'interface cesse de se redimensionner. - Zoredache
Bien sûr, @ zoredache! J'ai voté pour toi. - Jesse Smith


La meilleure façon de le faire en appuyant sur Ctrl + H lorsque vous ouvrez une vidéo.

Vous pouvez ensuite le redimensionner en conséquence.


-1
2017-08-30 20:53





Sélectionnez Outils ⇨ Préférences ⇨ Interface puis décocher la boîte de dialogue Redimensionner l'interface à la taille de la vidéo et la boîte Intégrer la vidéo dans l'interface, redémarrer.

Démarrer le film maintenant, si vous remarquez qu'il devrait y avoir 2 fenêtres dans la fenêtre principale et la fenêtre vidéo dans 2 fenêtres distinctes maintenant.

Retournez Sélectionnez Outils ⇨ Préférences ⇨ Interface puis vérifier Intégrer la vidéo dans l'interface Enfin, redémarrez VLC.

Les fenêtres vidéo reviennent à leur valeur par défaut dans la fenêtre principale. Maintenant, le film reste à l'emplacement souhaité, redimensionne comme vous le souhaitez, ferme le film et remarque que la taille choisie reste la même.

Je ne sais pas comment c'est, mais après avoir essayé cela, c'est comme ça que ça marche pour moi.

L'autre option que j'ai trouvée est:

enter image description here


-1
2017-12-13 05:43