Question Ouvrir plusieurs instances d'Excel sans message de verrouillage PERSONAL.xlsb


Chaque fois que j'ouvre plus d'une instance d'Excel, je reçois le message suivant:

PERSONAL.xlsb est verrouillé pour l'édition

PERSONAL.xlsb is locked for editing

Q: Comment puis-je désactiver ou masquer ce message?

Par ailleurs, si quelqu'un pouvait suggérer un moyen d'améliorer la prise en charge d'Excel 2007 pour plusieurs moniteurs au sein d'une même instance, le problème serait également résolu.

Remarque: Je ne veux pas utiliser "Ignorer les autres applications qui utilisent Dynamic Data Exchange (DDE)", car cela nuit à d'autres fonctionnalités que j'utilise régulièrement.


24
2017-08-25 16:04


origine


Cela m'a beaucoup embêté, merci! - Coops


Réponses:


Détachez votre Personal.xlsb et activez l'option de classeur de partage. Vous pouvez ensuite ouvrir autant d'instances d'Excel que vous le souhaitez sans ce message en lecture seule.

Le seul inconvénient est que si vous voulez réellement ajouter ou modifier une macro personnelle, vous devrez afficher Personal.xlsb de nouveau et désactivez l'option de partage (vous ne pouvez pas voir ou modifier les macros de classeurs partagés, mais vous pouvez les exécuter).

Pour rechercher l'option de classeur de partage, appuyez sur l'onglet "Révision", puis sur le bouton "Partager le classeur", qui se trouve dans le groupe "Modifications".

Dans Office 2007/2010, affichez personal.xlsb en ouvrant une seule instance d'Excel et en choisissant Afficher dans l'onglet Affichage, dans la section Fenêtre, puis sur Afficher le bouton Dans Office 2007, partagez le classeur à partir de l'onglet Révision, modifiez la section et partagez le classeur.


26
2018-01-08 21:50



Exceptionnel! Cela a fait l'affaire. Merci! - anschauung
Cela m'a beaucoup embêté, merci! - Coops
Merci beaucoup pour cela - ça m'a vraiment dérangé. Il suffit d'ajouter: Dans Office 2007, affichez personal.xlsb en ouvrant une seule instance d'Excel et en choisissant Afficher dans l'onglet Affichage, dans la section Fenêtre, puis sur le bouton Afficher dans Office 2007, partagez le classeur à partir de l'onglet Révision, modifiez la section, partagez le classeur. - sahmeepee


Si vous ne dépendez pas de vos macros personnelles, vous pouvez accéder à:

C: \ Utilisateurs \ utilisateur   nom \ AppData \ Local \ Microsoft \ Excel \ XLStart

et faire le Personal.xlsb fichier en lecture seule. Cela devrait arrêter le harcèlement.

Si 2 instances ne sont pas nécessaires, vous pouvez également forcer Excel à ouvrir une nouvelle fenêtre pour chaque fichier. Il affichera plusieurs instances dans la barre des tâches (ce que je suppose que vous pouvez faire glisser sur des moniteurs), mais il n’aura qu’une copie d’Excel en cours d’exécution.


3
2017-08-25 16:14



Existe-t-il un moyen de forcer Excel à ouvrir une nouvelle fenêtre pour chaque fichier en dehors d’Excel? C'est-à-dire, puis-je rendre ce comportement par défaut et ne pas avoir à utiliser Excel? open dialogue? - anschauung
pas sans le truc DDE malheureusement - John T
Pouah. Je ne peux pas le faire mais il y a une solution en quelque sorte - Word gère cela parfaitement, mais probablement parce qu'il ne charge pas le fichier de modèle en tant que document «caché» pour chaque instance. - anschauung
C'est plus ou moins ce que j'ai fait. Marqué le fichier en lecture seule. Si jamais je dois travailler sur mes macros, je peux simplement le rendre à nouveau accessible en écriture. :) - Chiramisu


Ce thread fournit quelques options sur la façon d'empêcher que cela se produise. Je n'ai pas eu de changement pour tester la prise en charge multi-écrans d'Excel 2010, mais je peux confirmer que 2007 n'a aucun moyen de prendre en charge une instance avec des fichiers ouverts sur plusieurs moniteurs.


2
2017-08-25 16:12



Merci, mais j'ai déjà essayé cette solution particulière ("Ignorer les autres applications qui utilisent Dynamic Data Exchange (DDE)") et n'a pas aimé le résultat. J'ai édité le post pour que les autres le sachent. - anschauung


J'ai trouvé une solution simple à ce problème.

1) Faites une copie de votre fichier PERSONAL.XLSB ailleurs. Peu importe où vous voulez stocker ce fichier, évitez simplement les dossiers système. Par exemple, mettez-le sur le lecteur D: \

2) Créez un répertoire appelé XLSTART, ainsi vous aurez créé le dossier D: \ XLSTART.

3) Déplacer PERSONAL.XLSB de D: \ à D: \ XLSTART

4) Décochez la case Lecture seule dans votre fichier D: \ XLSTART \ PERSONAL.XLSB et votre dossier D: \ XLSTART

5) Aller à l'emplacement précédent de PERSONAL.XLSB (dans mon cas, il était C: \ Program Files (x86) \ Microsoft Office \ root \ Office16 \ XLSTART - parce que j'ai migré vers un nouveau bureau), mais vous pouvez avoir C: \ Users \ AppData \ Roaming \ Microsoft \ Excel \ XLSTART au cas où vous exécutiez encore l'ancienne version d'Office.

6) Accédez à un niveau supérieur et supprimez complètement le dossier XLSTART.

7) Déplacer ou copier D: \ XLSTART à l'emplacement actuel.

8) Terminer. Tout fonctionne.

Cela a fonctionné pour moi, j'espère que cela fonctionnera pour vous aussi. Maintenant, je peux modifier PERSONAL.XLSB quand je veux. Plus de soucis.


-1
2017-12-27 16:50