Question Firefox ne reconnaît plus mes clés "ALT"


Ubuntu 12.04, Firefox 13.0, xfce

Pour une raison quelconque, mon installation de Firefox a cessé de prêter attention aux combinaisons de touches ALT. C'est-à-dire que lorsque j'essaie une combinaison de touches ALT-quelqu’un, j’ai le "quelque chose" comme si ALT n’était pas pressé du tout. Le mécanisme "ALT" fonctionne bien dans toutes les autres applications que j'ai essayées; il habitué travailler dans Firefox (littéralement pendant des années et des années, jusqu’à l’autre jour).

J'ai essayé de courir sur un nouveau profil Firefox, et il se comporte de la même manière, donc je ne pense pas que ce soit un profil corrompu. J'ai un autre ordinateur portable, du matériel différent, mais essentiellement la même configuration que celle-ci, et Firefox et la touche "ALT" se passent bien là-bas.

Je n'ai aucune idée où commencer à essayer de diagnostiquer cela. Le problème général du traitement de frappe sur Linux est, je le sais, un domaine extrêmement complexe, mais comme ma clé "ALT" semble fonctionner parfaitement dans toutes les autres applications de l’ordinateur, je pense que cela a quelque chose à voir Configuration de Firefox

Quel pourrait être le problème? Que puis-je faire pour enquêter sur ce qui ne va pas?

modifier - Firefox désinstallé / réinstallé, aucun effet. Vous ne pouvez toujours pas trouver une autre application sur le système qui ne comprend pas la touche ALT.


4
2018-06-15 01:01


origine


Si vous pensez que cela devrait être dans "Ask Ubuntu", ça me va. - Pointy
Je sais que sous Windows, les clés sont gâchées lorsque vous travaillez avec des machines virtuelles. (Je ne sais pas si cela doit faire n'importe quoi avec ton problème, mais pensais que je le mentionnerais juste au cas où ...) - Mehrdad
Merci - Je ne pense pas que ce soit ce qui m'arrive ici, mais je parie que vous avez raison de dire que cela est une possibilité. Mon OS hôte est Ubuntu sur cette machine, et c'est le Firefox natif. Cela a bien fonctionné jusqu'à il y a quelques jours; J'ai dû changer quelque chose sans le savoir, mais je n'ai aucune idée de ce que c'était. - Pointy


Réponses:


Vous devrez peut-être réinitialiser le mappage de votre clavier


  • à partir d'un run de xterm setxkbmap suivi par xmodmap

Autres choses à vérifier

  • Retirer lvl3:ralt_switch si présent dans / etc / default / console-setup

analyser le résultat de cette procédure:

  • de xterm: xev | grep -B 4 -C 4 KeyPress 
  • déplacer la souris dans la fenêtre du terminal
  • faire une pression de touche en utilisant ALT GAUCHE
  • faites ensuite une pression sur une touche en utilisant DROITE-ALT

2
2018-06-15 03:40



Je vais faire ces choses, mais il convient de noter que mes touches ALT fonctionnent parfaitement bien dans chaque autre application que je lance sur ce système. Ses seulement Firefox qui a le problème. - Pointy
OK maintenant c'était une mauvaise idée. le setxkbmap Le programme a totalement éliminé toutes mes cartographies de clavier (que j'utilise littéralement depuis le début des années 1990, sans aucun problème). - Pointy
Eh bien, si c'est quelque chose en dehors de FF, comment se fait-il que FF soit la seulement chose affectée? Chrome, par exemple, obéit à la touche ALT. Ainsi fait xterm. Il en va de même pour toutes les autres applications que j'ai essayées, qui sont essentiellement toutes les fonctionnalités du système avec une interface graphique. - Pointy
le xev programme montre que mes touches ALT fonctionnent parfaitement. - Pointy
Oui, la touche ALT fonctionne dans chaque élément du système, à l'exception de Firefox. C'est sans doute un problème de Firefox. - Pointy


J'ai exactement le même problème (mon cas est archlinux) et j'ai trouvé un correctif qui fonctionne pour moi: Ajouter / modifier une ligne:

Option "XkbVariant" "intl"

à ton /etc/X11/xorg.conf.d/10-evdev.conf

Section "InputClass"
    Identifier "evdev keyboard catchall"
    MatchIsKeyboard "on"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    Option "XkbModel" "asus_laptop"
    Option "XkbVariant" "intl"
    Option "XkbLayout" "us"
EndSection

1
2017-07-05 07:20