Question Impossible de démarrer l'émulateur Windows Phone


Lorsque j'essaie de lancer / déboguer une application dans l'émulateur, j'obtiens cette erreur:  Can't start the Windows Phone Emulator. The Windows Phone Emulator couldn't start because the hypervisor isn't running. The likely cause is that hardware-assisted virtualization isn't turned on. Check your PC's BIOS and make sure that hardware-assisted virtualization and hardware-assisted data execution protection are turned on.

Et dans la console de liste d'erreurs de Visual Studio, elle dit simplement: 0x80131500

Je n'ai pas travaillé sur ce projet depuis environ une semaine, mais cela fonctionnait alors. J'ai vérifié le BIOS et tout est activé (comme c'était la semaine dernière). Je ne pense pas que cela soit lié, mais hier, j'ai amélioré mon SSD système et utilisé l'outil de migration de données Samsung pour cloner mon disque.

J'ai essayé de réparer le SDK 8.0 de Windows Phone, mais cela n'a pas aidé.

Est-ce qu'il y a d'autres choses que je peux essayer? Je ne pense vraiment pas que cela soit lié au SSD.

Services liés à Hyper-V: services
Je ne peux pas en lancer aucun non plus.


4
2018-02-17 07:52


origine




Réponses:


La suppression et la lecture du rôle Hyper-V ont résolu le problème (Gagner + r, optionalfeatures).


3
2018-02-17 18:29



Ne fonctionne pas pour moi. - RredCat
J'ai eu un tel problème lorsque mon PC a été cassé et les gars de l'informatique installer un nouveau système d'exploitation. J'ai immédiatement essayé d'installer Phone SDK. Mais quand j'ai installé toutes les mises à jour pour Windows 8, il a commencé .. (mais ne fonctionne pas, on dirait que j'ai une configuration cassée lorsque j'ai essayé de le récupérer). - RredCat
A travaillé pour moi J'ajouterais que "run" est la clé Windows + R chose, pas sous-menu dans Visual Studio. Il m'a fallu du temps pour comprendre ... - Chuck Boris