Question Pourquoi les applications de premier plan Windows 10 se lancent-elles mystérieusement en tant que processus d'arrière-plan?


Parfois, le Gestionnaire des tâches montre que "Store", "Settings" et / ou "Calculator" fonctionnent mystérieusement en arrière-plan.

  • Il n'y a pas d'application de premier plan correspondante, mais uniquement les processus d'arrière-plan.
  • Je n'ai pas exécuté de manière interactive non plus pendant la session en cours.
  • Ni est répertorié dans l'onglet "Tout" de AutoRuns.

Comme discuté dans ma réponse à cette question SuperUserCes deux processus d'arrière-plan retardent l'exécution des touches de raccourci Windows. Mais à part ça, c'est tout simplement bizarre.

Est-ce que quelqu'un sait pourquoi ces applications de premier plan se lancent mystérieusement en tant que processus d'arrière-plan?

Et, idéalement, comment puis-je l'empêcher de se produire? Comme discuté ailleurs (Superutilisateur et Thomas Vanhoutte), Je pourrais désinstaller les applications Calculator and Store. Mais il semble exagéré de les désinstaller simplement pour faire échec à un délai de raccourci.


26
2017-08-16 20:29


origine


Vérifiez dans Démarrer -> Paramètres -> Confidentialité> Applications en arrière-plan. Si ces applications sont répertoriées, définissez-les sur Off (Plus d'informations). - harrymc
+1 Grande astuce Store est répertorié, alors je l'ai décoché et nous verrons comment vont les choses. Malheureusement, la calculatrice ne figure pas dans la liste, alors je pense que cela continuera à poser problème. Je suis perplexe quant à savoir pourquoi Calculator (ou Store) serait lancé au hasard en arrière-plan. - Andy Giesler
Re "Ces deux processus d'arrière-plan retardent l'exécution des touches de raccourci Windows."Un autre problème est qu’ils apparaissent dans la liste des applications en cours lors de l’utilisation de bureaux virtuels tels que VirtuaWin, et le gestionnaire de bureau virtuel peut les rendre visibles. Ces deux choses sont gênantes. - ikegami


Réponses:


Store fonctionne probablement pour faire une vérification automatique des mises à jour.

Pour l'éteindre, allez à Start -> Settings -> Privacy -> Background apps et réglez-le sur Off.
Plus d'infos dans l'article: Comment activer ou désactiver les applications en arrière-plan dans Windows 10.

Vous pourriez également dans ce cas désactiver les mises à jour appliquées automatiquement en allant sur
Settings -> Update & Security -> Advanced options
et définir "Choisissez comment les mises à jour sont installées", à "Notifier pour planifier le redémarrage."

Pour la calculatrice:

Je crois que cette application moderne est parmi ceux qui Windows 10 a tendance à rester en mémoire s'il est utilisé une fois. Il fonctionne probablement en mode suspendu, en utilisant très peu de mémoire, prêt à être lancé rapidement lors de l'appel, ce qui est plus utile dans une tablette qu'un ordinateur.

Windows peut l'oublier si vous le tuez plusieurs fois en utilisant le Gestionnaire des tâches avant de fermer. Si cela fonctionne, je conseille à l’avenir d’utiliser une calculatrice tierce au lieu de la moderne, sinon elle reviendra.


21
2017-08-20 14:30



La chose la plus curieuse à propos de Calculator est que plus d’une fois, les choses suivantes se sont produites: Je démarre mon ordinateur, vérifie le gestionnaire de tâches et confirme qu’il ne fonctionne pas; puis un peu plus tard je le trouve en arrière-plan même si je ne l'ai pas exécuté pendant cette session. - Andy Giesler
Vous pourriez utiliser Explorateur de processus pour trouver dans les propriétés de la calculatrice son parent qui l'a lancé, mais je suppose que vous constaterez qu'il s'agit d'un composant de Windows. Vous pouvez toujours désinstaller la calculatrice comme montré ici, comme ce n'est pas aussi essentiel que le magasin, et utilisez à la place un tiers ou même celui de Windows 7 (Google pour cela). - harrymc


Désactiver le SuperFetch Le service peut empêcher les applications de démarrer par elles-mêmes.

Nous avons découvert qu'avec SuperFetch en cours d'exécution, certaines applications sont démarrées à l'état suspendu automatiquement une ou deux fois par heure, même après avoir explicitement tué leurs processus. Cela se produit pour les applications Windows Store / UI / Metro modernes telles que Photos, Calculatrice, Cartes, Météo, Heure, etc.

Comment désactiver SuperFetch

De la ligne de commande

Exécutez cette commande sous Administrator:

sc config sysmain start=disabled

En outre, arrêtez un SuperFetch en cours d'exécution:

sc stop sysmain

De l'interface utilisateur

  1. presse les fenêtres+R, tapez services.msc et appuyez sur Entrer.
  2. Trouver SuperFetch dans la liste, et double-cliquez dessus pour ouvrir ses propriétés.
  3. Ensemble Type de démarrage à désactivé.
  4. (Facultatif) Cliquez sur Arrêtez pour arrêter un SuperFetch en cours d'exécution.

    Disable SuperFetch

  5. Cliquez sur D'accord pour enregistrer les modifications


8
2017-09-10 09:21



SuperFetch ne "lance pas d'applications en arrière-plan". Preuve: Vous ne trouverez jamais un processus d'application créé par le processus SuperFetch. (La vue "Process Tree" de Process Explorer vous montrera quels processus ont été créés, quels autres processus, au moins tant que le créateur est présent.) - Jamie Hanrahan
@JamieHanrahan: OK, j'ai reformulé cela. - Helen
+1 - J'étais un peu sceptique, mais depuis la désactivation de SuperFetch, il n'y a pas eu une seule instance de mes applications problématiques (Calculator and Store) qui s'est lancée en arrière-plan. - Andy Giesler
Est-ce une bonne idée de désactiver cela? Il est destiné à réduire le temps de démarrage et à rendre le chargement des applications plus efficace. Pour moi, ce n'est pas tout à fait clair, mais depuis que Windows Vista existe, je suppose que cela aide vraiment. - this.lau_


Je constate également le problème de délai de la touche de raccourci dans Windows 10. Je crois que cela est dû à une application Metro placée dans l'état "suspendu" (comme indiqué par Process Explorer). Je l'ai vu causé par l'application Photos, l'application vidéo, l'application Calendrier, etc., qui semblent se lancer de manière aléatoire par eux-mêmes, comme il le rapporte.

Il semble donc que le délai de la touche de raccourci pose un problème général avec les applications (la plupart / toutes?) À l'état suspendu.

J'ai vérifié le paramètre Applications d'arrière-plan dans Confidentialité, mais il ne répertorie pas toutes les applications problématiques. Par exemple. la calculatrice et les applications vidéo n'y figurent pas.

Signalé sur le forum Microsoft: Délai de 3 secondes lors de l'utilisation du raccourci clavier pour lancer le programme

Ma solution pour le moment est d'avoir un fichier batch que je peux exécuter à la demande, éliminant les problèmes rencontrés avec taskkill / f.


3
2017-08-20 12:24





Avait le même problème, j'avais changé les paramètres des applications d'arrière-plan, et cela ne changeait rien, les mêmes applications apparaissaient en arrière-plan et restaient, la seule façon de les fermer était de les démarrer puis de les fermer, puis ils disparaîtraient de l'arrière-plan.

J'ai vu ici que la désactivation du superfetch était peut-être le moyen ... alors je ne l'ai pas fait. Je viens de supprimer tous les fichiers du dossier prefetch (c://windows/prefetch/) alors ça recommencerait.

Tout le redémarrage ultérieur de Windows n'a pas encore montré les applications d'arrière-plan problématiques.


0
2017-12-09 18:51