Question UFW est actif mais pas activé pourquoi?


J'essayais de configurer un pare-feu sur ma machine Ubuntu 12.04. Après quelques difficultés, j'ai obtenu ce qui suit. N'est-ce pas un peu bizarre?

thomas@thomas-K40IJ:~$ sudo ufw status verbose
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing)
New profiles: skip

To                         Action      From
--                         ------      ----
21/tcp                     ALLOW OUT   Anywhere
80                         ALLOW OUT   Anywhere
22                         ALLOW OUT   Anywhere
21/tcp                     ALLOW OUT   Anywhere (v6)
80                         ALLOW OUT   Anywhere (v6)
22                         ALLOW OUT   Anywhere (v6)

thomas@thomas-K40IJ:~$ sudo ufw reload
Firewall not enabled (skipping reload)
thomas@thomas-K40IJ:~$ sudo ufw enable 
ERROR: Could not load logging rules
thomas@thomas-K40IJ:~$

De plus, mon pare-feu semble désactivé après le redémarrage. Qu'est-ce que je rate?


4
2018-05-02 13:29


origine


La désactivation de la journalisation (sudo ufw loging off) a résolu le problème. - Thomas
Utilisez l'interface graphique GUFW pour UFW (Uncomplicated Firewall), c'est plus simple ... - Prasad RD


Réponses:


mateusz@debian:~$ sudo ufw disable
Firewall stopped and disabled on system startup

mateusz@debian:~$ sudo ufw status verbose
Status: inactive

mateusz@debian:~$ sudo ufw enable
ERROR: problem running ufw-init

Même en cas d'erreur, vous pouvez vérifier que ufw est en cours d'exécution.

mateusz@debian:~$ sudo ufw status verbose
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing)
New profiles: skip

To                         Action      From
--                         ------      ----
80/tcp                     ALLOW IN    Anywhere
22/tcp                     ALLOW IN    Anywhere

ou

mateusz@debian:~$ sudo service ufw status
[ ok all is running...done.

Vous pouvez facilement configurer manuellement ENABLED=yes dans ufw config

sudo nano /etc/ufw/ufw.conf

qui contient:

# /etc/ufw/ufw.conf
#

# Set to yes to start on boot. If setting this remotely, be sure to add a rule
# to allow your remote connection before starting ufw. Eg: 'ufw allow 22/tcp'
ENABLED=no

# Please use the 'ufw' command to set the loglevel. Eg: 'ufw logging medium'.
# See 'man ufw' for details.
LOGLEVEL=low

9
2017-09-18 10:35





ufw possède une interface graphique qui pourrait vous aider à configurer le pare-feu plus facilement. Il devrait être installé par défaut, mais si vous ne l’avez pas, faites-le avec sudo apt-get install gufw.
Voici un guide sur son utilisation https://help.ubuntu.com/community/Gufw


0
2018-05-02 15:42