Question Empêcher OSX d'utiliser des guillemets "intelligents"


Y a-t-il un moyen d'empêcher OSX d'utiliser des guillemets doubles et simples par défaut? J'utilise Evernote pour stocker les commandes SQL à titre de référence et non pour obtenir " et ' en tapant je me retrouve avec  et . C'est ennuyant pour le moins qu'on puisse dire.

D'après ce que j'ai compris, cela n'a rien à voir avec Evernote, car il utilise simplement le schéma de codage standard pour OSX.


4
2018-05-02 18:36


origine




Réponses:


Cliquez simplement deux doigts (à droite) sur la zone de texte Evernote et sélectionnez Substitutions et décochez Smart Quotes. Cela fonctionne pour beaucoup de zones de texte, mais pas <textarea>s.

"Substitutions" and uncheck "Smart Quotes"

Si vous souhaitez le désactiver globalement, ouvrez System Preferences, sélectionnez Keyboard, sélectionnez Text, puis décochez Use smart quotes and dashes.

enter image description here


9
2018-05-02 20:43



Je suppose que c'était une chose spécifique à Evernote après tout. Je ne serais pas opposé à le désactiver globalement pour toutes les applications si possible. - ghostfly
@ghostfly Volià - evan.bovie
Parfait. Très appréciée. - ghostfly


Ce n'est pas un problème de Mac OS, mais plutôt un problème de police.
Quelle police utilisez-vous dans Evernote? Essayez d'utiliser une police monotype comme Andale Mono.
Je viens de tester: taper un simple SQL dans Evernote, copier-coller dans Sequel Pro et obtenir des résultats.


0
2018-05-02 19:23



C'est beaucoup plus subtil dans Andale Mono, mais il utilise toujours les versions bouclées. Je n'ai jamais utilisé Sequel Pro, mais peut-être que c'est en train de le convertir pour vous. - ghostfly
Utilisez-vous une langue autre que l'anglais américain? - Traveling Tech Guy
Vérifié sur ceci - SequelPro Est-ce que convertir automatiquement les smartquotes en normales, mais les autres applications ne seront pas aussi indulgentes. La réponse de @ evan.bovie est exacte. - Don McCurdy