Question Comment configurer GIMP 2.8 pour en faire une fenêtre unique dans XMonad?


J'essaie de faire en sorte que GIMP apparaisse comme une seule fenêtre dans XMonad. Actuellement, il flotte étrangement devant tous les autres écrans et je ne peux pas l'utiliser.

J'ai essayé de lire ceci:

http://www.haskell.org/haskellwiki/Xmonad/General_xmonad.hs_config_tips#Gimp

Mais il semble que ce soit pour les versions de GIMP antérieures à 2.8 quand il n’était pas possible d’utiliser uniquement une fenêtre pour GIMP. À cause de cela, c'est un problème XMonad, pas un problème GIMP.

Comment puis-je faire ceci?


4
2018-06-14 17:19


origine


Quelle est votre version de Xmonad? - ItsNotAboutTheName
@Nima version 0.10-4 - Pubby
Ok pouvez-vous fournir votre xmonad.hs? - ItsNotAboutTheName
@Nima La seule chose que j'ai changée est des raccourcis différents, sinon c'est la valeur par défaut. - Pubby
Je souhaite que GIMP / Steam / Evince arrête d'essayer de gérer mal les fenêtres et laisse le gestionnaire de fenêtres faire son travail! - Mark K Cowan


Réponses:


Gimp 2.8 a une option dans le menu "Windows" intitulé "Single Window Mode". Vérifiez cela et redémarrez Gimp.

pic of option in gimp


10
2018-06-19 03:41



Euh, peut-être un whoops ... Cette option n'aide-t-elle pas Xmonad? Allez les gens, flambez moi ... {soupir} - lornix
J'ai cette option cochée mais XMonad le traite étrangement et le place devant tout le reste. - Pubby
@Pubby: Essayez de fixer les fenêtres flottantes à droite et à gauche de la fenêtre centrale. - harrymc


Je vais essayer de nouveau.

Comment débloquer Gimp

Le lien contient pas mal d'informations sur l'utilisation de Xmonad. Plusieurs références à cette page.

Un de plus, concernant spécifiquement Gimp:

regarder dans les réponses ci-dessous la partie principale de l'article

La partie pertinente:

Mais xmonad fait également flotter toutes les fenêtres gimp par défaut. Je l'utilise pour éviter de faire flotter les deux fenêtres principales:

managehook = composeall [
    gimp "toolbox" --> (ask >>= doF . W.sink),
    gimp "image-window" --> (ask >>= doF . W.sink),
    manageHook defaultConfig
]
where gimp win = (className =? “Gimp” (fmap (win `isSuffixOf`) role))
role = stringProperty “WM_WINDOW_ROLE”

0
2018-06-19 03:56



Je pense que je vais juste quitter maintenant alors que je suis en avance ... Je viens juste de poster le même lien ... {Sigh} Je suis vraiment désolé de vous avoir dérangé .. Une chance sur un peu d'amour pour le SECOND lien ? - lornix


OK, j'ai eu le même problème et j'ai trouvé la meilleure solution (du moins pour moi) alors que je cherchais en ligne: il suffit d'aller dans window -> single-window mode. Ensuite, faites passer la fenêtre en plein écran avec mod + t (c'est la liaison par défaut).

Je sais que la première partie a déjà reçu une réponse, mais cette partie seule ne rassemble que toutes les fenêtres gimp dans une seule, il s'agit toujours d'une fenêtre flottante, et je n'aime pas ça dans mon xmonad.


0
2017-12-13 16:41