Question Désactiver définitivement le deuxième écran


Le moniteur de mon ordinateur portable ne fonctionne plus et j'ai donc connecté un moniteur externe.

Au démarrage, GDM reconnaît toujours l'écran principal de l'ordinateur portable et affiche sa fenêtre de connexion. Ce que je ne peux alors pas voir.

Je peux désactiver l'écran de l'ordinateur portable en cours d'exécution xrandr --output LVDS1 --off après vous être connecté. J'ai essayé de mettre cette commande dans ~\.xinitrc et dans un ./40-xrandr.sh dans /etc/X11/xinit/xinitrc.d.

Les deux sans aucun effet. J'avais espéré que cela éteindrait au moins l'écran de l'ordinateur portable lors de la connexion.

Comment puis-je désactiver l'écran de l'ordinateur portable avant GDM commence?


4
2017-07-31 21:34


origine


Le BIOS peut avoir une option pour définir le moniteur par défaut. Un grand nombre de BIOS portables modernes ont ceci. Vérifiez votre manuel BIOS. Lorsqu'il est correctement configuré et que votre second moniteur est branché, le BIOS le traitera comme principal (votre système d'exploitation pensera qu'il s'agit de l'écran principal), sinon il retournera à l'écran de l'ordinateur portable. - ADTC
Je l'ai cherché, mais le BIOS ne fournit pas une telle option. - phw
Aucun paramètre du BIOS avec les options comme LCD interne et Externe? Eh bien, je suis désolé alors. Cela aurait été la solution la plus simple. - ADTC
Oui je sais. J'espérais ça aussi. Et c'est même un «système d'entreprise» (Dell Latitude D830) ... - phw
Est-ce que ce correspond à votre écran BIOS? Je vois un Vidéo option sur la gauche. Il semble avoir des sous-options (comme indiqué par le +). Quelles sont les options disponibles sous Vidéo? Il y a tellement de variations dans les BIOS que l'on ne peut pas identifier exactement quelle option utiliser, à moins de l'examiner. Et les terminologies / descriptions utilisées par le fabricant sont souvent inadéquates, déroutantes ou trompeuses. - ADTC


Réponses:


Cela fait que linux ignore complètement la sortie LVDS. De cette façon, il ne sera pas utilisé par tous les gestionnaires de connexion et n'apparaîtra pas dans les boîtes de dialogue de configuration d'affichage.

Créer un fichier /usr/share/X11/xorg.conf.d/50-disable-lvds.conf et écris là:

Section "Monitor"
        Identifier      "lvds monitor"
        Option  "ignore"        "true"
EndSection
Section "Device"
        Identifier      "onboard"
        Option  "Monitor-LVDS1" "lvds monitor"
EndSection

6
2017-12-25 10:55



Belle addition! Merci! - phw
Réponse correcte à mon humble avis, depuis apparemment video=LVDS-1:d peut être ignoré par le serveur X. - JohnnyFromBF


modifier / etc / default / grub et ajouter

video=LVDS-1:d video=VGA-1:e

: d désactiver: e activer.

Par exemple le mien est

GRUB_CMDLINE_LINUX_DEFAULT="video=LVDS-1:d video=VGA-1:e acpi=force elevator=noop i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40"acpi=force elevator=noop i8042.noloop=1 usbhid.quirks=0xeef:0x1:0x40"

J'espère que cela t'aides


2
2017-07-31 23:00



Bien que cela devrait travail, il n'a pas en combinaison avec GDM3. Merci pour le conseil. - phw


Malheureusement, la réponse à Halox n'a pas résolu le problème, car GDM3 configure le serveur X sur son propre serveur et réactive le moniteur désactivé (idiot).

Après lire les docs J'ai ajouté xrandr --output LVDS1 --off Au sommet de /etc/gdm/Init/Default et l'a finalement fait fonctionner.


2
2017-08-01 11:26