Question Impossible d'installer matplotlib dans cygwin (problème de type libre)


Ce serait vraiment bien d'avoir matplotlib dans mon environnement cygwin. J'ai Windows 8 64 bits avec cygwin 64 bits.

Quand je tape:

pip install matplotlib

Je reçois le message d'erreur suivant:

 * The following required packages can not be built:
 * freetype

Comme pour apt-cyg, les paquets suivants sont déjà installés:

Searching for installed packages matching freetype: 
cygwin32-freetype2
freetype2-debuginfo
libfreetype-devel
libfreetype-doc
libfreetype6

De quoi d'autre a-t-il besoin? Comment installer freetype & matplotlib correctement?


4
2018-06-18 00:25


origine




Réponses:


J'ai eu le même problème sur Windows 7 64 bits; Je l'ai résolu en installant les paquets Cygwin pkg-config et libX11-devel avant de taper easy_install matplotlib==1.1.1 (la version 1.3.1 contient des erreurs sur ma machine, d'où le 1.1.1).


9
2017-07-23 12:24



Merci pour la suggestion, je vais l'essayer. Pour ma part, j'utilise simplement matplotlib en dehors de cygwin (installation Windows normale). - Alexey Petrenko


J'ai aussi eu le même problème sur cygwin Windows 8 64-bit. J'ai suivi les conseils dans une autre réponse (installer pkg-config et libX11-devel) mais le paquet qui m'a finalement permis d'installer matplotlib était libfreetype-devel. Alors juste easy_install matplotlib==1.4.2.


3
2017-12-24 16:54