Question Synergy se connecte, mais la souris ne change pas d'écran (et aucune sortie de débogage ne présente un problème)


Essayer de configurer Synergy, et ne semble pas avoir bien compris. Voici la configuration:

  • Serveur: WinXP avec écran nommé TV
  • Client: Ubuntu 11.04 nommé PORTABLE

Configuration du serveur:

section: screens
    LAPTOP:
        halfDuplexCapsLock = false
        halfDuplexNumLock = false
        halfDuplexScrollLock = false
        xtestIsXineramaUnaware = false
        switchCorners = none +top-left +bottom-left 
        switchCornerSize = 0
    TV:
        halfDuplexCapsLock = false
        halfDuplexNumLock = false
        halfDuplexScrollLock = false
        xtestIsXineramaUnaware = false
        switchCorners = none +top-right +bottom-right 
        switchCornerSize = 0
end

section: links
    LAPTOP:
        right = TV
    TV:
        left = LAPTOP
end

section: options
    relativeMouseMoves = false
    screenSaverSync = false
    win32KeepForeground = false
    switchCorners = none 
    switchCornerSize = 0
    keystroke(F12) = lockCursorToScreen(toggle)
end

Lorsque je me connecte, le journal du serveur indique:

2011-07-04T09:57:18 NOTE: client "LAPTOP" has disconnected
    ..\lib\server\CClientProxy1_0.cpp,209

2011-07-04T09:57:21 NOTE: accepted client connection
    ..\lib\server\CClientListener.cpp,130
2011-07-04T09:57:21 NOTE: client "LAPTOP" has connected
    ..\lib\server\CServer.cpp,299

2011-07-04T09:57:38 NOTE: client "LAPTOP" has disconnected
    ..\lib\server\CClientProxy1_0.cpp,209

2011-07-04T10:01:48 NOTE: accepted client connection
    ..\lib\server\CClientListener.cpp,130
2011-07-04T10:01:48 NOTE: client "LAPTOP" has connected
    ..\lib\server\CServer.cpp,299

2011-07-04T10:01:53 INFO: screen "LAPTOP" grabbed clipboard 1 from "TV"
    ..\lib\server\CServer.cpp,1239

2011-07-04T10:01:53 INFO: screen "LAPTOP" updated clipboard 1
    ..\lib\server\CServer.cpp,1524

2011-07-04T10:02:02 NOTE: client "LAPTOP" has disconnected
    ..\lib\server\CClientProxy1_0.cpp,209

2011-07-04T10:07:01 NOTE: accepted client connection
    ..\lib\server\CClientListener.cpp,130
2011-07-04T10:07:01 NOTE: client "LAPTOP" has connected
    ..\lib\server\CServer.cpp,299

2011-07-04T10:08:40 INFO: screen "LAPTOP" grabbed clipboard 1 from "LAPTOP"
    ..\lib\server\CServer.cpp,1239

2011-07-04T10:08:40 INFO: screen "LAPTOP" updated clipboard 1
    ..\lib\server\CServer.cpp,1524

Sur le client, je cours: synergyc -d DEBUG -f -n LAPTOP -l --log = / tmp / synergy.debug TV

2011-07-04T10:06:50 INFO: Synergy 1.3.6 Client on Linux 2.6.38-10-generic #44+kamal~mjgbacklight4-Ubuntu SMP Mon Jun 6 19:40:12 UTC 2011 x86_64
    /build/buildd/synergy-1.3.6/cmd/synergyc/synergyc.cpp,765
2011-07-04T10:06:50 DEBUG: XOpenDisplay(":0")
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsScreen.cpp,889
2011-07-04T10:06:50 DEBUG: xscreensaver window: 0x00000000
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsScreenSaver.cpp,342
2011-07-04T10:06:50 DEBUG: screen shape: 0,0 1920x1080 
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsScreen.cpp,131
2011-07-04T10:06:50 DEBUG: window is 0x07e00004
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsScreen.cpp,132
2011-07-04T10:06:50 DEBUG: opened display
    /build/buildd/synergy-1.3.6/lib/synergy/CScreen.cpp,41
2011-07-04T10:06:50 NOTE: started client
    /build/buildd/synergy-1.3.6/cmd/synergyc/synergyc.cpp,339
2011-07-04T10:06:50 NOTE: connecting to 'TV': 192.168.1.75:24800
    /build/buildd/synergy-1.3.6/lib/client/CClient.cpp,115
2011-07-04T10:06:59 DEBUG: open clipboard 0
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsClipboard.cpp,316
2011-07-04T10:06:59 DEBUG: empty clipboard 0
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsClipboard.cpp,269
2011-07-04T10:06:59 DEBUG: grabbed clipboard 0
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsClipboard.cpp,292
2011-07-04T10:06:59 DEBUG: close clipboard 0
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsClipboard.cpp,351
2011-07-04T10:06:59 DEBUG: open clipboard 1
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsClipboard.cpp,316
2011-07-04T10:06:59 DEBUG: empty clipboard 1
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsClipboard.cpp,269
2011-07-04T10:06:59 DEBUG: grabbed clipboard 1
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsClipboard.cpp,292
2011-07-04T10:06:59 DEBUG: close clipboard 1
    /build/buildd/synergy-1.3.6/lib/platform/CXWindowsClipboard.cpp,351
2011-07-04T10:06:59 NOTE: connected to server
    /build/buildd/synergy-1.3.6/cmd/synergyc/synergyc.cpp,256

Cependant, même si tout semble être connecté, ma souris sur mon ordinateur portable ne laisse jamais l’écran actuel.

Je ne vois aucun message de débogage pouvant aider. Quelqu'un voit-il quelque chose que je fais mal?

TIA


4
2017-07-04 14:23


origine




Réponses:


Il s'avère que vous pouvez utiliser Scroll Lock pour garder la souris bloquée sur un écran! Donc, essayez d'appuyer sur ScrollLock pour voir si cela libère la souris.


12
2018-01-31 15:14



C'était presque ennuyeux. - isaaclw


J'utilisais juste Fedora 28 et Ubuntu 18.04 LTS, le verrou Scroll n'a pas aidé. Mais qu'est-ce qui a aidé était

  • Fedora 28, je suis revenu à la même version 1.8.8 que Ubuntu 18.04
  • Désactiver Wayland sur Fedora et Ubuntu les deux
  • Redémarrez (le bisou de Goodluck)

et le tour est joué!


1
2018-05-07 06:22





mis à jour de 1.4.8 à 1.4.10 et ce problème est apparu pour moi

Serveur: win7-64bit Synergy-v1.4.10 Client: Thinkpad T430s Ubuntu-v12.04-32bit Synergy-v1.4.10

essayé avec une machine différente du côté du client et toujours pas aller: Client: Thinkpad T420s Ubuntu-v12.10-32bit Synergy-v1.4.10

également essayé d'utiliser le client 1.4.8 dans Ubuntu avec le serveur 1.4.10 dans Windows et les mêmes problèmes.

J'ai donc finalement désinstallé synergy 1.4.10 du client et du serveur et réinstallé la v1.4.8 sur les deux et tout fonctionne très bien. même config utilisé sur les deux versions donc pas que ...


0
2017-12-06 22:03



désolé j'ai oublié de mentionner que j'ai essayé de jouer avec les boutons SCRLK sur les deux machines trop longtemps. Je l’ai fait fonctionner une fois et je pense que j’ai eu une combinaison de touches mais je ne pouvais plus les retrouver, alors je ne pouvais pas le faire fonctionner après le redémarrage ou le redémarrage du service. - syner-marr
Cela ne devrait pas vraiment être un commentaire, mais un montage. Cliquez sur edit sous votre question et mettre le contenu de votre commentaire dans la question, puis supprimez votre commentaire. - BenjiWiebe