Question Configuration de Mutt pour Gmail


J'essaie de configurer Mutt pour Gmail. je suis Instructions du wiki Crunchbangcependant, après avoir mis

set from = "yourusername@gmail.com"
set realname = "Your Real Name"

set imap_user = "yourusername@gmail.com"
set imap_pass = "yourpassword"

(avec mes coordonnées, bien sûr), je reçois

$ mutt
Error in $HOME/.muttrc, line 12: imap_user: unknown variable
Error in $HOME/.muttrc, line 13: imap_pass: unknown variable
source: errors in $HOME/.muttrc
Press any key to continue...

Si j'essaie d'envoyer un courrier électronique, cela ne fonctionne pas car au lieu d'IMAP, il essaie d'envoyer un courrier électronique directement à partir du système de messagerie de mon localhost. Mutt dit que c'est la version Mutt 1.4.2.3i.

Mettre à jour:

J'ai donc téléchargé mutt-devel sur Macports, qui est 1.5:

$ mutt -v
Mutt 1.5.21 (2010-09-15)
Copyright (C) 1996-2009 Michael R. Elkins and others.
Mutt comes with ABSOLUTELY NO WARRANTY; for details type `mutt -vv'.
Mutt is free software, and you are welcome to redistribute it
under certain conditions; type `mutt -vv' for details.

System: Darwin 11.3.0 (x86_64)
ncurses: ncurses 5.9.20110404 (compiled with 5.9)
libiconv: 1.14
libidn: 1.22 (compiled with 1.22)
Compile options:
-DOMAIN
-DEBUG
-HOMESPOOL  +USE_SETGID  +USE_DOTLOCK  +DL_STANDALONE  +USE_FCNTL  -USE_FLOCK   
+USE_POP  +USE_IMAP  -USE_SMTP  
-USE_SSL_OPENSSL  -USE_SSL_GNUTLS  -USE_SASL  -USE_GSS  +HAVE_GETADDRINFO  
+HAVE_REGCOMP  -USE_GNU_REGEX  
+HAVE_COLOR  +HAVE_START_COLOR  +HAVE_TYPEAHEAD  +HAVE_BKGDSET  
+HAVE_CURS_SET  +HAVE_META  +HAVE_RESIZETERM  
+CRYPT_BACKEND_CLASSIC_PGP  +CRYPT_BACKEND_CLASSIC_SMIME  -CRYPT_BACKEND_GPGME  
-EXACT_ADDRESS  -SUN_ATTACHMENT  
+ENABLE_NLS  -LOCALES_HACK  +HAVE_WC_FUNCS  +HAVE_LANGINFO_CODESET  +HAVE_LANGINFO_YESEXPR  
+HAVE_ICONV  -ICONV_NONTRANS  +HAVE_LIBIDN  +HAVE_GETSID  -USE_HCACHE  
-ISPELL
SENDMAIL="/usr/sbin/sendmail"
MAILPATH="/var/mail"
PKGDATADIR="/opt/local/share/mutt"
SYSCONFDIR="/opt/local/etc"
EXECSHELL="/bin/sh"
-MIXMASTER
To contact the developers, please mail to <mutt-dev@mutt.org>.
To report a bug, please visit http://bugs.mutt.org/.

En l'état, il n'est pas configuré pour utiliser smtp, mais imap doit être activé. Cependant, juste commencer mutt se bloque

Connecting to gmail.com...

Y a-t-il un moyen de vérifier les journaux ou quelque chose pour voir si, disons qu'il ne trouve pas le serveur ou que le mot de passe est rejeté ou autre chose?

Mettre à jour:

Après l'installation pour le support de ssl, imap et smtp, je reçois toujours ces avertissements / erreurs, même s'il peut se connecter à gmail.

Error in $HOME/.muttrc line 9: trash: unknown variable
Error in $HOME/.muttrc, line 11: header_cache: unknown variable

5
2018-03-20 19:09


origine


Tout a fonctionné selon ce guide avec le mutt 1.5.21, qui date du 2010-09-15. Le #! Le guide montre cette configuration car elle est basée sur Debian, et le dépôt stable de Debian a la version 1.5.20 - Rob
Merci, @Rob! J'ai mis à jour à 1.5.21, et il semble que je ne peux pas encore me connecter à Gmail. - highBandWidth
Avez-vous défini le reste du fichier? Voici mon fichier (sans mot de passe) sprunge.us/RKdW - Rob
@Rob, merci! Cependant, il ne reconnaît pas certains des paramètres tels que la corbeille et header_cache. - highBandWidth


Réponses:


Tout d'abord, vous pouvez vérifier si vous êtes muté IMAP et SMTP par exec
mutt -v

FLAG comme +USE_IMAP et +USE_SMTP

si vous voulez utiliser IMAP, dans votre muttrc doit avoir

set imap_user = "YOUR.EMAIL@gmail.com"
set imap_pass = "PASSWORD" 
set folder = "imaps://imap.gmail.com:993"
set spoolfile = "+INBOX" 

Si j'essaye d'envoyer un email, ça ne marche pas car au lieu d'IMAP, ça   essaie d'envoyer un courriel directement à partir du système de messagerie de mon localhost

IMAP?
Peut-être que vous vouliez est SMTP

set smtp_url = "smtp://yourusername@smtp.gmail.com:587/"
set smtp_pass = "yourpassword"

ou vous pouvez installer des programmes externes comme esmtp ou msmtp


5
2018-03-21 08:53