Question Comment puis-je désactiver l'avertissement donné par Chrome si un certificat de sécurité n'est pas approuvé?


Je veux savoir s'il est possible de désactiver l'avertissement que vous recevez dans Chrome lorsque vous essayez d'accéder à un site HTTPS ne disposant pas d'un certificat de confiance.

J'ai quelques sites dans mes favoris qui utilisent le protocole HTTPS, mais aucun d'entre eux ne possède des certificats de confiance. Chaque fois que je les visite, je dois cliquer sur "Continuer quand même" dans l'avertissement et cela devient ennuyant.

Est-il possible de désactiver l'avertissement ou d'ajouter ces sites à une liste de sécurité?


154
2017-08-21 15:43


origine


Au cas où, vérifiez les paramètres de date / heure de votre appareil. - Timo Huovinen
Vous pourriez juste taper badidea n'importe où sur la page lorsque vous voyez l'avertissement (ne le faites que sur les sites que vous connaissez ne sont pas compromis). Vous devrez peut-être le faire plusieurs fois, mais vous verrez que cela fonctionne très bien. - Jeremy


Réponses:


sippa,
Lorsque vous utilisez les options de Google Chrome> Gérer les certificats> Importer, où placez-vous le certificat? Sur l'écran "Certificate Store" de l'importation, choisissez "Placer tous les certificats dans le magasin suivant" et recherchez "Autorités de certification racine de confiance". Redémarrez Chrome. Cela fonctionne normalement pour moi.


32
2017-09-16 02:08



ne fonctionne pas dans Chrome 11.0.696.71 (86024) sur Ubuntu 11.04 :( - Radu Maris
Chrome me demande le mot de passe d'un certificat: "Veuillez saisir le mot de passe utilisé pour chiffrer ce fichier de certificat" - kachar
Vous devez tout d'abord exporter le certificat SSL (le certificat non fiable) à partir du site pour lequel vous souhaitez ajouter une exception. Vous pouvez le faire en cliquant sur l'icône représentant un cadenas rouge à gauche de l'URL. De là, vous obtenez un menu déroulant avec un lien "Informations sur le certificat". Cliquez sur ce lien, allez dans l'onglet «Détails» et «copier dans un fichier». J'ai utilisé les options par défaut, exportées sur mon bureau puis suivies comme suggéré par cornelius10. Dans les paramètres -> paramètres avancés, il y aura une section SSL. Allez-y et importez le certificat que vous venez d'exporter. A travaillé un régal pour moi. - Lukey
J'ai essayé ceci et d'autres permutations suggérées ici et rien ne fonctionne. J'importe le certificat mais le message "Votre connexion n'est pas privée" est toujours affiché. Est-ce toujours une solution valable? - Klas Mellbourn
Six ans plus tard, Chrome a totalement gâché les certificats auto-signés. Je l'ai fait exactement comme vous l'avez décrit, mais cela a seulement changé le message d'erreur en NET :: ERR_CERT_COMMON_NAME_INVALID - Amalgovinus


Vous pouvez indiquer à Chrome d'ignorer toutes les erreurs SSL en transmettant ce qui suit sur la ligne de commande:

--ignore-certificate-errors

Je commence Chrome à partir de bash en utilisant ceci:

/Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome --ignore-certificate-errors &> /dev/null &

et ça marche super bien. Notez que cela devrait seulement être utilisé pour tester les sites de développement, et ne devrait pas être utilisé par un utilisateur final type.

Pourquoi? Parce que Chrome ne parlera pas des mauvais certs sur les "vrais" sites aussi! Donc, n'utilisez cela que si vous êtes développeur!

Si vous ne voulez que cela pour les certificats SSL locaux, vous pourrez peut-être simplement utiliser cette option dans Chrome, allow-insecure-localhost:

chrome: // flags / # allow-insecure-localhost

Sur une note associée, si vous souhaitez créer des certificats SSL auto-signés entièrement approuvés pour Chrome / Safari, vous pouvez savoir comment faire cela ici


73
2018-02-05 14:23



Fonctionne sur Windows aussi! - Chaoix
Ce devrait être la réponse acceptée - c'est une telle réponse à savoir que ce n'est même pas drôle. Merci Brad! - Danail Gabenski
C'était la solution que je cherchais. Fonctionne sous Windows. Doit travailler sur d'autres plateformes également. Lancez simplement l'exécutable avec l'indicateur mentionné. - Srinivas Gollapudi
@BradParks a l'air d'avoir du chrome.exe en cours d'exécution que je devais forcer à quitter, puis ça a fonctionné à nouveau pour moi. J'ai toujours le "Vous utilisez un indicateur de ligne de commande non pris en charge: --ignore-certificate-errors. La stabilité et la sécurité vont en souffrir." Je n'aime vraiment pas voir les choses souffrir, en particulier la sécurité. Est-ce que ça s'en va à un moment donné? - ScottN
Cool! Je pense que cet avertissement restera probablement là pour toujours, pour que les utilisateurs sachent que chrome ignore les certificats SSL. Sinon, quelqu'un pourrait exécuter un faux site avec un certificat SSL invalide et modifier votre configuration de lancement Chrome pour ignorer les certificats SSL, et Chrome y accéderait de cette façon sans aucun avertissement! - Brad Parks


Vous pouvez éviter le message pour les sites de confiance en installant le certificat.

Cela peut être fait en cliquant sur l'icône d'avertissement dans la barre d'adresse, puis cliquez sur

"Informations sur le certificat" -> Onglet Détails -> Copier dans un fichier

Enregistrez le certificat, puis double-cliquez sur le fichier de certificat. Dans la fenêtre de certificat qui s'ouvre, cliquez sur Installer le certificat, puis parcourez l'installation.

La prochaine fois que vous visiterez le site, cela devrait fonctionner sans erreur.


34
2017-08-21 15:57



Hmm .. J'ai essayé ce que vous avez dit sur deux sites, mais cela ne semble pas fonctionner. Pensez-vous que je dois redémarrer après avoir installé le certificat? - sippa
J'ai également essayé d'aller dans Options dans Chrome, puis Gérer les certificats et les importer de cette façon. Il dit importé avec succès mais il n'apparaît pas dans la liste. - sippa
Ça ne fonctionne pas - Harikrishnan
son 2016. Bonjour? Chrome ne nous écoute pas. - YumYumYum
des frissons42 ça a fonctionné pour moi, ouf! Merci! - Sajjan Sarkar


Pour Chrome sur OSX, voici un moyen relativement simple d’ajouter le certificat auto-signé au trousseau du système, utilisé par Chrome: Google Chrome, Mac OS X et certificats SSL auto-signés. Plus besoin d'écran d'alerte rouge ennuyant! (J'aimerais bien que Chromium simplifie l'ajout de l'exception)


17
2018-01-12 02:09



Je vous remercie. Si vous recevez l'erreur 100013 lors de l'ajout via Keychain Access, reportez-vous à cette page: bit.ly/jBujt1 - Chris Serra
@ChrisSerra - J'essaie de suivre votre lien, mais obtenez un 404; pouvez-vous préciser quelles étaient les instructions? - EmmyS
@EmmyS: Je suis désolé - je ne me souviens vraiment pas. J'essayais de trouver la page dans Google Cache, mais elle n'a pas réussi. Je vais essayer de revoir le processus et voir si la mémoire musculaire m'aide à rappeler la solution. - Chris Serra
@ChrisSerra - pas grave; nous avons compris comment le faire. - EmmyS
Merci pour le lien. Ça a marché. Il semble que le CN du certificat doit toujours correspondre au domaine de l'URL même après ces étapes. De plus, l'étape 5 sur ce site n'est pas nécessaire. Il peut être ajouté à votre trousseau de connexion et n'a pas besoin d'être dans le trousseau du système. - mhost


Instructions pour Linux (Chrome 12+):

Certificate Information -> Details -> Export

Enregistrez le certificat en tant que fichier de votre choix.

Preferences -> Under the hood -> Manage certificates -> Authorities

Importez le fichier et cochez toutes les cases lorsqu'il vous le demande. Vous avez terminé.

C'est très important importer sous le Onglet Autoritéset pas d'autres!


12
2017-08-05 07:36



Le fichier contenait un certificat, qui n'a pas été importé: xxx.xxxxx.com: pas une autorité de certification. - kachar
Eh bien, on dirait que vous n'avez pas d'autorité cert. Essayez différents onglets La question est pour les autorités ... - lzap
Oui, ça a fonctionné sur l'onglet 'Autres certificats' - kachar
Enfin une réponse qui fonctionne! Merci beaucoup! - Andre Figueiredo


Sur OsX, vous devez exporter votre certificat depuis Firefox et importer sur le trousseau sous le profil de connexion.


3
2017-11-18 23:09





Pour que cela fonctionne, je devais copier dans un fichier en utilisant l'option "Cryptographic Message Syntax Standard - Certificats PKCS # 7 (.P7B)" et cocher la case "Inclure tous les certificats dans le chemin de certification si possible".

Ensuite, j'ai importé en utilisant les instructions de Cornelius et cela a fonctionné.


1
2018-06-02 13:10



Cela me donne toujours "NET :: ERR_CERT_COMMON_NAME_INVALID" .. - Amalgovinus


Si le site sur lequel vous allez, votre propre serveur, assurez-vous d'avoir installé le certificat auto-signé ou un certificat auprès d'une autorité de confiance sur votre serveur. Certains logiciels serveur définissent le certificat de test par défaut, qui ne peut pas être ajouté au magasin de certificats Autorités racine approuvées.


1
2017-07-04 10:07





Si le paternalisme de Google devient insupportable un péché:

nous ne voulons pas d'utilisateurs pour visiter un site avec un certificat révoqué. Si vous pensez que ce rapport de bogue concerne le n ° 2, je   marquez-le WontFix. Voulez-vous que je fasse ça?

Vous pouvez annuler complètement le système TLS du navigateur en utilisant un proxy TLS qui signe toutes les ouvertures de connexion TLS avec sa propre autorité de certification racine TLS. De toute évidence, cela a des conséquences désagréables, comme l’impossibilité de visualiser le véritable certificat d’un site Web avec l’interface Chrome. De plus, les certificats TLS clients ne sont par nature pas compatibles avec ce proxy TLS.

De nombreuses extensions Google Chrome vous permettent de sélectionner des serveurs proxy basés sur le domaine. Vous ne pouvez donc proxy que les domaines connus pour causer des problèmes avec TLS dans Chrome.


0
2017-07-11 01:24