Question Les applications Windows continuent à passer au texte accentué


D'une manière ou d'une autre, je continue à appuyer sur une touche de raccourci (ou quelque chose de similaire) qui permet de saisir du texte accentué. Chaque fois que ce mode de texte accentué est activé, appuyez sur 'ne répond pas immédiatement; au lieu de cela, la clé est mémorisée, donc si j'appuie sur une voyelle après cela, j'obtiens la voyelle avec un accent aigu, et si j'appuie sur une autre touche, j'obtiens immédiatement une apostrophe suivie de l'autre touche.

Je ne veux pas que cela se produise. C'est vraiment agaçant. Comment désactiver ce mode?

J'ai vu ce comportement dans Firefox, Pidgin et Outlook. Cela se produit apparemment pour chaque application, et le redémarrage de l'application le corrige. J'ai vérifié le panneau de contrôle "Région et langue" de Windows 7 et je n'ai rien vu de pertinent (bien que je ne connaisse pas tous ces paramètres, donc j'ai peut-être oublié quelque chose).

Modifier: Ce n'est apparemment pas la même chose que de changer les dispositions du clavier. J'ai retiré tous les claviers non américains du panneau de commande de mon clavier et je vois toujours ce comportement, et en appuyant sur LAlt+Décalage (que le panneau de configuration du clavier répertorie comme raccourci «entre les langues d’entrée») ne fait rien.


5
2018-04-19 15:43


origine


En guise de note - Si vous rencontrez un utilisateur avec ce problème au Canada, l'anglais canadien a également activé les tombes par défaut. S'ils ne l'utilisent pas, il suffit de supprimer la langue et de mettre l'anglais. - SITDGNymall


Réponses:


La touche de raccourci pour changer de clavier est par défaut LAlt + Décalage.

Si vous avez configuré plusieurs claviers (par exemple US et United States-International), cela va basculer entre les deux. Le premier a le comportement "normal" souhaité. Le second est le clavier avec la "apostrophe collante".

En tant qu'écrivain néerlandais et anglais, je trouve utile de pouvoir basculer entre les deux en utilisant le raccourci clavier. Gardez à l'esprit, cependant, que Windows se souvient du réglage par application. Si vous souhaitez utiliser plusieurs langues, je vous recommande de configurer deux langues avec des claviers différents et d'afficher la langue active de la barre de langue dans la barre d'état système:

Language settings in Windows 7


7
2018-04-19 16:33





J'ai finalement résolu ce problème:

J'avais allumé EnableHexNumpad (comme décrit sur fileformat.info) pour faciliter la saisie des caractères Unicode. Avoir apparemment EnableHexNumpad sur signifie que LAlt agit apparemment comme AltGr et en appuyant sur RShift + RCtrl peut entrer dans le mode "apostrophe collante".

Éteindre EnableHexNumpad fait de mon clavier un nouveau clavier américain.


4
2017-07-12 14:05





En fait, il est important de préciser que Alt + Shift bascule entre différentes langues, par ex. Anglais et néerlandais, et Ctrl + Maj basculent entre différents claviers dans une langue, par ex. basculer entre les États-Unis et US-International Keyboard. Sur mon ordinateur, il répond soit à la gauche ou à droite Ctrl, Alt et Shift.


2
2018-01-05 01:11





Ce que vous voyez est le passage du clavier à "U.S. International". Vérifiez le panneau de commande du clavier et apportez les modifications appropriées.


0
2018-04-19 15:53