Question Comment désactiver les raccourcis d'orientation de l'écran sous Windows (XP)?


J'utilise Eclipse sous Windows XP. Un de mes raccourcis préférés est CTRL+ALT+VERS LE BAS (ou CTRL+ALT+UP) pour dupliquer une ligne.

Je viens de découvrir que sur cette machine (XP ThinkPad, avec le pilote graphique NVIDIA), cela a pour effet de retourner l’écran, ce que je vais rarement utiliser.

Comment puis-je le désactiver? Ou, si cela est difficile, existe-t-il un moyen de donner la priorité aux raccourcis Eclipse par rapport aux autres raccourcis? Je ne suis pas sûr qu'il s'agisse d'une fonctionnalité du système d'exploitation ou d'un utilitaire d'arrière-plan, ou d'une fonction du pilote graphique, mais toutes les suggestions qui pourraient m'aider à le détecter et à l'éliminer seraient appréciées.

J'ai parcouru les choix sur le panneau de configuration NVIDIA et je ne trouve aucune option de raccourci.


154
2018-05-05 19:21


origine


Êtes-vous sûr que c'est le raccourci de l'OS? Pourrait-il y avoir un utilitaire fonctionnant en arrière-plan pour contrôler l'orientation? - Tog
@Tog - Bon point. Comment voulez-vous enquêter sur cela? - Eric Wilson
Consultez la liste des programmes pour les utilitaires OEM, vérifiez le gestionnaire de tâches, vérifiez la liste de démarrage en utilisant msconfig - Tog
C'est un paramètre très ennuyeux pour les utilisateurs d'IntelliJ puisque "ctrl + alt + gauche / droite" est utilisé pour naviguer dans le code que vous éditez. - Sung Kim


Réponses:


Je n'ai pas testé sur les graphiques AMD / ATI, mais je sais très bien que tous les pilotes Intel le font et certains pilotes Nvidia.

Allez simplement dans l'outil de configuration de votre pilote et regardez sous une section appelée raccourcis clavier et désactivez-la.

Pour Intel:

Screenshot from the Intel specific display driver


149
2018-05-05 19:46



Je me sens comme un cancre, mais je ne trouve pas l'outil de configuration de mon pilote. Où est-ce que je regarde? - Eric Wilson
Je l'ai trouvé, mais je n'ai pas trouvé de raccourcis, édité la question. - Eric Wilson
Pour ceux qui ne peuvent pas trouver ces paramètres - essayez de suivre l'itinéraire: Panneau de configuration → Apparence et personnalisation → Affichage → Résolution d'écran → Paramètres avancés → Pilote graphique - lyuba
J'ai trouvé les paramètres de raccourci dans le menu contextuel de l'icône Intel HD Graphics SysTray. Options graphiques> Raccourcis clavier> Désactiver. - Somantra
Whaao! C'était super incroyable. Je viens de rechercher des paramètres et trouvé des cacahuètes! Merci! - sud007


La solution consiste à cliquer avec le bouton droit de la souris sur votre bureau et à sélectionner Options graphiques >>> Touches de raccourci >>> Désactiver.

disabling graphics hotkeys

Bien que vois ici, où quelqu'un décrit cela, le fait fonctionner pendant un certain temps, puis une mise à jour le fait pour lui. D'autres ont suggéré dans un cas pire comme celui-ci de désinstaller le logiciel de configuration installé avec votre pilote mais de garder le pilote. Je suis un peu inquiet que ce ne soit pas un correctif nVidia, cependant, puisque vous devez utiliser la route ci-dessus pour les désactiver en premier lieu, pas une sorte de panneau de contrôle.

En tout état de cause, l'itinéraire Options graphiques a fonctionné pour moi dans une situation similaire.


124
2018-04-27 15:36



Propriétés graphiques et Options graphiques ne sont pas toujours disponibles (j'ai vérifié sur quatre ordinateurs, avec Windows XP 32 bits, Windows 7 Enterprise 32 bits et deux avec Windows 7 Enterprise 64 bits. Un seul, l'un des deux avec Windows 7 Enterprise 64 bits, avait ces deux options). (Sont-ils ajoutés par le pilote d'affichage spécifique?) - Peter Mortensen
Parfait merci. Cela interférait avec mon raccourci clavier Visual Studio préféré - Vazgen
IMPRESSIONNANT! Travaillé... - Ozan Kurt


Si désactiver la fonctionnalité de raccourci clavier du pilote Intel n'est pas utile, vous pouvez essayer de changer le raccourci clavier, puis le désactiver. Sur mon ordinateur, cette méthode fonctionne.


6
2017-10-22 08:16



la solution consiste à attribuer d'autres raccourcis avant de les désactiver. Lorsque j'ai désactivé les raccourcis, l'écran ne tournait pas mais les frappes au clavier n'étaient pas enregistrées par Visual Studio (dans mon cas) - Maximo Dominguez


C'est une fonction du pilote d'affichage, pas du système d'exploitation. Vous devrez vérifier les paramètres dans le pilote d'affichage pour voir s'il peut être désactivé.


2
2018-05-05 19:46