Question Mon invité Ubuntu dans VBox perd la connectivité Internet sous NAT mais pas sous Bridged Adapter- pourquoi?


J'utilise Ubuntu Linux via VirtualBox en tant qu'invité au-dessus d'un hôte Win 7 Home Premium. Tout allait bien jusqu’à il ya quelques jours lorsque ma connectivité Internet a commencé à échouer dans Ubuntu. La connexion réseau par défaut est NAT (Network Address Translation). Le problème est donc le suivant: j'ai une connectivité Internet dans Ubuntu pendant environ 30 secondes, puis cela échoue. Lorsque je change la connexion réseau à "Bridged Adapter", ce problème disparaît, c’est-à-dire que ma connexion Internet dans Ubuntu reste stable.

Aussi, pour une raison quelconque, sur mon hôte (Win 7), ma barre de connectivité sans fil (en bas à droite du bureau) indique que je dispose d’un accès Internet, mais je suis sur un "réseau non identifié - pas d’accès réseau". comme je me connecte via mon ordinateur portable à mon routeur domestique, comme je l'ai toujours fait. Je pensais que cela avait peut-être quelque chose à voir avec l'expiration de mon Norton AntiVirus il y a quelques jours, mais je viens de le renouveler, et le problème persiste. Est-ce que quelqu'un a une idée de la raison pour laquelle le NAT provoque l'abandon de la connectivité Internet de mon invité Ubuntu Linux dans les 30 secondes, mais pas avec la mise en réseau "Bridged Adapter"? Je vous remercie.


6
2017-08-08 00:30


origine




Réponses:


Configurez votre carte réseau pour AMD PCNet FAST III (Am79C973, la valeur par défaut). (La source)

Cela pourrait aussi être un problème de DNS. Entrez les commandes suivantes (La source):

sudo su
  echo "nameserver 8.8.4.4" >> /etc/resolv.conf
  echo "nameserver 8.8.8.8" >> /etc/resolv.conf
  Sortie


1
2018-05-07 09:44