Question Comment puis-je régler mes touches "Fn + Volume Up / Down" pour ajuster ma chaîne casque dans Ubuntu Karmic?


je résolu ce problème à Jaunty, mais le menu des préférences sonores a beaucoup changé dans Karmic. Quelle est la nouvelle façon de faire cela?

Question originale: J'ai toujours ma chaîne maître en sourdine et j'ai changé d'applet de volume pour régler le canal du casque. De cette façon, le son ne sort jamais de mes haut-parleurs, mais il est toujours allumé lorsque je branche des écouteurs.

Cependant, lorsque j'utilise mes touches Fn pour régler le volume, elles ajustent le canal "maître" plutôt que le canal "casque". Comment changer ce comportement? Si cela fait une différence, j'utilise un Dell Inspiron 1200.


6
2017-10-06 19:00


origine




Réponses:


vous pouvez utiliser xbindkeys: Courir xbindkeys -k dans un terminal Appuyez sur votre raccourci clavier et ajoutez la ligne appropriée à votre fichier ~ / .xkeybindkeysrc. Par exemple, avec une commande 'amixer' pour augmenter / baisser le volume de votre casque.) N'oubliez pas de lancer xbindkeys avant votre gestionnaire de fenêtres. Vous pouvez jeter un oeil ici pour plus sur xbindkeys. De cette façon, vous n'êtes pas dépendant de DE et vous pouvez même transférer des raccourcis clavier vers d'autres distributions / versions.

(Je sais que ce n'est pas exactement ce que vous voulez, mais cela pourrait résoudre vos problèmes?)


2
2018-01-23 21:29





Si vous ne trouvez aucune option de configuration, vous pouvez adopter l’approche barebone et attribuer ces touches de fonction à une commande raw qui augmente ou diminue le volume sur le canal du casque. Karmic utilise un peu de pulseaudio, mais je pense que les commandes alsa fonctionneront toujours, à savoir: aumix.


0
2018-01-08 10:24





Pour une raison quelconque, je ne peux pas prendre une capture d'écran avec le menu déroulant, mais pouvez-vous essayer de cliquer sur la liste déroulante du connecteur et de sélectionner la sortie casque? J'utilise le karmic et un dell et le mien dit "Analog Headphones". Je pense que cela peut le faire pour vous.

enter image description here


0
2017-12-31 18:21



En ce moment mon volume est tout foutu, de sorte que je ne peux pas le régler du tout. Une fois que je l'ai corrigé (probablement pas jusqu'à Lucid, à la recherche de choses), je vais tester cela et voir si cela fonctionne. - Matthew
Matthew est-il connecté à des journaux d'erreur lorsque vous essayez de modifier le volume (et que cela ne change pas)? Cela me semble bien foutu; Si vos répertoires de données sont regroupés, il peut être utile de les sauvegarder et de les réinstaller. - pbr
@pbr Cela semble être un bug dans le noyau Linux. Le noyau ne rapporte pas correctement le niveau dB. Pour une raison quelconque, cela ne sera pas corrigé dans karmic, mais sera corrigé dans lucid. Voir bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/410948 - Matthew