Question DNS ne fonctionne pas dans Bash (Ubuntu) sous Windows avec VPN


Je viens juste de commencer à tester "Bash on Ubuntu on Windows", et j'aime ça!

Juste, le problème est que je dois utiliser VPN pour accéder à nos serveurs backend et développeur. Et en essayant (par exemple) ssh sur notre serveur de développement avec le shell Windows Bash, il ne peut pas résoudre le nom d'hôte.

Notez que je suis capable de ssh en utilisant l'adresse IP, et ces noms d'hôte fonctionnent également très bien ailleurs dans Windows. Comme avec le mastic, le cmd régulier, l'explorateur de fichier etc.

J'ai aussi vérifié le fichier /etc/resolv.conf et je peux voir notre serveur de noms de travail sur la liste.

À partir de là, mes compétences en matière de réseautage sont insuffisantes, en particulier avec Linux, alors aidez-moi: D


7
2017-09-21 15:36


origine


Je viens de parler du même problème. Avez-vous réussi à résoudre le problème ailleurs? - Hugh


Réponses:


Cela ne résout pas le problème avec le DNS ne fonctionne pas, mais c'est une solution de contournement qui fait que cela semble fonctionner.

Vous pouvez modifier votre fichier hosts (dans / etc / hosts) et ajouter une entrée pour le nom d'hôte que vous souhaitez utiliser.

Ajoutez une entrée ayant l'adresse IP suivie d'un espace et du nom d'hôte.

123.456.1.1 target.host.net

Notez que vous devrez sudo votre commande d'édition. sudo vi /etc/hosts

Pour moi, l’édition reste fidèle aux sessions shell bash. Je suppose que c'est un bogue que Microsoft espère corriger dans le futur. Pour l'instant, je viens d'utiliser cette solution de contournement.


1
2017-11-02 13:51





C'est un problème de routage, pas un bogue de WSL. Il est très probable que votre sous-réseau local soit identique à celui du sous-réseau distant. Et je suppose que vous utilisez le VPN ponté.

J'ai rencontré le même problème. J'utilise OpenVPN pour connecter mon bureau (distant) et mon domicile (local). Les deux sous-réseaux sont tous deux 192.168.1.0, le plus commun sur lequel se trouvent de nombreux routeurs.

J'ai finalement résolu le problème avec la configuration suivante. Mon objectif est d'utiliser tun afin de réduire les frais généraux et de ne rediriger que le trafic là où la destination est au bureau. Cependant, cela fonctionnerait également avec le VPN ponté.

;make the dhcp-option works on Windows 10.
script-security 2
;do not accept any pushed route command.
route-nopull
;make sure the connection still go through my home router. This line may not be necessary. You can try to remove this line and see it the VPN works.
route 192.168.1.1 255.255.255.0 net_gateway
;redirect the traffic where the destination is within the 192.168.1.0 subnet to OpenVPN gateway.
route 192.168.1.128 255.255.255.128
route 192.168.1.0 255.255.255.128
;set the DNS server which is in the office
dhcp-option DNS 192.168.1.254
dhcp-option DNS 192.168.1.253
dhcp-option DOMAIN my.company.domain

1
2018-01-17 13:53





J'ai le même problème. J'ai édité temporairement /etc/resolv.conf avec un seul serveur de noms et un seul domaine de recherche (pour le réseau VPN) et il a résolu les noms d'hôtes sur ce réseau. Ce changement n'est pas persistant, donc quitter et redémarrer Bash sur Ubuntu sous Windows restaurera les paramètres par défaut de /etc/resolv.conf.


-1
2018-01-08 18:08



"mais aimerait vraiment savoir comment configurer correctement les interfaces réseau pour Bash sur Ubuntu sous Windows, afin que l’établissement d’une connexion VPN dans Windows configure automatiquement le DNS." - Vous devriez retirer ce commentaire de votre réponse. - Ramhound