Question Mon clavier Windows est "intelligent" avec les clés de devis - comment puis-je l'arrêter?


J'utilise Windows 7 sur un ordinateur portable. Sur le clavier d'ordinateur portable, pour une raison quelconque, la clé de devis (qui comporte à la fois des guillemets doubles et des guillemets simples) fait des choses ennuyeuses "intelligentes":

  1. Lorsque j'appuie sur un guillemet simple (ou un guillemet double), Windows n'envoie aucun caractère tant que je ne l'ai pas appuyé deux fois ( '' ou "")
  2. Quand je l'appuie sur une voyelle, j'obtiens une sorte de caractère accentué. Comme je n'écris habituellement que l'anglais, c'est ennuyeux.

La touche backtick / tilde est soumise à un comportement similaire.

Ce n'est pas un duplicata de la question liée parce que les deux problèmes ont des solutions complètement différentes. Cette question était due à l'activation d'un paramètre d'internationalisation. cette autre question a été causée par la mise à mort des clés.

Je n'ai pas tenté de configurer mon ordinateur pour traiter autre chose que l'anglais. Mon clavier semble être (dans la mesure où ces choses sont standard sur les ordinateurs portables) un clavier qwerty US standard.

Comment puis-je arrêter cela?


177
2017-10-13 12:06


origine


Duplicata possible de Les apostrophes et les guillemets ne s'affichent pas avant que je tape la lettre suivante - Cees Timmerman
Pas assez de réputation pour poster une réponse, mais le problème que vous rencontrez est que les guillemets, les guillemets et le tilde sont définis comme "Dead Keys". Si vous souhaitez conserver le clavier US International mais supprimer la fonctionnalité "Dead Keys", vous devez créer et installer votre propre clavier (ou en télécharger un prêt à l'emploi) en utilisant Microsoft Keyboard Layout Creator. Je viens d'ouvrir le clavier US-Interntaional, supprimé la fonctionnalité des clés mortes, enregistrée et installée. - Agustín Lado


Réponses:


Je voudrais d'abord m'assurer que les paramètres de votre "méthode de saisie" sont définis sur "US" (et certainement pas sur "United States-International"). Vous pouvez le faire via le panneau de configuration. Un redémarrage peut être requis.

Pour Windows 7:

  1. Ouvrir Panneau de contrôle
  2. Cliquer sur Horloge, langue et région, et alors Région et langue.
  3. Clique le Claviers et Langues onglet, puis cliquez sur Changer les claviers.
  4. En dessous de Services installés, Cliquez sur Ajouter.
  5. Double-cliquez sur la langue que vous souhaitez ajouter, double-cliquez sur Clavier, sélectionnez les options de services de texte à ajouter, puis cliquez sur D'accord.

Voir également:

Pour Windows 10:

  1. Ouvrir Panneau de contrôle.
  2. Cliquer sur Horloge, langue et région puis cliquez sur La langue.
  3. Si vous ne voyez pas de carte "Anglais (États-Unis)" dans la liste, cliquez sur "Ajouter une langue"sur la barre d'outils pour l'ajouter.
  4. Sur la même ligne appartenant à la carte "Anglais (États-Unis)", assurez-vous qu'il y a une ligne indiquant "Disposition du clavier: US". Si ce n'est pas le cas (c'est la supposition de cette réponse), cliquez sur le "Les options"hyperlien appartenant à la même ligne, à gauche.
  5. Dans la section "Méthode de saisie", cliquez sur le lien hypertexte "Ajouter une méthode de saisie" pour ajouter une disposition de clavier appelée "NOUS". Supprimez toute autre méthode d’entrée installée en anglais.

Voir également:


171
2017-10-13 12:26



Je vous remercie! Je n'ai pas réalisé que ces paramètres nécessitaient un redémarrage pour prendre effet. - Marcin
Ouais, une chose que j'ai apprise est que ça ne fait jamais mal de se déconnecter et de se reconnecter quand on joue avec les paramètres du panneau de contrôle, la gestion de l'ordinateur ou le registre Windows (aussi ennuyeux soit-il :)). - Dminish
Je m'arrête et démarre l'explorateur via la fenêtre d'exécution "cmd / c taskkill / f / im explorer.exe & explorer". La plupart du temps, cela permettra aux modifications de nombreuses choses de prendre effet. Cela fonctionne sur XP devrait fonctionner sur 7 et 8 - Michael Mantion
IL FAUT SE MÉFIER! Vous allez perdre le signe de la livre £ (AltGr+Shift+4) en passant de United States-International à US mise en page, mais il résoudra la gêne susmentionnée. - igor
Cela ne fonctionne pas si vous souhaitez conserver le clavier international (pour la fonctionnalité AltGR). Le seul choix est d'utiliser Microsoft Keyboard Layout Creator créer un clavier international US personnalisé sans Dead Keys. - Agustín Lado


Dans le cas de Windows 8/10 (pas la question, je sais) - ces touches d'accent sont actives lorsque le clavier est US International (US INTL), et seront désactivées si vous passez à US ENG.

Vous pouvez basculer entre les deux en utilisant le raccourci "WindowsKey + Space".

En outre, si vous regardez la barre des tâches du bureau (en bas de l'écran) - à gauche de l'affichage Date / Heure, vous devriez voir une tuile affichant le clavier actuel (dans ce cas, US ENG ou US INTL) - cliquez dessus pour un sélecteur.


47
2017-08-19 15:12



Travaillé pour moi, je travaillais avec l'éditeur de texte Sublime et cela me rendait fou tout en programmant. Merci! - Șerban Ghiță
C'est vraiment un PITA quand on a l'habitude de travailler avec Mac OS ... Apple Key-Space signifie "Spotlight Search", donc je le presse souvent sous Windows. - TheEye
Alt gauche + décalage gauche était lié à changer les langues du clavier dans Windows 7. (Le raccourci doit être répertorié dans la fenêtre où vous ajoutez d'autres langues de clavier). Changé à la carte non internationale et il est de retour à la normale, merci. - aportr
Dans mon cas, l'US Eng était actif et j'avais toujours le problème. Je l'ai corrigé en sélectionnant International dans la barre de langue, puis en sélectionnant immédiatement US Eng. - misterManSam
+1 Le raccourci WindowsKey + Space travaille dans Windows 10 aussi. Merci :) - Krishna Mohan


Vous avez probablement pressé par inadvertance ctrl  décalage  '.

Ceci est un raccourci Windows qui affecte certaines applications (exemples: mIRC, gtalk, wordpad, etc.) et provoque le comportement que vous décrivez. Appuyez à nouveau sur le raccourci ou redémarrez l'ordinateur pour le désactiver (et la réponse de Dmnisih est donc incorrecte).


9
2017-10-13 17:07



Est-ce que votre liste inclut cmd et xemacs sous cygwin? Sinon, votre diagnostic est incorrect. - Marcin
SharePoint Designer 2010 est également affecté par ce raccourci. - MrChrister
Cela a fait le tour pour moi. "Merci" - ViVi
@Marcin Tout ce qui utilise une entrée de texte enrichi win32 en serait affecté. CMD le fait, et IIRC GTK fonctionne sous cygwin. Les diagnostics sont corrects. - Tritium21


Si vous appuyez sur l'espace après la citation, ce sera comme si vous n'aviez qu'une citation


7
2017-11-28 10:40



Est-ce que cela fonctionne avec n'importe quelle clé? Ou juste de l'espace? - Marcin
n'importe quelle touche pour autant que je puisse voir ... - rupweb
Oui, mais appuyer sur les 2 touches pour faire apparaître une seule touche n’est pas la solution au problème. - simo.37920


Voici comment je l'ai corrigé:

  1. Ouvrez le panneau de configuration Options régionales et linguistiques.
  2. Cliquez sur l'onglet Claviers et langues.
  3. Cliquez sur le bouton Modifier les claviers.
  4. Supprimez tous les claviers installés jusqu'à ce qu'il n'en reste plus sauf l'anglais américain.
  5. Redémarrez votre ordinateur.

4
2018-01-24 12:56



Habituellement, les variantes "internationales" des claviers provoquent ce comportement. Notez que vous ne pouvez pas supprimer le clavier actuellement sélectionné et que le redémarrage n'est probablement pas nécessaire. (mais Windows me surprend souvent avec des redémarrages demandés) - pabouk


Cela se produit généralement quand on frappe accidentellement les touches Ctrl gauche et Maj droite du clavier.

Le moyen de récupérer consiste à appuyer sur ces touches Ctrl-Maj deux fois de plus.

Il a été bien illustré à http://www.pctips.smittystips.com/v_laptop_keyboard_errors.php


4
2017-09-22 15:18



Ouah merci! Une solution simple pour moi lorsque mon clavier a déjà été sélectionné en anglais américain. J'ai presque sauté votre suggestion en pensant que cela ne pouvait pas être correct! :) - pcdev


  1. Si vous appuyez sur " une fois, suivi de Barre d'espace, il donne ' sans espace à côté.
  2. Si vous appuyez sur ", en tenant Décalage, puis appuyez sur Barre d'espace, vous obtenez " sans espace à côté.
  3. Si vous appuyez sur " suivi d'une consonne, vous obtenez alors le même résultat que (2). Par exemple:

    ", suivi par m, donne 'm.

    Décalage+", suivi par m, donne "m.


0
2018-01-28 10:51



Quelle solution / action suggérez-vous? - meatspace
Ce que je suggère, c'est que la barre d'espace fera l'affaire. Il n'est pas nécessaire de modifier le paramètre Region and Language, car ce problème se produit généralement dans n'importe quelle configuration de clavier. - jaydeepsb
Votre réponse est vraiment difficile à lire et pourrait être améliorée si vous la modifiez et l'utilisez. <kbd>space</kbd> et <kbd>"</kbd> afin de formater les noms des touches du clavier pour les rendre plus lisibles. - Ryan
Merci d'avoir décrit la misère de l'affiche originale en autant de mots. Cependant, ce n’est pas une réponse à la question de «comment puis-je l’arrêter? Abaissé


Pour WinXP

Ouvrez la fenêtre RUN (winbutton + r) tapez la ligne suivante et appuyez sur Entrée

cmd /c intl.cpl ,1 & taskkill /f /im explorer.exe & explorer

Cliquez sur "détail"

Mettez en surbrillance et supprimez tous les claviers sauf US

Cliquez deux fois sur OK et vous devriez avoir terminé


-3
2018-01-05 08:25