Question Désactiver la parenthèse dans Sublime Text 2


J'ai des questions sur la désactivation des parenthèses. Est-ce que quelqu'un sait comment désactiver l'appariement des parenthèses?

Exemple:

Quand je tape un (, il ajoutera automatiquement ), devient ().

C'est très bien pour éditer du texte en clair. Mais assez ennuyeux lors de l'édition de fichiers clojure.


42
2018-02-21 02:57


origine




Réponses:


Définissez ceci dans vos paramètres d'utilisateur

"auto_match_enabled" : false

56
2018-03-08 11:56



Pouvez-vous en faire un interrupteur à bascule? - laggingreflex
Vous feriez mieux d'ajouter cette ligne aux paramètres utilisateur (Préférences> Paramètres - Utilisateur) plutôt que globale afin qu'ils ne soient pas écrasés par les mises à jour. - pelms


Vous pouvez basculer ce paramètre en ajoutant une liaison de clé à "Préférences> Liaisons de touches - Utilisateur".
par exemple. faire Ctrl+Décalage+p basculer le paramètre, utilisez:

{
    "keys": ["ctrl+shift+p"],
    "command": "toggle_setting",
    "args":
    {
        "setting": "auto_match_enabled"
    }
} 

8
2017-10-03 12:27





Il semble que vous ayez besoin de changer autoMatchEnabled sur false sous Préférences de type de fichier pour désactiver le couplage automatique. En savoir plus à ce sujet: http://www.sublimetext.com/docs/file-type-preferences


1
2018-02-22 14:36



Merci Sam! ça devrait être là. Mais j'ai défini "autoMatchEnabled": false @ Global.sublime-settings, redémarrer, ne fonctionne toujours pas. - Juanito Fatas
Les espaces me manquent ... Merci! - Juanito Fatas