Question Ubuntu vi Action étrange


Je viens d'installer Ubuntu Server 8 et j'ai trouvé que vi agissait étrangement (comparé à vi sur Fedora, CentOS et OSX).

Lorsque j'utilise la commande 'a' pour saisir du texte, appuyer sur les touches fléchées entraîne la saisie de «C», «D», «B» et «A». Cela rend l'édition presque impossible.

Est-ce que je fais quelque chose de mal ici?


8
2017-08-27 16:27


origine




Réponses:


Vous utilisez probablement l'éditeur vim-tiny qui ne prend pas en charge la navigation par touches fléchées en mode insertion; Ubuntu 8.04 n'a pas le vim paquet installé. Installez cela et mettez à jour votre version par défaut de vi:

sudo apt-get install vim
sudo update-alternatives --config vi

Sélectionnez "vim.basic". Vous pouvez également vouloir faire cela pour l'éditeur (remplacez vi dans la commande ci-dessus par l'éditeur) afin que l'éditeur par défaut appelé par d'autres programmes (comme visudo) soit également la bonne version de vim.

Je conseille également de prendre l'habitude de frapper ESC à partir du mode insertion et d'utiliser hjkl navigation commune à Vi / Vim, plutôt que d'utiliser les touches fléchées.


12
2017-08-27 16:32



Il peut aussi être réel vi au lieu de vim. Étant un serveur, ils ont tendance à expédier avec le strict minimum. hjkl est la voie à suivre. = -] - Jack M.
@jack m .: jtimberman est correct, Ubuntu va installer le vim-tiny package par défaut. Je pense que cette version de vim est compilé pour agissent comme  vi, donc il n'y aura pas beaucoup (le cas échéant) de différence entre elle et réelle vi. - quack quixote


une autre option consiste à supprimer vim-tiny:

sudo apt-get remove vim-tiny

puis réinstallez vim:

sudo apt-get install vim

3
2017-11-19 11:36



+1, simplement parce que je ne vois plus aucune raison de rester dans le système. - Radu Maris


aptitude install vim-full

La première chose que je fais sur une nouvelle installation d'ubuntu.


2
2017-08-27 16:31



Cela va installer le paquet vim-gnome, ce qui est probablement indésirable sur les systèmes "serveur". - jtimberman


Vous pouvez également vouloir faire une configuration:

$ cp /usr/share/vim/vimcurrent/vimrc_example.vim ~/.vimrc
$ vim !$    # and adapt it to your needs

L'exemple de vimrc comporte des paramètres utiles et constitue un bon point de départ.

(notez que vous devez adapter le chemin pour les autres systèmes, ceci est spécifique à debian / ubuntu. Sur les systèmes qui suivent de plus près l'installation vim en amont, c'est /usr/share/vim/vimrc_example.vim)


0
2017-08-27 19:50





Essayer:

:set nocompatible

Si cela fonctionne, vous pouvez envisager de le mettre dans votre .exrc (sans côlon).


0
2017-09-27 22:33