Question Comment désactiver de manière permanente la page "Cette connexion est non fiable" sur Firefox


Je deviens fou.

Quelqu'un peut-il m'aider s'il vous plaît à DÉSACTIVER COMPLÈTEMENT la page "Cette connexion est non fiable" sur Firefox.

Faits:

  • J'utilise Firefox 23.0 sur une machine Ubuntu (téléchargé et installé Ubuntu aujourd'hui)
  • C'est un ordinateur de travail et Je dois utiliser la procuration de mon employeur
  • Bien que la visite de pages Web / Webapps comme Gmail ou Google ouvre la page "Cette connexion est peu fiable" et que je doive passer par la tâche fastidieuse de sélectionner "Je comprends les risques" et ajouter des exceptions, etc. Le fait est que Je ne me soucie pas des risques. Je préférerais que cet ordinateur fonde dans le sol plutôt que de devoir revoir cette page. Je veux danser nue dans des pages non fiables et ne pas me soucier des conséquences. Je ne veux juste jamais revoir cette page. Déjà.
  • Pour certains sites (par exemple, wikipedia), le css ne se charge pas et je finis par les voir en texte brut. En conséquence, ces sites sont complètement inutiles. Des heures perdues en essayant de résoudre ce problème pour stackoverflow.com.
  • Ces problèmes se produisent également sur Firefox sur mon ordinateur Windows XP (également avec le même proxy).

Je ne veux pas exporter / importer de certificats ou créer des exceptions pour chaque site qui montre cette page sanglante. Je veux juste que cette page soit partie. Je ne veux pas que Firefox me dise ce qui est sûr et ce qui ne l'est pas.

En outre, l'heure et la date de mon système sont correctes. J'ai aussi essayé le se trouve sur cette page aussi sans bons résultats.

Edit: J'ai également essayé tout ce qui se passait dans la page de configuration avancée des certificats-> Certificats-> et décochez la case Utiliser le protocole OCSP (Online Certificate Status Protocol) pour confirmer la validité actuelle des certificats. Rien ne s'est passé même après le redémarrage de Firefox ou le redémarrage. J'ai besoin d'aide.

Merci.


9
2017-11-07 06:43


origine


Je n'ai pas testé cela, mais cela peut être votre réponse: support.mozilla.org/en-US/questions/957485 - Darius
Pourquoi voulez-vous une solution de contournement pour les symptômes? Pourquoi ne demandez-vous pas à votre employeur de réparer la cause? Normalement, vous ne devriez voir aucune page d'erreur https. - Werner Henze
Mon employeur encourage les employés à utiliser IE8. Ils vivent dans les années 1990 et sont à la maison en train de regarder MASH sur leur téléviseur à tube cathodique. - TheIronChef9
@ TheIronChef9 Vous pourriez aussi regarder ma réponse sur Comment désactiver le certificat "This Connection is Untrusted" dans FireFox? J'espère que cela t'aides... - Murat Yıldız


Réponses:


C’est une chose très dangereuse à faire, car vous ne pourrez pas détecter un L'homme au milieu attaque n'importe où (chez soi, sur un wifi public ...)

La solution consiste à ajouter le certificat racine utilisé par votre proxy d'entreprise en tant qu'autorité de confiance (CA) dans votre navigateur, comme décrit ici:

https://wiki.wmtransfer.com/projects/webmoney/wiki/Installing_root_certificate_in_Mozilla_Firefox

Pour obtenir le certificat proxy, cliquez sur l’icône de verrouillage située près de l’URL d’une page HTTPS, cliquez sur "Afficher le certificat" et, sur Windows, cliquez sur le certificat de votre proxy ( ici) puis l'exportez et procédez comme expliqué ci-dessus pour l'importer en tant qu'autorité de certification de confiance.


5
2017-11-07 08:44



Le lien fourni en premier me donne une erreur de "page non fiable" puis quand j'ajoute une exception, il va à une page 404 non trouvée. - TheIronChef9


Si vous cherchez juste à désactiver les pages d'erreur HTTPS:

Allez dans Outils> Options> Avancé "Onglet" (?)> Onglet Cryptage Cliquez sur le bouton "Validation" et décochez la case pour vérifier la validité. Non recommandé, mais cela devrait les empêcher de s'afficher.

Je vous conseille de vous assurer que l'heure de votre système est correcte, si ce n'est pas le cas, cela pourrait déclencher toutes les erreurs de certificat.


0
2017-11-07 06:56



J'aurais dû le mentionner dans mon post mais j'ai déjà essayé cette approche et je n'ai pas eu de bons résultats. Je l'ai fait, redémarré firefox (même redémarré depuis) ​​et rien. C'est comme si cette case à cocher ne faisait rien. - TheIronChef9


Si vous installez une ancienne carte nVidia (ou éventuellement une autre marque), cette erreur peut également se produire.

Il va automatiquement définir votre date et votre heure, par exemple, je viens d'installer un 9600GT sur un système Windows 7 et il a remonté le temps en 2008. J'ai donc reçu les avertissements de certificat dans Firefox.
La modification de la date et de l’heure a permis de résoudre le problème.


-3
2018-05-28 21:03



Cela n'a vraiment rien à voir avec l'installation d'une carte Nvidia. Cela est probablement dû au fait que l'ordinateur est débranché suffisamment longtemps pour que l'heure CMOS soit réinitialisée. - Michael Frank