Question La langue du clavier continue à changer dans Windows 10


J'ai donc récemment effectué une installation propre de Windows 10 anglais. Je l'ai configuré pour avoir une langue anglaise, mais un clavier norvégien. J'ai plusieurs problèmes avec cette configuration:

  1. La langue du clavier ne cesse de changer en anglais
  2. Je ne peux pas voir la barre de langue ni la langue bascule popup lorsque je permute:

    language toggle popup

J'ai lié le clavier norvégien à Décalage+Alt+0 et ça marche, mais c'est ennuyeux de devoir le faire toutes les 5 minutes. Aussi je trouve bizarre que je ne puisse pas voir la barre de langue ni sur le bureau ni sur la barre d’outils.

Quelqu'un a-t-il une idée de ce qui pourrait être faux?

Voici quelques captures d'écran de mes paramètres:

settings 1

settings 2

settings 3

No language bar on the toolbar

P.S. La seule fois où je vois la langue basculer popup est en fait quand je suis déconnecté dans l'écran de verrouillage et appuyez sur Gagner+Espace. Rien ne se passe si je le fais après avoir été connecté.


230
2017-09-23 06:21


origine


Cela m'a poussé à monter le mur depuis l'installation de Windows 10. La disposition du clavier change sporadiquement au fur et à mesure de ma frappe. Je jure que je n'ai pas touché le raccourci <kbd> Win </ kbd> + <kbd> Espace </ kbd>. - Colonel Panic
Alt + Shift change également la langue, semble-t-il. - Mir
Et Left Ctrl + Shift change de clavier si plus d'un clavier est installé !! Alt + Shift et Ctrl + Shift sont des modèles de raccourci courants dans les éditeurs de code et les produits Adobe (Photoshop par exemple). WINDOWS-: c'était un choix médiocre et inutile de détournement de raccourci !! Honte à toi. Ha! Pas étonnant que je devais continuer à "redémarrer"! Je pensais que ce nouvel ordinateur portable / clavier était cassé! Merci à tous pour la solution :) - SherylHohman
Cela m'attriste que MSFT ait toujours de tels problèmes d'utilisabilité de base. - Bruno Brant


Réponses:


Dans Windows 10, par défaut, en appuyant sur CTRL+DÉCALAGE (ou pour certains ALT+DÉCALAGE - merci madmenyo) fera défiler toutes les configurations de clavier que vous avez pu mapper et il est étonnamment facile de le faire par erreur.

Si vous continuez à appuyer CTRL+DÉCALAGE (ou quoi que vous ayez pu changer), vous devriez bientôt revenir au réglage correct. (alternativement redémarrer ce que j'ai fait la première fois ;-))

Vous pouvez désactiver cette action de clavier par défaut comme suit:

Control Panel > Clock, Language, and Region > Language > Advanced settings > Switching input methods > Change language bar hotkeys > Change key sequence... > Switch keyboard layout > Not Assigned

à partir de 2016, l'emplacement a changé. (des commentaires)

Control panel > Language > Advanced settings > Switching input methods > Change language bar hot keys 

Soyez averti, ce qui précède ne fonctionne pas toujours - Le redémarrage et le mode veille peuvent tous deux modifier la valeur par défaut du clavier (généralement aux États-Unis) - je n'ai trouvé aucune solution .

Dans une urgence

WIN+R  
osk

pour faire apparaître le clavier à l'écran peut aider temporairement.

Notez également qu'il est possible de désactiver cette option pour qu'aucune combinaison de touches ne modifie la langue - changez les clés pour "Non attribué" - voir la réponse ci-dessous de Mort pour plus d'informations


314
2017-10-25 22:13



Whaaaat. J'utilise fréquemment Ctrl + Shift dans Visual Studio. Pas étonnant que ma disposition de clavier ne cesse de changer. Merci! - willem
Pour moi c'est en fait ALT+SHIFT - Madmenyo
Impair. Peut-être qu'ils ont changé cela, mais pour moi, il est dit que le raccourci pour basculer est [windows key] + [space], ce qui semble un peu plus raisonnable (et semble être la seule chose qui fonctionne comme raccourci de changement de langue). - Nyerguds
Pour quiconque y participera en 2016, il semble que l'emplacement ait changé. Maintenant, il est situé dans Control panel//Language//Advanced settings//Switching input methods//Change language bar hot keys - David Metcalfe
être précisément: win + space changements entre toutes les paires langue / clavier configurées. alt + shift ne change que la langue et ctrl + shift ne change que le clavier - Simon Zyx


Si vous cliquez sur le lien "Modifier les touches de raccourci de la barre de langue", visible dans votre dernière capture d'écran, vous devriez être en mesure de voir quelles touches sont susceptibles de changer la langue du clavier.

Les paramètres par défaut sont très faciles à atteindre lorsque vous utilisez le clavier, changeant ainsi soudainement la langue du clavier. Changer les touches à "Not Assigned" empêchera la langue du clavier de changer accidentellement.


15
2017-09-29 10:03



Oui, ceux-ci ont été réglés sur Maj + Alt à l'origine, puis je les ai remplacés par "aucun". Malheureusement, cela n'a pas résolu le problème tout seul, mais voyez mon autre réponse. - Nilzor


Il s'est avéré que je devais configurer une disposition de clavier dans la première capture d'écran. Vous remarquerez qu'il est dit "Clavier: Aucun disponible". Donc en cliquant sur "Options" ici, puis "Ajouter une méthode de saisie" et en sélectionnant QWERTY Norwegian, vous avez résolu le cas.

Je ne sais pas comment j'ai pu installer Windows avec une telle configuration linguistique. Quoi qu'il en soit, je conseille à tout le monde de regarder de plus près les questions linguistiques lors de l'installation initiale.

Pic1

Pic2


12
2017-09-29 12:50



Après avoir essayé de faire de l'écriture manuscrite pour travailler en français (au Canada), j'ai eu deux versions de l'anglais (États-Unis, Canada) et du français (France, Canada), sans parler de plus d'une méthode de saisie pour l'anglais américain. En bref, cette réponse m'a permis de bien nettoyer tout cela. - Fuhrmanator


Le paramètre de registre direct pour désactiver les raccourcis clavier de la disposition du clavier est le suivant:

reg add "HKCU\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3

Vous pourriez aussi vouloir

reg add "HKCU\Keyboard Layout\Toggle" /v "Language Hotkey" /d 3
reg add "HKCU\Keyboard Layout\Toggle" /v "Hotkey" /d 3

Et pour les nouveaux utilisateurs, essayez ceci (dans une invite élevée):

reg load HKEY_USERS\temp "%USERPROFILE%\..\Default\NTUSER.DAT"
reg add "HKEY_USERS\temp\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3
reg unload HKEY_USERS\temp

9
2018-05-22 14:21



Que font ces commandes? - kleinfreund
@kleinfreund Comme mentionné dans la première phrase, il désactive les raccourcis clavier qui permettent de basculer la mise en page, afin de ne pas pouvoir la modifier par inadvertance. - mivk
Merci! Exécution d'un build d'initié et ils ont complètement supprimé la section de langue du panneau de configuration. Je ne peux toujours pas comprendre ce qui a conduit Microsoft à utiliser une telle combinaison de touches couramment utilisée - samdd
Merci! La seule façon de travailler en 2018 pour bloquer la commutation alt-shift / ctrl-shift, il semble que le composant d'interface utilisateur où vous pourriez le changer soit parti, je ne le trouve nulle part. - jakub.g


Solution1

utiliser cette solution- Comment désactiver la modification automatique de la disposition du clavier dans Windows 8? 

Solution2

Choisissez la seconde langue par défaut. puis, lorsque vous passez au premier, il reste commuté.

(merci à @SimonSeyock):

win + space changements entre toutes les paires langue / clavier.  
alt + shift  ne change que la langue  
ctrl + shift ne change que le clavier


5
2018-03-19 07:13



Solution 1 n'offre pas réellement une solution dans ce lien. Cela résout un Procédé d'entrée pas une langue d'entrée. - msysmilu
alt + shift l'a fait pour moi. Rien d'autre n'a vraiment fonctionné - Ghoti and Chips


Mon problème: j'ai 3 langues (dispositions de clavier) installées. Lorsque vous dormez sous Windows 10, puis que vous vous réveillez, il revient toujours par défaut à la "langue principale", au lieu de conserver le dernier ensemble. Je considère cela comme un bug.

Solution:

  1. Ouvrir Control Panel\All Control Panel Items\Language.
  2. Cliquer sur Advanced Settings.
  3. En dessous de Switching input methods, vérifier la Let me set a different input method for each app windows.

Cela gardera la langue pour aller dormir et revenir.


5
2018-05-04 03:56



Merci. Cela a résolu mon problème avec la disposition du clavier revenant toujours à la "valeur par défaut" après le redémarrage et après le sommeil. J'ai également 3 dispositions de clavier installées. Anglais, car il fonctionne mieux avec certains jeux et deux suédois. Qwerty normal et dvorak. - Albert Veli
J'ai eu un problème similaire, résolu en définissant mon clavier directement sous la langue principale: voir superuser.com/a/1322521/97570 - jakub.g


2018 réponse:

J'ai eu le même problème, en essayant d'utiliser le clavier polonais avec la langue anglaise de l'interface utilisateur de Windows.

Chaque fois que j'ai verrouillé l'ordinateur, il est revenu au clavier américain.

Le problème était que je possédais un clavier polonais en polonais, où en fait, je voulais vraiment un clavier polonais en anglais.

J'ai enlevé le pack de langue polonaise, ajouté le clavier polonais sous la langue anglaise et enlevé le clavier américain de la langue anglaise - voir la capture d'écran ci-dessous:

Windows 10 (2018) language preferences

En bref, l'astuce consiste à ajouter le clavier de votre choix comme seul clavier dans la langue par défaut.

(Cela fonctionne pour moi parce que je tape généralement en anglais, seulement parfois je veux entrer en polonais, mais je peux le faire sans changer le clavier, puisque le clavier polonais est entièrement compatible avec US QWERTY).


4
2018-05-14 12:43





Ce top résultat de Google travaillé sur mon nouvel ordinateur portable Windows 10:

Définir une disposition de clavier par défaut:

  1. Clique le Le menu Démarrer et sélectionnez Paramètres.
  2. Sélectionner Temps et langue.
  3. Cliquez sur Région et langue dans la colonne de gauche.
  4. En dessous de Langues cliquez sur la langue que vous voulez par défaut et cliquez sur Définir par défaut.

0
2017-12-13 15:20



Je vais essayer et voir si cela aide réellement. Ca a du sens + c'est la seule chose que je n'ai pas encore essayée :) - krizajb