Question Écran GNU - Suppression de la fenêtre vim après la fermeture


J'utilise urxvt avec l'écran GNU avec X11 sur mon mac. Je l'aime beaucoup. Mon seul problème, c'est que lorsque je quitte vim, il met l'invite du shell sous la fenêtre vim. Ce n'est pas un problème énorme, mais il cache essentiellement tout ce que je faisais avant d'ouvrir vim. Si j'utilise urxvt sans écran GNU et que je quitte vim, cela masque la fenêtre vim et place mon invite de commande juste après l'invite qui a ouvert vim.

Avez-vous une idée de ce que je peux réparer dans l'écran pour vous aider?

Cela a-t-il quelque chose à voir avec le blanker?


11
2017-09-15 19:53


origine


voici un bon lien avec les paramètres courants que vous devriez avoir dans votre screenrc ou .screenrc wiki.linuxquestions.org/wiki/Screen - Spike


Réponses:


Activer le altscreen option dans ~/.screenrc.

Les programmes plein écran utilisent une fonctionnalité de terminal appelée «écran alternatif», qui dispose d'un tampon d'écran distinct et de changements de comportement (souvent) mineurs pour s'adapter à ces interfaces. Le programme entre dans l'écran «Alternatif» au démarrage et revient à «normal» à la sortie.

Comme Screen lui-même agit en tant qu'émulateur de terminal, il doit également émuler la fonction d'écran alt. Tous les autres émulateurs de terminaux activent cette fonctionnalité par défaut, mais Screen la cache derrière le altscreen option pour des raisons historiques.


18
2017-09-15 20:47



Je ne peux pas t'enlever assez! - George


Ajoutez cette ligne à votre ~ / .screenrc:

altscreen on

10
2017-09-15 20:48