Question Comment empêcher Windows 10 d'ajouter automatiquement des dispositions de clavier (par exemple, clavier américain)


Mettre à jour: c'est un long message, vous pouvez sauter directement à la réponse ci-dessous


Remarque: La liste de langues rapide se réfère à la liste dans la capture d'écran ci-dessous, accessible via le raccourci Win + barre d'espace

J'ai deux langues pour la vérification orthographique de Windows dans mon système, États Unis Anglais) et Français (Suisse), mais bien que les deux langues soient correctement configurées avec le clavier d’entrée "Swiss French", Clavier américain entrée continue d'apparaître sur cette liste:

enter image description here

Voici les paramètres pour États Unis Anglais) langue, vous pouvez voir que la seule entrée est "suisse français":

enter image description here

Pareil pour Français (Suisse), la seule entrée est "Swiss French":

enter image description here

Dans le panneau de configuration, les deux sont également définis en français suisse:

enter image description here

Tous mes paramètres sont configurés pour utiliser "liste de langues":

enter image description here enter image description here

Voici quelques petites choses que j'ai déjà essayées:

  • J'ai déjà réussi à le supprimer par une gymnastique de configuration de la langue, en ajoutant et en supprimant des langues, il finit toujours par revenir
  • Je l'ai déjà fait: https://superuser.com/a/484595/168632
  • Il n'y a aucune mention de US Keyboard dans mes paramètres de registre:

enter image description here

S'il vous plaît aider, je suis désespéré, ceci est mon troisième ordinateur avec Windows 10 et ils font tous la même chose.


65
2018-06-22 13:36


origine


Et si vous aviez besoin d'un script qui s'exécuterait à Autostart + SUPPRIMEZ CES INSCRIPTIONS? - Sergey Larin
Win + Maj + Barre d'espace - SmartManoj
Windows 10 Avril 2018 Update a ajouté une langue supplémentaire et je ne peux pas le supprimer - SmartManoj


Réponses:


Pour résoudre ce problème, supprimez le Précharge dossier de Registre et déconnecter ou redémarrer l'ordinateur:

HKEY_USERS\.DEFAULT\Keyboard Layout\Preload

Ce dossier semble être un résidu hérité qui contient des dispositions de clavier non spécifiées par l'utilisateur à ajouter à la liste des langues lorsque l'utilisateur se connecte. Alors que le correctif lui-même fonctionne à travers les redémarrages, au moment d'écrire, il y a des choses qui ramènent ce dossier embêtant, voici quelques-uns que j'ai personnellement rencontrés:

  • Bureau à distance sur un ordinateur avec mise en page américaine
  • Mise à jour 10 anniversaire
  • Utiliser le même compte Microsoft sur un autre PC qui a toujours ce compte problème

Chaque fois que le problème revient, ce dossier de registre doit être supprimé à nouveau.

Modifier: J'ai créé un RemovePreload.reg fichier texte avec le contenu suivant, de cette façon, ce correctif peut facilement être réappliqué à chaque fois sans naviguer dans le registre:

Windows Registry Editor Version 5.00

[-HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]

Pour l'utiliser, enregistrez-le dans un fichier texte et modifiez l'extension à partir de .txt à .reg. Ensuite, chaque fois que vous revenez, vous pouvez simplement double-cliquer dessus et redémarrer ou vous déconnecter.


65
2018-06-29 14:00



Merci! C'était la seule chose qui a finalement résolu le problème pour moi. La disposition du clavier américain a toujours été ajoutée lorsque je me suis connecté. Je pourrais le supprimer en l'ajoutant d'abord, puis en le retirant, comme la réponse de Snaiper, mais il réapparaîtrait toujours au redémarrage. Cela semble l'avoir supprimé définitivement. - The Oddler
Il apparaît après un moment quand même. - troorl
Oui, il a réapparu pour moi maintenant :( Il n'a pu redémarrer qu'une seule fois sans que cela réapparaisse, semble-t-il. - The Oddler
La solution consistant à ajouter et supprimer le clavier est beaucoup plus sûre et aussi hackeuse que celle-ci :) - user2158153


En fait, la solution est assez simple et ne nécessite aucune modification du registre!

  • Aller à Région et langue (précédemment nommées Préférences de langue), cliquer sur États Unis Anglais) et allez à Les options.

  • Si vous voyez "US Keyboard", l'enlever, et tu as fini.

  • TOUTEFOIS, si vous ne le voyez pas, cliquez sur Ajouter un clavier, ajoutez "US keyboard", puis retirez ce clavier et vous avez terminé.

Je me suis rendu compte après quelques essais et erreurs en essayant diverses choses, j'avais le même problème.


43
2018-01-28 11:03



Travaillé pour moi, merci! - Arthur Castro
Il apparaît à nouveau après le redémarrage. - troorl
Le troisième point est littéralement: "As-tu essayé de l'allumer et de l'éteindre à nouveau?" ... et c'était à propos :) Merci pour ça! - ccjmne
Comme pour @troorl, le clavier américain réapparaît après un redémarrage. - Enora
Ne fonctionne pas après le redémarrage, j'ai testé cela avant de venir avec la solution ci-dessus - Luis Ferrao


Theres est deux endroits pour la configuration du clavier dans Windows 10, panneau de contrôle -> langue

L'autre est dans le réglage comme votre capture d'écran

Faire les changements là aussi, il devrait résoudre le problème.

enter image description here


3
2018-06-22 13:44



Malheureusement ce n'est pas ça, j'ai ajouté une capture d'écran de cet écran sur mon ordinateur, elle est correctement configurée avec "Swiss French" exactement comme dans la nouvelle interface. - Luis Ferrao


Je n'ai pas eu d'entrée 409 dans le registre (voir anwer accepté). Les mesures que j'ai prises pour supprimer l'anglais (US) du menu de sélection rapide:

  1. Ouvrez "Préférences de langue" dans le menu de sélection rapide.
  2. Ajouter la langue anglaise (US).
  3. Supprimer la langue anglaise (US).

Astuce: Dans le Panneau de configuration \ Tous les éléments du Panneau de configuration \ Langue \ Paramètres avancés -> Changer les touches de raccourci de la barre de langue


3
2017-09-20 19:25



Je pense que votre réponse manque le but de cette question. Le problème n’est pas de supprimer la langue anglaise, que je saisis et que je veux absolument inclure dans ma liste de langues. Le but est de supprimer une disposition "US Keyboard" inexistante qui ne correspond pas à ma propre disposition de clavier de temps en temps comme une "langue" supplémentaire dans la liste des langues. Il y a beaucoup de discussions concernant la suppression de la langue anglaise elle-même, mais celle-ci n'en fait pas partie. Je ne veux pas non plus supprimer la liste de langues, je l'utilise pour passer rapidement d'une langue à l'autre (pour le correcteur orthographique de Windows). - Luis Ferrao


  1. Panneau de contrôle
  2. Horloge, langue et région
  3. La langue
  4. Modifier les méthodes de saisie
  5. Réglages avancés
  6. Remplacer pour la méthode de saisie par défaut
  7. Choisissez votre mise en page préférée (au lieu de "Utiliser la liste de langues")
  8. sauvegarder

Screenshot of Input settings -> Advanced settings


2
2017-09-21 09:56



Relire "Pourquoi ai-je besoin de 50 points de réputation pour commenter" pour vous assurer de comprendre comment vous pouvez commencer à commenter. - Pimp Juice IT


La réponse de Mikel ci-dessus corrige cela… mais juste au cas où cela réapparaîtrait pour vous (comme pour moi): Avez-vous peut-être un raccourci AutoHotkey personnalisé pour modifier les dispositions de clavier?

Le problème était que mon script AutoHotkey contenait les lignes de code suivantes:

; This should be replaced by whatever your native language is. See 
; http://msdn.microsoft.com/en-us/library/dd318693%28v=vs.85%29.aspx
; for the language identifiers list.
el := DllCall("LoadKeyboardLayout", "Str", "00000408", "Int", 1)
en := DllCall("LoadKeyboardLayout", "Str", "00000409", "Int", 1

Donc, sur mon bureau, cela fonctionnerait parfaitement et passerait de l’anglais (disposition du clavier au Royaume-Uni) au grec (disposition du clavier GR) et vice versa, sur mon ordinateur portable doté d’un clavier américain. le bleu sur mon sélecteur de langue.

J'espère que ça aide!


1
2017-12-24 15:27





Ce n'est pas le correctif permanent, mais un fichier de commandes à portée de main pour remplacer l'ajout manuellement en-US et le supprimer.

Remove_en-US.xml:

<gs:GlobalizationServices xmlns:gs="urn:longhornGlobalizationUnattend">

    <!--User List-->
    <gs:UserList>
        <gs:User UserID="Current"/>
    </gs:UserList>

    <!--input preferences--> 
    <gs:InputPreferences>
        <!--add en-US keyboard input-->
        <gs:InputLanguageID Action="add" ID="0409:00000409"/>
        <!--remove en-US keyboard input-->
        <gs:InputLanguageID Action="remove" ID="0409:00000409"/>
    </gs:InputPreferences>

</gs:GlobalizationServices>

Remove_en-US.bat:

control intl.cpl,, /f:"%CD%\Add_en-US.xml"

Ensuite, vous pouvez simplement courir Remove_en-US.bat pour supprimer la mise en page. J'ai également un raccourci vers ce fichier de commandes dans mes programmes de démarrage.

Ici, 0409 est le locale ID et 00000409 correspond aux valeurs de disposition du clavier. Pour la liste des locale ID:keyboard layout value voir https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-8.1-and-8/hh825682(v=win.10).


1
2018-01-07 23:28