Question Comment contourner l'avertissement "Échec de la connexion sécurisée" dans Firefox 33


Depuis l'installation de Firefox 33, l'erreur "Secure Connection Failed" n'est plus contournable en utilisant le
"Je comprends les risques"bouton - c'est parti!

Est-il toujours possible d'ignorer les erreurs de certificat? (par exemple pour une utilisation paresseuse dans des environnements locaux)
Code d'erreur: sec_error_invalid_key
 

Warnings


66
2017-10-14 17:37


origine


Êtes-vous 100% les deux messages d'erreur sont les mêmes, car dans mon expérience, ils ne le sont pas. - Ramhound
Je me penche également vers "une erreur différente". Juste mis à jour à Firefox 33 et la boîte de dialogue "Connexion est non fiable" est inchangée pour moi. Un changement comme vous le suggérez (suppression du choix de l'utilisateur pour les certificats non valides) serait tellement différent sur les interfaces Web des intranets d'entreprise, de nombreuses parties sur Internet et en particulier des périphériques SOHO tels que les modems câble et les routeurs WiFi. Il est plus probable qu'il y ait un problème réel de connexion au serveur ou à quelque chose. Avez-vous essayé d'autres sites HTTPS dotés de certificats non valides? - Iszi
Il est également possible que vous rencontriez un bogue connu qui semble avoir été autour depuis FF 31. - Iszi
Je crois que vous avez obscurci le code d'erreur réel. En outre, l'image est petite. - Daniel B
Je peux confirmer que FF33.0 échoue avec (Code d'erreur: sec_error_invalid_key) sur le même site que 32.0 a travaillé avant la mise à niveau, sur le même ordinateur client. Il fonctionne toujours sur Ubuntu / Canonical FF30.0 comme toujours. (même que les captures d'écran). - MattBianco


Réponses:


Ouvrez Firefox about:config

Ensemble security.tls.insecure_fallback_hosts = www.domain.com (remplacez le domaine avec lequel vous avez un problème)

Recharge la page


29
2018-05-19 21:11



C'est la réponse qui répond effectivement à la question. Certaines des réponses les plus élogieuses sont tout à fait à propos (ne donnant aucune solution à la question et donnant des solutions aux problèmes de webmin) ... - pgr
Cela a fait ne pas travailler pour moi dans Firefox 48.0 (système d'exploitation GNU / Linux, si cela fait une différence). - code_dredd
Ne fonctionne pas dans Firefox 53.0 Mac. Peut-être que je dois essayer de mettre en liste blanche une adresse IP, 192.168.1.219, et non un nom de domaine. - sudo
C'est une question extrêmement ancienne. La solution actuelle (2017) était impossible lorsque la question d'origine a été publiée et la question a été modifiée / améliorée depuis qu'elle a été initialement posée. - MattBianco
Alors à quelle version de FF cette réponse est-elle applicable? Et comment voulez-vous ajouter plus d'un site Web? Concaténer avec des virgules, des points-virgules? Nombre surprenant de votes pour une réponse faible. - Adam


Ce problème a été signalé à Mozilla dans leur forum de support.

La raison en est que Firefox 33 a complètement basculé vers le plus strict libPKIX et vous ne pouvez plus désactiver cette bibliothèque et revenir à la précédente NSS code.

Voir connexes Blog Mozilla poster et bug:

Bug 975229 - Supprimer la vérification de certificat basée sur NSS

Il semble qu'ils vont ne pas changer ce comportement.

Si votre problème est comme le mien, sur un webmin site, essayez de recréer le certificat à partir de webmin. Cela m'a aidé à récupérer "l'exception de sécurité" dans FF 33.0!


14
2017-10-15 15:48



Je peux confirmer que la recréation du certificat a ramené l’ancienne boîte de dialogue connue de FF32 et ci-dessous. Merci Matt! Pour tout le monde affecté par ceci, voici un bon guide sur comment recréer votre certificat. - RienNeVaPlu͢s
En outre, Firefox affichera l'erreur standard de certificat non approuvé si vous créez un certificat auto-signé avec le CN défini sur votre nom de domaine. - Toothbrush
Merci d'avoir fourni une solution, mais en tout cas c'est GODDAMN COMPLICATED! Firefox est moins utilisable chaque jour, c'est comme s'ils essayaient de forcer tout le monde à intégrer Chrome. - Mephisto
C'est ridicule en effet. - Erwin


J'ai eu le même problème avec Webmin et firefox 33. Lorsque j'ai regardé le certificat SSL utilisé par Webmin, j'ai constaté qu'il utilisait une clé 512 bits! Cela a dû être la taille de clé par défaut lorsque j'ai installé Webmin il y a quelques années.

Firefox 33 ne prend plus en charge les clés de moins de 1024 bits (avec raison). Voir compatibilité du site

Vous pouvez corriger ce problème directement à partir de Webmin si vous utilisez un autre navigateur qui vous permet de contourner ce type d'erreur ou si vous désactivez temporairement SSL dans webmin en définissant ssl = 0 dans /etc/webmin/miniserv.conf et redémarrez webmin avec "/ etc / init.d / webmin restart ". Connectez-vous simplement à l'interface Web Webmin et sélectionnez: Webmin -> Webmin Configuration -> SSL Encryption -> Self Signed Certificate. Remplissez le formulaire (ou laissez les valeurs par défaut), puis cliquez sur le bouton Create Now bouton. Si vous avez temporairement désactivé ssl, activez-le avec ssl = 1 dans /etc/webmin/miniserv.conf et redémarrez webmin avec "/etc/init.d/webmin restart". Cela mettra à jour votre certificat auto-signé pour Webmin et vous pourrez désormais accéder à la page à partir de Firefox 33 (avec l'avertissement habituel du navigateur concernant une connexion non fiable).


10
2017-10-17 21:03



Donc, il n'y a aucun moyen d'accepter ces certs de toute façon? - Geremia


Essayé la suggestion par @wisbucky mais besoin de redémarrer le navigateur pour contourner l'erreur "Secure Connection Failed".

Les étapes suivies étaient -

Ouvrez la configuration de Firefox en tapant la suite dans la barre d'adresse -

à propos de: config

Recherchez security.tls.insecure_fallback_hosts et définissez-le sur

security.tls.insecure_fallback_hosts = nom d'hôte de l'erreur de lancement du site


5
2018-05-21 11:46





Pour les messages concernant une clé DH faible, essayez de basculer les préférences suivantes (dans Firefox). about:config):

  • security.ssl3.dhe_rsa_aes_128_sha
  • security.ssl3.dhe_rsa_aes_256_sha

Cela a résolu une erreur "Secure Connection Failed" que je voyais:

SSL a reçu une clé Diffie-Hellman éphémère faible dans la clé du serveur   Échange de message de poignée de main. (Code d'erreur:   ssl_error_weak_server_ephemeral_dh_key)


3
2017-07-09 20:12



Je vous remercie! Depuis la dernière mise à jour FF, je ne pouvais plus accéder à mon routeur en raison de ce message d'erreur. Fonctionne bien maintenant! D'un autre côté, je souhaite que la société dudit routeur ne soit pas si fainéante et qu'il suffit de mettre à jour le firmware avec de nouveaux certificats, car ils ont déjà un an de validité. - rfreytag


La clé web ssl initiale de webmin est de 512 octets

Solutions: utilisation de chrome ou firefox, connexion à webmin, dans la configuration webmin -> Cryptage SSL-> Certificat auto-signé

créer une nouvelle clé SSL et un nouveau certificat pour votre serveur Webmin, la clé RSA sélectionner la valeur par défaut (2048) et activer l'option "Utiliser une nouvelle clé immédiatement"

alors vous pouvez utiliser IE accès Webmin


0
2017-10-22 10:34





Un autre correctif potentiel à noter: dans votre about:configVotre profil utilisateur peut comporter des paramètres endommagés.

Un en particulier qui a été noté ici: security.tls.version.max

En particulier, la discussion sur le site lié indique que d’une manière ou d’une autre la security.tls.version.max le réglage avait été changé de sa valeur d'origine (3) à la nouvelle valeur de 1, et après ce changement, l'utilisateur n'a pas été en mesure de se connecter à certains sites nécessitant le plus récent Transport Layer Security.

Un moyen simple de vérifier si cela se produit sans avoir à vous soucier de votre about:config est d'essayer de créer un nouveau profil, en exécutant firefox -P puis créer un nouveau profil et voir si vous pouvez visiter le site avec succès.


0
2018-05-22 14:25