Question Forcer Chrome à ouvrir les URL en tant qu'URL, au lieu de rechercher


J'ai un serveur Apache local en cours d'exécution, défini par /etc/hosts comme "apache". J'ouvre donc souvent des pages comme:

http://apache/website/

Normalement, cela fonctionne bien. Cependant, étant donné que j'utilise un navigateur Chrome plus récent, le navigateur décide parfois que l'URL que je tape n'est pas une URL mais une recherche. Il charge donc mon moteur de recherche par défaut et tente de trouver cette URL. Il affiche souvent, mais pas toujours, un lien sous la barre d’adresse indiquant Did you mean to go to http://apache/website?. C'est bien, mais très ennuyeux de devoir cliquer ici au lieu d'y aller directement. Qu'est-ce qui fait que Chrome se comporte de cette façon? Puis-je résoudre ce problème?


66
2017-11-05 22:50


origine




Réponses:


J'ai eu le même problème et j'ai trouvé que taper le / à la fin le traitera toujours comme une URL au lieu de mot-clé.

Par exemple dans mon cas:

local.dev/ben is treated as search

mais

local.dev/ben/ its working fine

50
2017-07-28 17:49



Dire que l'ajout d'un / à la fin le traitera toujours comme une url au lieu d'un mot-clé n'est pas toujours vrai, par exemple les adresses locales de liens de portée déclencheront une recherche même si un / est présent: https://[fe80::1%eth0]/ - Tiernan
Ne fonctionne pas pour mon serveur nodejs amélioré http://0.0.0.0:8080/bla/ Ne marche pas! - hitautodestruct
@hitautodestruct 0.0.0.0 n'est pas une adresse IP valide, c'est une adresse fictive qui signifie généralement une route par défaut dans le routage, ou toutes les adresses ipv4 sur l'hôte pour les services. Vous devrez y accéder via une adresse IP valide attribuée à votre hôte. - Steve Buzonas


Vous pouvez le faire implicitement en créant un nouveau moteur de recherche avec une URL de http://%s et mot clé de null. Ensuite, définissez cette option comme moteur de recherche par défaut.

Pour accéder à la page des moteurs de recherche en chrome:

  • Ouvrir Settings panneau.
  • Cliquez sur Manage search engines... bouton sous Search titre.
  • Search Engines le volet a deux sections: Default search engines et Other search engines
  • Au bas de la Other search engines section, vous verrez un formulaire que nous utiliserons pour ajouter un nouveau moteur de recherche.

Search Engines


28
2017-11-05 23:31



C'est un bon tour. Je vais devoir l'essayer! - afrazier
@iglvzx Merci, mais cela ne fonctionne que si je toujours voulez ouvrir un mot clé de cette façon. J'aime vraiment continuer à utiliser Google Search lors de la saisie d'autres mots, mais je ne veux tout simplement pas que cela se produise lorsque je tape une URL localhost.
Il n'est plus possible de définir "null" comme mot-clé de Chrome v26. - skolima
@skolima C'est possible en v27.0 - svandragt
@svandragt: v27 est maintenant stable et malheureusement, il est toujours désactivé. Merde. - skolima


Cela m'a énervé aussi. J'ai récemment découvert ce qui l'a causé. Essayez de désactiver «Utiliser un service Web pour résoudre les erreurs de navigation».


13
2018-02-28 10:08



Cela ne fonctionne pas si j'ajoute ensuite à l'URL. par exemple. Je charge local.symphony-2.3 et ajoute / symphony ou / symphony / à l'URL, chrome recherche google pour cette phrase. - codecowboy
Cela fonctionne parfaitement pour moi, merci! - Nik
Dans Chrome 54, ceci se trouve dans "Afficher les paramètres avancés" en bas de about://settings page. - DanFromGermany


Si vous connaissez le port que vous utilisez, vous pouvez le spécifier à la main comme

url: 80 / index.html

au lieu de

url / index.html

Dans le premier cas, il ne sera pas traité comme une demande de recherche


3
2018-03-29 22:23





Voici comment désactiver la possibilité d'effectuer des recherches à partir de la barre d'adresse (omnibox) de Google Chrome:

  1. Ouvrez Google Chrome.
  2. Type chrome://flags dans la barre d'adresse et appuyez sur Entrée.
  3. Faites défiler jusqu'à Activer le bouton de recherche dans Omnibox.
  4. Sélectionner désactivé.

1
2018-02-01 22:28



Je n'ai pas cette option; quelle version utilisez-vous? - Ben N


Je devais ajouter google.co.in avec la chaîne de recherche: http://google.com/search?q=%s pour que Google Search et la recherche d’URL fonctionnent.

Maintenant, si je veux parcourir l'URL, je peux simplement ajouter 'http: // peu importe'et choisissez si je veux faire une navigation ou une recherche d’URL.

La réponse de @ iglvzx ne semble plus fonctionner dans la version 40 de Chrome. Il semble que Null ne soit plus une entrée valide. J'ai dû improviser comme ci-dessus pour que cela fonctionne.


0
2018-01-24 08:34



Hmm ne fonctionne pas pour moi sur Chrome 40. Quel bug étrange. - jfroom


J'ai eu le même problème avec Chrome sur mon téléphone Android. Je l'ai résolu de façon similaire à la suggestion de @Rik.

Pour Chrome mobile:

  1. Aller à Paramètres -> Intimité
  2. Décocher Suggestions d'erreur de navigation

0
2018-01-26 12:45



J'ai dû décocher les "suggestions d'erreur de navigation" et les "suggestions de recherche et de site" (les deux premières options) avant que Chrome ne cesse de transformer mes URL en requêtes de recherche. après je pouvais activer les deux paramètres et chrome ouvrait toujours mes URL comme il se doit. mauvais chrome. mauvaise boîte noire de chrome. j'utilise firefox kthxbye - lesmana