Question Comment définir l'encodage des caractères lors de l'ouverture d'Excel


Est-il possible de définir le codage par défaut pour Excel (toute version, par exemple 2010) lors de l'ouverture de fichiers tels que des fichiers CSV (comme vous pouvez le faire dans Open Office Calc)?

I Lorsque j'essaie d'ouvrir un fichier csv encodé en japonais SHIFT-JIS, il s'ouvre mais avec le mojibake (caractères corrompus). Dans Open Office Calc, si vous cliquez sur un fichier csv avec un codage non standard comme SHIFT-JIS, une boîte de dialogue s'ouvre automatiquement pour vous permettre de définir le codage.


67
2018-05-08 02:42


origine


Quelle version d'Excel? - paulmorriss
2003 ou 2010 (j'ai sauté 2007) - lozzer


Réponses:


Utilisez la fonction d'importation sous l'onglet "Données" où Excel nous permet de spécifier le codage. Sélectionnez "from text" et choisissez votre fichier csv, puis sélectionnez le codage japonais shift-jis.


66
2018-06-27 15:32



fonctionne parfaitement pour xl2007 et xl2010 - SooDesuNe
Désolé, je n'ai pas vérifié jusqu'à maintenant. L'approche "Data" -> "From Text" fonctionne bien avec xl2007 et xl2010. Pas évident mais ça marche. - lozzer
Fonctionne également dans Excel 2016 - Korayem
Sur Excel 2016 pour Mac: ouvrez d'abord la feuille de calcul vide, puis dans le menu principal, accédez à "Données" -> "Obtenir des données externes" -> "Importer un fichier texte". - DaddyM
Mis en veilleuse, car l'utilisation de la fonction d'importation (ou de l'assistant de saisie de texte dans les colonnes) signifie que les sauts de ligne à l'intérieur des cellules seront perturbés (cela n'est plus le cas depuis Excel). Il encapsulera la ligne suivante dans une nouvelle ligne et, par conséquent, supprimera l'intégralité de la disposition des données ci-dessous. - CoDEmanX


Les étapes suivantes fonctionnent avec Office 2003.

  1. Renommez .csv en .txt
  2. Ouvrez le fichier .txt à partir d'Excel (ne le faites pas avec un clic droit sur le fichier puis ouvrez avec Excel), Excel ouvrira une boîte de dialogue Assistant Importation de texte, demandez le format du fichier .txt, y compris le codage du fichier texte.
  3. Renommez .txt en .csv une fois votre modification terminée.

6
2018-06-24 09:09





Sur Excel 2016 pour Mac:

  1. créer une feuille de calcul vierge,
  2. dans le menu principal aller à Data -> Get External Data -> Import Text File,
  3. suivez les étapes de l'assistant - choisissez l'encodage jusqu'à ce que vous voyiez l'aperçu correct et, à l'étape suivante, choisissez le délimiteur des colonnes (les délimiteurs diffèrent des fichiers csv aux fichiers csv).

3
2018-06-06 11:43





Voir si cela aide (MS Excel 2007 et supérieur).

  1. Ouvrez Excel et cliquez sur le Microsoft Orb en haut puis cliquez sur Options Excel.

  2. Aller à Avancée, puis regardez pour le Options Web bouton. Il devrait être sous général.

  3. Allez à la Codage onglet et choix Maj Japonais-JIS dans le menu déroulant. Cliquez sur D'accord, redémarrez Excel et essayez d'ouvrir votre fichier.


2
2018-05-10 17:31



Cela n'a pas fonctionné. Mon système est un système japonais et SHIFT-JIS est donc défini ici par défaut. Mais j'ai mon défaut l'édition langue définie pour l'anglais (avec le japonais également ajouté). Si je mets la langue d'édition par défaut en japonais, le fichier csv SHIFT-JIS s'ouvre correctement. Mais c'est compliqué. Que faire si le fichier était un autre encodage (par exemple, coréen, chinois)? Ce dont j'ai vraiment besoin, c'est d'un endroit pour définir l'encodage du fichier (comme je peux le faire dans Open Office Calc). - lozzer
Cela devrait fonctionner pour économie, mais pas pour l'ouverture. Je me demande si cela a du sens de choisir un encodage quand ouverture un fichier. Est-ce que cela résoudrait le problème? - Veverke


Lozzer a fourni d'excellents commentaires dans les petits caractères:  "Si je mets la langue d’édition par défaut en japonais, le fichier csv SHIFT-JIS s’ouvrira correctement ...."

J'ai passé des heures à chercher une solution pour ouvrir le CSV japonais d'un simple clic Nous avons un environnement multilingue (En-Jp).

Même si Excel affichait des menus japonais (basés sur les paramètres de langue des panneaux de contrôle), le paramètre de modification par défaut dans File > Options > Language > Choose Editing Language (Zone supérieure) est resté anglais. Changer cela en japonais (évidemment pas de problème pour les utilisateurs japonais) a résolu notre problème.


0
2017-08-02 01:15