Question Trouver des paquets de pépins obsolètes / actualisables


pip freeze me montre les paquetages installés, mais comment vérifier avec pypi ceux qui sont obsolètes?


67
2018-03-19 04:24


origine




Réponses:


Depuis la version 1.3, pip comporte une nouvelle commande:

$ pip list --outdated
requests (Current: 1.1.0 Latest: 1.2.0)

Voir ce post pour plus d'informations.


101
2018-04-27 12:40





Utilisez cette fourchette:

https://github.com/dgladkov/pip

Qui fait exactement ce que vous voulez en utilisant cette commande:

$ pip list --outdated

6
2018-04-25 13:37



lol, merci dsa. Nous avons tous les deux déjà commenté la fourchette avant :) - Xster


La chose est, Je ne mets jamais à jour tous les paquets. Je n'améliore que ce dont j'ai besoin, parce que le projet peut casser.

Comme il n'y avait pas de moyen facile de mettre à jour le paquet par paquet et de mettre à jour le fichier requirements.txt, j'ai écrit ceci: pip-upgrader lequel met également à jour les versions de votre requirements.txt fichier pour les packages choisis (ou tous les packages).

Installation

pip install pip-upgrader

Usage

Activez votre virtualenv (important, car il installera également les nouvelles versions des packages mis à niveau dans virtualenv en cours).

cd dans votre répertoire de projet, puis exécutez:

pip-upgrade

Utilisation avancée

Si les exigences sont placées dans un emplacement non standard, envoyez-les en arguments:

pip-upgrade path/to/requirements.txt

Si vous savez déjà quel paquet vous souhaitez mettre à niveau, envoyez-les simplement en tant qu'arguments:

pip-upgrade -p django -p celery -p dateutil

Si vous devez effectuer une mise à niveau vers la version antérieure ou postérieure à la publication, ajoutez --prerelease argument à votre commande.

Divulgation complète: j'ai écrit ce paquet.


2
2018-04-26 12:03





Peut-être des outils de pipetage, disponibles à https://github.com/nvie/pip-tools, pourrait vous aider à atteindre ce que vous voulez?

Un exemple du fichier README:

$ pip-review --interactive
requests==0.14.0 available (you have 0.13.2)
Upgrade now? [Y]es, [N]o, [A]ll, [Q]uit y
...
redis==2.6.2 available (you have 2.4.9)
Upgrade now? [Y]es, [N]o, [A]ll, [Q]uit n
rq==0.3.2 available (you have 0.3.0)
Upgrade now? [Y]es, [N]o, [A]ll, [Q]uit y
...

1
2018-02-06 11:04



Il semble que ce paquet est maintenant passé à github.com/jgonggrijp/pip-review - Droplet


Semblable à pip list --outdated mais met à jour un requirements.txt fichier:

pur -r requirements.txt

PyPi: https://pypi.python.org/pypi/pur

GitHub: https://github.com/alanhamlett/pip-update-requirements


0
2018-06-01 22:51