Question Installer OpenWRT


Je suis un débutant en réseau complet, essayant d'installer OpenWRT sur un TPLink 703N, en suivant ces instructions: http://wiki.xinchejian.com/wiki/Install_OpenWRT_on_TPlink_WR703N

Ayant installé et OpenWRT et configuré comme indiqué sur cette page, nous essayons d’en voir l’internet (afin d’exécuter opkg, etc.). Nous avons le TPLink connecté à notre routeur / modem via un câble Ethernet et peut y accéder depuis les autres machines du même réseau.

Cependant, nous ne pouvons pas a) voir le TPLink lui-même en tant que routeur wifi. (Ne ressemble pas au wifi est actuellement activé) b) voir internet depuis l'intérieur (pour faire fonctionner opkg etc.)

Quelqu'un peut-il donner des indices (en langage plutôt simple) sur la façon de déboguer ceci? Quel genre de problèmes devrions-nous rechercher? Et comment devrions-nous les résoudre?

/ etc / config / network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'wlan0'
    option proto 'dhcp'

/ etc / config / wireless

config wifi-device  radio0
    option type     mac80211
    option channel  11
    option hwmode   11ng
    option path 'platform/ar933x_wmac'
    option htmode   HT20
    list ht_capab   SHORT-GI-20
    list ht_capab   SHORT-GI-40
    list ht_capab   RX-STBC1
    list ht_capab   DSSS_CCK-40
    # REMOVE THIS LINE TO ENABLE WIFI:
    #option disabled 1

config wifi-iface
    option device   radio0
    #option network  lan
    option network  wan
    #option mode     ap
    option mode     sta
    option ssid     'THE NAME OF OUR EXISTING WIFI NETWORK'
    #option encryption none
    option encryption wep+shared
    option key 'WEP PASSWORD FOR OUR EXISTING WIFI NETWORK'

à votre santé

phil


2
2017-12-20 14:40


origine


Afficher les interfaces réseau activées avec ip link et voir vos paramètres wifi avec iwconfig wlan0 ou iw -i wlan0 status. Pour le débogage, il existe des journaux cat /var/log/messages | more et cat /var/log/syslog | more (pas sûr si celui-ci est en openwrt) - week


Réponses:


Pour vos problèmes sans fil, si nous examinons votre configuration sans fil:

config wifi-iface
    option device   radio0
    #option network  lan
    option network  wan
    #option mode     ap
    option mode     sta
    option ssid     'THE NAME OF OUR EXISTING WIFI NETWORK'
    #option encryption none
    option encryption wep+shared
    option key 'WEP PASSWORD FOR OUR EXISTING WIFI NETWORK'

Vous avez le mode ap ligne a commenté et remplacé par le sta option. Selon le Documentation OpenWRT, cela signifie que l'interface sans fil est configurée pour le mode client. Avec les autres options que vous avez en place, votre appareil est configuré pour agir en tant que périphérique client et se connecter à votre réseau existant. Car si tel est le cas, il ne peut pas fonctionner comme un point d'accès.

Si votre appareil se connecte à votre réseau via l'interface sans fil, pourquoi avez-vous un câble Ethernet connecté à votre réseau local?

Je ne vois pas où vous notez vos serveurs DNS. Cela peut être la raison pour laquelle l'appareil ne peut pas «accéder» à Internet pour obtenir des paquets d'Opkg. Vous pouvez vérifier pour voir ce que le contenu de /etc/resolv.conf est, car il répertorie quels serveurs de noms le périphérique utilise pour la résolution de noms DNS.

Un exemple (utilisant les serveurs de noms de Google):

nameserver 8.8.8.8
nameserver 4.4.4.4

Vous pouvez également essayer d'ajouter les éléments suivants à /etc/config/network:

option dns 8.8.8.8 

J'espère que cela t'aides...

MODIFIER

Voici une configuration suggérée pour l'interface wifi pour l'utiliser comme point d'accès:

config wifi-iface
    option device     radio0
    option network    lan
    option mode       ap
    option ssid       'DESIRED SSID HERE'
    option encryption wep+shared
    option key        'YOUR WEP PASSWORD FOR ACCESS'

Tu veux network mis à lan et mode mis à ap. Je recommande fortement une forme de cryptage et suggérerais que vous utilisiez autre chose que le WEP, car il est peu sûr.


1
2017-12-20 20:20



Merci. Le conseil DNS nous a permis d'accéder à Internet afin de pouvoir télécharger opkg et l'interface utilisateur du navigateur, ce qui nous a permis de configurer le reste des paramètres. Malheureusement, même si nous pouvons maintenant voir le routeur via le wifi, il ne semble toujours pas nous permettre de nous connecter avec le wifi. - interstar
actuellement: config wifi-device 'radio0' option type 'mac80211' option channel '11' option hwmode '11ng' option chemin 'platform / ar933x_wmac' option htmode 'HT20' liste ht_capab 'SHORT-GI-20' list ht_capab 'SHORT- GI-40 'liste ht_capab' RX-STBC1 'liste ht_capab' DSSS_CCK-40 'option txpower' 27 'pays d'option' GB 'option configuration wifi-iface périphérique' radio0 'clé d'option' KEY 'option ssid' réseau 'option réseau' wan 'option cryptage' option 'mode de mode' ap ' - interstar
Quelque chose dans la liste ci-dessus semble étrange? - interstar
@interstar Voir la réponse mise à jour. - Justin Pearce
Merci beaucoup Justin. Je vais essayer ça bientôt. - interstar