Question Correction de la dépendance de libboost-dev


J'ai besoin d'installer fcl qui dépend de libboost-dev. Cependant, libboost-dev dépend de libboost1.46-dev et refuse d'installer car j'ai le plus récent libboost1.48-dev.

J'ai suivi les instructions dans la réponse à cette question: apt et correction des dépendances incorect. Cependant, je suis incapable de courir debuild -uc -us avec succès. Ceci est la sortie:

 dpkg-buildpackage -rfakeroot -D -us -uc
dpkg-buildpackage: exporte les CFLAGS depuis dpkg-buildflags (origine: vendeur): -g -O2 -fstack-protector --param = ssp-buffer-size = 4 -Wformat -Wformat-security
dpkg-buildpackage: exporte CPPFLAGS depuis dpkg-buildflags (origine: vendor): -D_FORTIFY_SOURCE = 2
dpkg-buildpackage: exporte CXXFLAGS depuis dpkg-buildflags (origine: vendeur): -g -O2 -fstack-protector --param = ssp-buffer-size = 4 -Wformat -Wformat-security
dpkg-buildpackage: exporte des FFLAGS depuis dpkg-buildflags (origine: fournisseur): -g -O2
dpkg-buildpackage: export LDFLAGS à partir de dpkg-buildflags (origine: vendeur): -Wl, -Bsymbolic-functions -Wl, -z, relro
dpkg-buildpackage: valeurs par défaut du paquet source
dpkg-buildpackage: version source 1.48.0.2
dpkg-buildpackage: source modifiée par Steve M. Robbins
 dpkg-source --before-build boost-defaults-1.48.0.2
dpkg-buildpackage: architecture hôte amd64
dpkg-checkbuilddeps: Dépendances de construction non satisfaites: libboost1.48-dev (> = 1.48.1)
dpkg-buildpackage: avertissement: créer des dépendances / conflits insatisfaits; avorter.
dpkg-buildpackage: avertissement: (Utilisez l'option -d pour le remplacer.)
debuild: erreur fatale à la ligne 1350:
dpkg-buildpackage -rfakeroot -D -us -uc a échoué

J'ai actuellement libboost1.48-dev installé et d'autres paquets de 1,48 boost.

Ce lien montre la source de l'erreur libboost-dev: http://www.ubuntuupdates.org/package/core/precise/main/base/libboost-dev

Que puis-je faire pour résoudre ce problème?

Modifier: Après avoir vérifié les dépendances, j'ai réalisé que je pouvais désinstaller libboost1.48-dev et utilise libboost1.46-dev au lieu.

J'ai accepté la réponse de terdon car je pense que c'est toujours une information utile.


2
2018-01-21 20:23


origine


Êtes-vous sûr d'avoir la bonne version? Il se plaint de libboost1.48-dev (>= 1.48.1) et boost-defaults semble être 1.48.0.2. - terdon
@terdon Synaptic dit que j'ai libboost1.48-dev version 1.48.0-3 - ehuang
Eh bien, l'erreur que vous obtenez demande une version plus récente. Ça veut >= 1.48.1 et tu as 1.48.0-3. 1.48.0-3 < 1.48.1 - terdon
@terdon Synaptic a seulement la version 1.48.0-3. Savez-vous comment passer à une version ultérieure? Aussi, la solution dans superuser.com/questions/388428/… potentiellement empoisonner mes dépendances apt-get. - ehuang


Réponses:


La solution que vous avez liée ne doit affecter que le package que vous reconstruisez. Au moins, il n'y a pas de modifications à l'échelle du système ou de modifications à /etc/apt/sources.list.

En ce qui concerne le dernier stable libboost, il semble être 1.5.2.0. Vous pouvez le télécharger (ou une version légèrement plus ancienne pour être plus proche de ce que vous avez installé) à partir de la source de boost page de téléchargement et compiler à partir des sources.

Alternativement, vous pouvez recherche packages.debian.org où vous pouvez trouver un .deb pour 1.49.0.1. En fonction des dépendances (sans jeu de mots), vous pourrez l’installer avec ou sans apt épinglant.


1
2018-01-21 20:46