Question Arrêtez l'affichage des fichiers PDF dans Google Chrome


Lorsque je clique sur un lien PDF dans Chrome, celui-ci s'ouvre automatiquement dans la fenêtre du navigateur. Comment puis-je le télécharger et l'ouvrir avec un lecteur externe?

Mettre à jour: J'ai implémenté la solution de djhowell mais Chrome semble toujours gérer les fichiers PDF différemment des fichiers ordinaires. Lorsque je clique sur un lien PDF, celui-ci s'ouvre dans Adobe Reader, mais normalement, les fichiers sont d'abord téléchargés dans un dossier.

Je trouve également étrange que cela soit contrôlé par Reader et non par Chrome. N'y a-t-il pas de contrôles de type fichier dans Chrome?


75
2017-08-27 17:15


origine


J'ai vérifié aussi, il semble que Chrome a tendance à choisir quoi faire avec des fichiers pour vous ... Je suis en fait surpris qu'il n'y ait pas "association de fichiers" à trouver, pour choisir le programme / plugin à utiliser pour une extension particulière . - Gnoupi
Je trouve même de tels sujets dans le groupe Google pour Chrome: groups.google.com/group/chrome-google/browse_thread/thread/ ... , les gens qui voudraient passer à un autre téléspectateur, et ne peuvent pas .. Pas de réponse .. - Gnoupi
Ajout d'une mise à jour mais les conversations dans les forums de support Chrome ne semblent pas encourageantes. - djhowell
S'il vous plaît examiner ma réponse, je pense que cela couvre vos besoins un peu mieux, si oui, vous devriez changer votre sélection du bon - Rafareino


Réponses:


Vous pouvez désactiver le plug-in Adobe dans Chrome, ce qui forcera Chrome à télécharger le PDF.

Il se trouve sous Paramètres> Confidentialité et sécurité> Paramètres de contenu> Documents PDF. Ou entrez chrome://settings/content/pdfDocuments dans la barre d'adresse de votre navigateur pour y aller directement.


71
2017-07-08 20:02



C'est la bonne réponse! - nickd
un moyen probablement plus rapide de faire la même chose: aller sur chrome: // plugins (dans firefox, ce serait sur: plugins), et désactiver le plugin acrobat reader - Babu
Comme je l'ai mentionné dans ma réponse, Adobe Reader n'est plus installé mais cela semble être la meilleure solution pour ceux qui le font. - DisgruntledGoat
En version 12 de Chrome, je vois Chrome PDF Viewer répertorié comme un plugin. Désactiver cela fait ce qui est demandé, télécharge le pdf dans un fichier. - KeithB
le chrome://plugins La page n'est plus disponible dans Chrome. - Royi


parcourir pour chrome: // plugins et désactiver Chrome PDF Viewer


12
2017-11-11 13:08



Cela semble être la seule réponse qui résout le problème "Mise à jour" de DisgruntledGoats (à part la réponse identique de Doug postée un jour après celle-ci). C'est certainement celui qui m'a aidé! - Fred Hamilton
Cela a fonctionné pour moi. Merci! - Tim Perry


Utilisez-vous Adobe Acrobat / Adobe Reader pour afficher les PDF? Si tel est le cas, il faut probablement modifier le comportement d'Abode.

Voici les étapes à suivre:

  1. Ouvrir Adobe Reader
  2. Menu Edition, Préférences
  3. Selcet l'Internet de la liste des catégories
  4. Décocher Afficher le PDF dans le navigateur
  5. appuyer sur OK

Si vous utilisez une autre application pour afficher les PDF, les étapes sont probablement similaires.

Re: mise à jour

Par hasard, Adobe Reader et Adobe Acrobat sont-ils installés? Vous devrez peut-être répéter les étapes ci-dessus dans l'autre application.

Chrome est un peu bizarre dans la mesure où son comportement par défaut consiste à tout télécharger et à l’ouvrir. Lorsque vous cliquez sur un lien PDF, voyez-vous le nom du fichier dans la "barre de téléchargement" en bas de la fenêtre? Si c'est le cas, essayez de cliquer dessus avec le bouton droit de la souris et décochez la case "Toujours ouvrir les fichiers de ce type" si elle est cochée.


8
2017-08-27 17:36



m'a battu par 50 secondes, CG :)
Merci pour la réponse mais cela n'a pas fonctionné à 100%, voir la mise à jour. - DisgruntledGoat
le problème du téléchargement du fichier dans un dossier local semble d'abord lié à ce sujet: superuser.com/questions/30823/
Pour répondre à votre mise à jour: Non, je ne vois pas le fichier dans la barre de téléchargement, le PDF s'ouvre simplement lorsque je clique dessus. Le comportement que vous décrivez est ce que je vouloir pour voir, c’est-à-dire le même que tous les autres fichiers. - DisgruntledGoat


Dans Google Chrome: ouvrez un nouvel onglet, accédez à: plugins et désactivez "Chrome PDF Viewer". Cela semble avoir fait le tour pour moi.


7
2017-09-28 14:40





Sorte de trié ceci; J'ai désinstallé Adobe Reader et installé SumatraPDF à la place! Application bien meilleure et légère.


4
2017-09-28 19:54





Une autre option est que Chrome, au lieu de télécharger des PDF, les lance dans le lecteur PDF défini par le système.

La manière de l'arrêter se trouve dans les paramètres de contenu dans les paramètres de Chrome:

enter image description here


4
2018-02-02 16:17





cela dépend de votre lecteur PDF par défaut, pour Adobe essayez ceci:

Modifier> Préférences> Internet

effacer la boîte Afficher le PDF dans le navigateur


2
2017-08-27 17:37





Que diriez-vous d'appuyer sur CTRL + S et d'enregistrer le fichier après l'avoir ouvert? Fonctionne bien si vous ne voulez pas télécharger beaucoup de fichiers PDF


1
2018-01-09 10:25



C'est une vieille question et je ne pense pas que cela ait fonctionné à l'époque. Le seul problème de votre solution est que (selon mon expérience) les gros fichiers PDF sont longs à charger dans le navigateur (téléchargement non compris) et parfois ne fonctionnent pas. - DisgruntledGoat
cela ne semble toujours pas fonctionner, par exemple, si le PDF est protégé par un mot de passe - cnst
Cela ne fonctionnera pas si le pdf n'est pas utilisé comme une ressource statique, mais plutôt par un autre type de requête. Ensuite, chrome indiquera "fichier introuvable" lorsque vous essayez de sauvegarder. Au lieu de cela, vous pouvez choisir de l’imprimer et, dans la boîte de dialogue d’impression, choisissez Enregistrer sous format pdf, mais cela est très encombrant et peu intuitif. - Superole